aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-01-27 08:38:14 +0800
committeryuri <yuri@FreeBSD.org>2018-01-27 08:38:14 +0800
commit0d80c9bdad12c62c31aef0af9bcfd907aec200c4 (patch)
tree9faee8694a10cffc45250af5f6c6dd83c0695263
parent5d8b2a30a60babfc45fbc2f98eed63ff7c5a2897 (diff)
downloadfreebsd-ports-gnome-0d80c9bdad12c62c31aef0af9bcfd907aec200c4.tar.gz
freebsd-ports-gnome-0d80c9bdad12c62c31aef0af9bcfd907aec200c4.tar.zst
freebsd-ports-gnome-0d80c9bdad12c62c31aef0af9bcfd907aec200c4.zip
New port: devel/py-QtPy: Abstraction layer on top of the various Qt bindings
This is an abstraction layer on top of the various Qt bindings. It doesn't have any explicit dependencies. It has alternative dependencies on PyQt5, PyQt4, PySide2 or PySide which it selects in the run-time. Users have the responsibility to ensure that one of them is installed, and to optionally set QT_API to force one of them. Approved by: tcberner (mentor) Differential Revision: D13657
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-QtPy/Makefile19
-rw-r--r--devel/py-QtPy/distinfo3
-rw-r--r--devel/py-QtPy/pkg-descr10
-rw-r--r--devel/py-QtPy/pkg-message10
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 137dfaf3413f..7a5300717a43 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4199,6 +4199,7 @@
SUBDIR += py-PyExecJS
SUBDIR += py-PyLD
SUBDIR += py-PyODE
+ SUBDIR += py-QtPy
SUBDIR += py-RPyC
SUBDIR += py-Record
SUBDIR += py-SymbolType
diff --git a/devel/py-QtPy/Makefile b/devel/py-QtPy/Makefile
new file mode 100644
index 000000000000..8ab8126a8c3e
--- /dev/null
+++ b/devel/py-QtPy/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= QtPy
+DISTVERSION= 1.3.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Abstraction layer on top of the various Qt bindings
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-QtPy/distinfo b/devel/py-QtPy/distinfo
new file mode 100644
index 000000000000..d027583b291e
--- /dev/null
+++ b/devel/py-QtPy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1514403575
+SHA256 (QtPy-1.3.1.tar.gz) = 08af2525d59f9eb639946d5ed7a72b002103c5b7369c0ef0dd70ad2696845313
+SIZE (QtPy-1.3.1.tar.gz) = 25061
diff --git a/devel/py-QtPy/pkg-descr b/devel/py-QtPy/pkg-descr
new file mode 100644
index 000000000000..275c24512584
--- /dev/null
+++ b/devel/py-QtPy/pkg-descr
@@ -0,0 +1,10 @@
+QtPy is a small abstraction layer that lets you write applications using a
+single API call to either PyQt or PySide.
+
+It provides support for PyQt5, PyQt4, PySide2 and PySide using the Qt5 layout
+(where the QtGui module has been split into QtGui and QtWidgets).
+
+Basically, you write your code as if you were using PySide2 but import Qt
+modules from qtpy instead of PySide2 (or PyQt5)
+
+WWW: https://github.com/spyder-ide/qtpy
diff --git a/devel/py-QtPy/pkg-message b/devel/py-QtPy/pkg-message
new file mode 100644
index 000000000000..099d4512ca23
--- /dev/null
+++ b/devel/py-QtPy/pkg-message
@@ -0,0 +1,10 @@
+======================================================================
+You installed py-QtPy: the abstraction layer on top of Qt bindings.
+
+One of PyQt5, PyQt4, PySide2 or PySide bindings is required to be
+installed for it to work. py-QtPy will choose between the avaiable
+bindings, PyQt5 will be chosen first when available.
+
+The QT_API environment variable can be used to force a particular
+binding.
+======================================================================