aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-10-25 01:09:00 +0800
committerjeh <jeh@FreeBSD.org>2000-10-25 01:09:00 +0800
commit0d8ac6b59e3535d5e4d0a455daf890edffdd10f4 (patch)
treee58505db5e8b7eb0acebdb8450761d4b09cf0ce0
parent0349de2ce0a7a0bc13c8ea3fff589444e4471d63 (diff)
downloadfreebsd-ports-gnome-0d8ac6b59e3535d5e4d0a455daf890edffdd10f4.tar.gz
freebsd-ports-gnome-0d8ac6b59e3535d5e4d0a455daf890edffdd10f4.tar.zst
freebsd-ports-gnome-0d8ac6b59e3535d5e4d0a455daf890edffdd10f4.zip
bento doesn't have a real working apxs. Use these unil bsd.apache.mk
is created. Submitted by: bento
-rw-r--r--www/apache-contrib/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/www/apache-contrib/Makefile b/www/apache-contrib/Makefile
index 2c8a8b45fb9e..4f7004c1a3d4 100644
--- a/www/apache-contrib/Makefile
+++ b/www/apache-contrib/Makefile
@@ -30,6 +30,24 @@ MAINTAINER= anders@fix.no
BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-ALL_TARGET= APXS=${LOCALBASE}/sbin/apxs all
+APXS= ${LOCALBASE}/sbin/apxs
+
+AP_PORT?= apache13
+.if exists(${APXS})
+APXS_WORKS!= ${APXS} -q TARGET 2>/dev/null || echo no
+.endif
+.if exists(${APXS}) && ${APXS_WORKS} != no
+AP_TARGET!= ${APXS} -q TARGET
+AP_SYSCONF!= ${APXS} -q SYSCONFDIR
+AP_INCLUDE!= ${APXS} -q INCLUDEDIR
+AP_LIBEXEC!= ${APXS} -q LIBEXECDIR
+.else
+AP_TARGET?= httpd
+AP_SYSCONF?= ${PREFIX}/etc/apache
+AP_INCLUDE?= ${PREFIX}/include/apache
+AP_LIBEXEC?= ${PREFIX}/libexec/apache
+.endif
+
+ALL_TARGET= APXS=${APXS}/sbin/apxs all
.include <bsd.port.mk>