aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-08-06 18:48:23 +0800
committermiwi <miwi@FreeBSD.org>2008-08-06 18:48:23 +0800
commit0ddcf21ded3ba8f61e48afed5b03961db5a3db3a (patch)
treec40c68ed3ca30787687c68dafb407ee9897ac237
parent4f0a593b0dcd00034ac1221a7f8b265222f6439e (diff)
downloadfreebsd-ports-gnome-0ddcf21ded3ba8f61e48afed5b03961db5a3db3a.tar.gz
freebsd-ports-gnome-0ddcf21ded3ba8f61e48afed5b03961db5a3db3a.tar.zst
freebsd-ports-gnome-0ddcf21ded3ba8f61e48afed5b03961db5a3db3a.zip
Gmm++ is a generic C++ template library for sparse, dense and skyline
matrices. It is built as a set of generic algorithms (mult, add, copy, sub-matrices, dense and sparse solvers ...) for any interfaced vector type or matrix type. It can be view as a glue library allowing cooperation between several vector and matrix types. However, basic sparse, dense and skyline matrix/vector types are built in Gmm++, hence it can be used as a standalone linear algebra library. Interfacing a vector or matrix type means writing "traits" objects called "linalg_traits", which describe their properties. The library offers predefined dense, sparse and skyline matrix types. WWW: http://home.gna.org/getfem/
-rw-r--r--math/Makefile1
-rw-r--r--math/gmm++/Makefile19
-rw-r--r--math/gmm++/distinfo3
-rw-r--r--math/gmm++/pkg-descr12
-rw-r--r--math/gmm++/pkg-plist55
5 files changed, 90 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 7d1c090a69e6..63a3b59e4ed9 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -88,6 +88,7 @@
SUBDIR += gexpr
SUBDIR += glgraph
SUBDIR += glpk
+ SUBDIR += gmm++
SUBDIR += gmp-ecm
SUBDIR += gnumeric
SUBDIR += gnuplot
diff --git a/math/gmm++/Makefile b/math/gmm++/Makefile
new file mode 100644
index 000000000000..8a3b0454f021
--- /dev/null
+++ b/math/gmm++/Makefile
@@ -0,0 +1,19 @@
+# New ports collection makefile for: gmm++
+# Date created: 2008-07-23
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmm++
+PORTVERSION= 3.0.4
+CATEGORIES= math
+MASTER_SITES= http://download.gna.org/getfem/stable/
+DISTNAME= ${PORTNAME:S/+//g}-${PORTVERSION}
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= A generic matrix template library
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/math/gmm++/distinfo b/math/gmm++/distinfo
new file mode 100644
index 000000000000..0da7976e2e47
--- /dev/null
+++ b/math/gmm++/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmm-3.0.4.tar.gz) = 677b6f08012235f956e9d83fb855b96e
+SHA256 (gmm-3.0.4.tar.gz) = 6ecae1d1bcf513c9cdedb6ae5979b9af8af90d5961383fbfa3a78ad938b96d46
+SIZE (gmm-3.0.4.tar.gz) = 463087
diff --git a/math/gmm++/pkg-descr b/math/gmm++/pkg-descr
new file mode 100644
index 000000000000..1b74ee0f381e
--- /dev/null
+++ b/math/gmm++/pkg-descr
@@ -0,0 +1,12 @@
+Gmm++ is a generic C++ template library for sparse, dense and skyline
+matrices. It is built as a set of generic algorithms (mult, add,
+copy, sub-matrices, dense and sparse solvers ...) for any interfaced
+vector type or matrix type. It can be view as a glue library allowing
+cooperation between several vector and matrix types. However, basic
+sparse, dense and skyline matrix/vector types are built in Gmm++,
+hence it can be used as a standalone linear algebra library.
+Interfacing a vector or matrix type means writing "traits" objects
+called "linalg_traits", which describe their properties. The library
+offers predefined dense, sparse and skyline matrix types.
+
+WWW: http://home.gna.org/getfem/
diff --git a/math/gmm++/pkg-plist b/math/gmm++/pkg-plist
new file mode 100644
index 000000000000..bade4c56fc7a
--- /dev/null
+++ b/math/gmm++/pkg-plist
@@ -0,0 +1,55 @@
+include/gmm/gmm.h
+include/gmm/gmm_MUMPS_interface.h
+include/gmm/gmm_algobase.h
+include/gmm/gmm_blas.h
+include/gmm/gmm_blas_interface.h
+include/gmm/gmm_condition_number.h
+include/gmm/gmm_conjugated.h
+include/gmm/gmm_def.h
+include/gmm/gmm_dense_Householder.h
+include/gmm/gmm_dense_lu.h
+include/gmm/gmm_dense_qr.h
+include/gmm/gmm_dense_sylvester.h
+include/gmm/gmm_domain_decomp.h
+include/gmm/gmm_except.h
+include/gmm/gmm_inoutput.h
+include/gmm/gmm_interface.h
+include/gmm/gmm_interface_bgeot.h
+include/gmm/gmm_iter.h
+include/gmm/gmm_iter_solvers.h
+include/gmm/gmm_kernel.h
+include/gmm/gmm_lapack_interface.h
+include/gmm/gmm_least_squares_cg.h
+include/gmm/gmm_matrix.h
+include/gmm/gmm_modified_gram_schmidt.h
+include/gmm/gmm_opt.h
+include/gmm/gmm_precond.h
+include/gmm/gmm_precond_diagonal.h
+include/gmm/gmm_precond_ildlt.h
+include/gmm/gmm_precond_ildltt.h
+include/gmm/gmm_precond_ilu.h
+include/gmm/gmm_precond_ilut.h
+include/gmm/gmm_precond_ilutp.h
+include/gmm/gmm_precond_mr_approx_inverse.h
+include/gmm/gmm_real_part.h
+include/gmm/gmm_ref.h
+include/gmm/gmm_scaled.h
+include/gmm/gmm_solver_Newton.h
+include/gmm/gmm_solver_Schwarz_additive.h
+include/gmm/gmm_solver_bfgs.h
+include/gmm/gmm_solver_bicgstab.h
+include/gmm/gmm_solver_cg.h
+include/gmm/gmm_solver_constrained_cg.h
+include/gmm/gmm_solver_gmres.h
+include/gmm/gmm_solver_idgmres.h
+include/gmm/gmm_solver_qmr.h
+include/gmm/gmm_std.h
+include/gmm/gmm_sub_index.h
+include/gmm/gmm_sub_matrix.h
+include/gmm/gmm_sub_vector.h
+include/gmm/gmm_superlu_interface.h
+include/gmm/gmm_transposed.h
+include/gmm/gmm_tri_solve.h
+include/gmm/gmm_vector.h
+include/gmm/gmm_vector_to_matrix.h
+@dirrm include/gmm