aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2012-05-26 23:41:00 +0800
committerkuriyama <kuriyama@FreeBSD.org>2012-05-26 23:41:00 +0800
commit0de2bb9f6b038f73778338a22df9f71ad88b5a04 (patch)
treee66a1ea203e4fa61e597484e5dd95ea5a9530ca4
parent672bf296d6fa2f6228a2ac49ac070d53e53cc518 (diff)
downloadfreebsd-ports-gnome-0de2bb9f6b038f73778338a22df9f71ad88b5a04.tar.gz
freebsd-ports-gnome-0de2bb9f6b038f73778338a22df9f71ad88b5a04.tar.zst
freebsd-ports-gnome-0de2bb9f6b038f73778338a22df9f71ad88b5a04.zip
This module is a stupid hack to make the default File::Spec behavior
available from a subclass. This can be useful when using another module that expects a subclass of File::Spec but you want to use the current, native OS format (automatically detected by File::Spec). WWW: http://search.cpan.org/dist/File-Spec-Native/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Spec-Native/Makefile21
-rw-r--r--devel/p5-File-Spec-Native/distinfo2
-rw-r--r--devel/p5-File-Spec-Native/pkg-descr6
-rw-r--r--devel/p5-File-Spec-Native/pkg-plist7
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4ee1a7f01027..06f75f886926 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1841,6 +1841,7 @@
SUBDIR += p5-File-ShareDir-ProjectDistDir
SUBDIR += p5-File-Slurp
SUBDIR += p5-File-Slurp-Tree
+ SUBDIR += p5-File-Spec-Native
SUBDIR += p5-File-Stream
SUBDIR += p5-File-Sync
SUBDIR += p5-File-Tail
diff --git a/devel/p5-File-Spec-Native/Makefile b/devel/p5-File-Spec-Native/Makefile
new file mode 100644
index 000000000000..42f5efdbf2e8
--- /dev/null
+++ b/devel/p5-File-Spec-Native/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: File::Spec::Native
+# Date created: 27 May 2012
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Spec-Native
+PORTVERSION= 1.003
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for native OS implementation of File::Spec
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Spec::Native.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Spec-Native/distinfo b/devel/p5-File-Spec-Native/distinfo
new file mode 100644
index 000000000000..6c245926cbfa
--- /dev/null
+++ b/devel/p5-File-Spec-Native/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-Spec-Native-1.003.tar.gz) = bbb22c53d8cfdd3389f0b4bcf90077847347ef851d297026352eb9e5bb218156
+SIZE (File-Spec-Native-1.003.tar.gz) = 15799
diff --git a/devel/p5-File-Spec-Native/pkg-descr b/devel/p5-File-Spec-Native/pkg-descr
new file mode 100644
index 000000000000..228a5b8964ad
--- /dev/null
+++ b/devel/p5-File-Spec-Native/pkg-descr
@@ -0,0 +1,6 @@
+This module is a stupid hack to make the default File::Spec behavior
+available from a subclass. This can be useful when using another
+module that expects a subclass of File::Spec but you want to use the
+current, native OS format (automatically detected by File::Spec).
+
+WWW: http://search.cpan.org/dist/File-Spec-Native/
diff --git a/devel/p5-File-Spec-Native/pkg-plist b/devel/p5-File-Spec-Native/pkg-plist
new file mode 100644
index 000000000000..9beda32b2c07
--- /dev/null
+++ b/devel/p5-File-Spec-Native/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Spec/Native/.packlist
+%%SITE_PERL%%/File/Spec/Native.pm
+@dirrmtry %%SITE_PERL%%/File/Spec
+@dirrmtry %%SITE_PERL%%/File
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Spec/Native
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Spec
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File