aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordes <des@FreeBSD.org>2002-07-01 21:03:07 +0800
committerdes <des@FreeBSD.org>2002-07-01 21:03:07 +0800
commit0dfd5a2cce9771ae0cc2f506b6f76ebfcd6fc3ef (patch)
treeb0172287e535c993e7cdac169f25a5fc54b39d00
parentcb6b0c43c7e0ce02e2d21b6ff2e79f04490c4b56 (diff)
downloadfreebsd-ports-gnome-0dfd5a2cce9771ae0cc2f506b6f76ebfcd6fc3ef.tar.gz
freebsd-ports-gnome-0dfd5a2cce9771ae0cc2f506b6f76ebfcd6fc3ef.tar.zst
freebsd-ports-gnome-0dfd5a2cce9771ae0cc2f506b6f76ebfcd6fc3ef.zip
Use a patch rather than sed magic for the <sys/soundcard.h> issue.
-rw-r--r--audio/mpg123/Makefile5
-rw-r--r--audio/mpg123/files/patch-af11
2 files changed, 11 insertions, 5 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index 8242f712bcf4..c9254390d5e0 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -99,9 +99,4 @@ OPT_ARCH?= i586
MAKE_ARGS+= OPT_ARCH=${OPT_ARCH}
.endif
-post-patch:
- @${SED} -e 's,machine/soundcard.h,sys/soundcard.h,' < \
- ${WRKSRC}/audio_oss.c > ${WRKSRC}/audio_oss.c.new
- @${MV} ${WRKSRC}/audio_oss.c.new ${WRKSRC}/audio_oss.c
-
.include <bsd.port.post.mk>
diff --git a/audio/mpg123/files/patch-af b/audio/mpg123/files/patch-af
new file mode 100644
index 000000000000..36f059cfb493
--- /dev/null
+++ b/audio/mpg123/files/patch-af
@@ -0,0 +1,11 @@
+--- audio_oss.c.orig Sat Jan 31 23:14:08 1998
++++ audio_oss.c Sun May 12 15:35:49 2002
+@@ -31,7 +31,7 @@
+ #elif defined(__bsdi__)
+ #include <sys/soundcard.h>
+ #else
+-#include <machine/soundcard.h>
++#include <sys/soundcard.h>
+ #endif
+
+ int audio_open(struct audio_info_struct *ai)