aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-05 22:18:32 +0800
committervs <vs@FreeBSD.org>2005-10-05 22:18:32 +0800
commit117ca5f5a175d3f502d5a877725f6a4d7fd14ed5 (patch)
tree40cc88cfb1e09ed8f302fd3fc9c21a28443651fb
parent02e434b247601f57e3f152274b8b6f6224b27b99 (diff)
downloadfreebsd-ports-gnome-117ca5f5a175d3f502d5a877725f6a4d7fd14ed5.tar.gz
freebsd-ports-gnome-117ca5f5a175d3f502d5a877725f6a4d7fd14ed5.tar.zst
freebsd-ports-gnome-117ca5f5a175d3f502d5a877725f6a4d7fd14ed5.zip
Use less patches by virtue of MAKE_ARGS and USE_LIBTOOL.
USE_GCC=3.3+ and nuke static lib while here.
-rw-r--r--devel/zthread/Makefile10
-rw-r--r--devel/zthread/files/patch-aa11
-rw-r--r--devel/zthread/files/patch-ltmain.sh15
-rw-r--r--devel/zthread/pkg-plist1
4 files changed, 8 insertions, 29 deletions
diff --git a/devel/zthread/Makefile b/devel/zthread/Makefile
index cc3fefba2589..1411195c7fff 100644
--- a/devel/zthread/Makefile
+++ b/devel/zthread/Makefile
@@ -15,9 +15,12 @@ DISTNAME= ZThread-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= A platform-independent object-oriented C++ threading library
+USE_INC_LIBTOOL_VER=15
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --without-ftime
+CONFIGURE_ARGS= --without-ftime --disable-static
USE_GMAKE= yes
+MAKE_ARGS+= INSTALL_PROGRAM="${INSTALL_SCRIPT}"
+MAKE_ENV+= SED=sed # req'd for LIBTOOL?!
INSTALLS_SHLIB= yes
.if !defined(NOPORTDOCS)
@@ -27,12 +30,15 @@ PORTDOCS= *
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-USE_GCC= 3.3
+USE_GCC= 3.3+
.endif
post-extract:
@${FIND} ${WRKSRC} -name CVS -type d -delete
+post-patch:
+ @${CP} ${LTMAIN} ${WRKSRC}
+
post-install:
@${FIND} ${PREFIX}/include/zthread -type f | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
diff --git a/devel/zthread/files/patch-aa b/devel/zthread/files/patch-aa
deleted file mode 100644
index 82746b033729..000000000000
--- a/devel/zthread/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig Fri Aug 31 15:12:28 2001
-+++ Makefile.in Wed Nov 14 16:04:12 2001
-@@ -382,7 +382,7 @@
-
- install-exec-hook:
- $(mkinstalldirs) $(bindir)
-- $(INSTALL_PROGRAM) $(top_srcdir)/share/zthread-config $(bindir)
-+ $(INSTALL_SCRIPT) $(top_srcdir)/share/zthread-config $(bindir)
-
- install-data-hook:
- $(mkinstalldirs) $(datadir)/aclocal
diff --git a/devel/zthread/files/patch-ltmain.sh b/devel/zthread/files/patch-ltmain.sh
deleted file mode 100644
index 0e4f1ce2927b..000000000000
--- a/devel/zthread/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Thu Apr 1 11:53:22 2004
-+++ ltmain.sh Thu Apr 1 11:53:33 2004
-@@ -4210,10 +4210,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false ; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/zthread/pkg-plist b/devel/zthread/pkg-plist
index a3f6953629c1..536cfdb9ea93 100644
--- a/devel/zthread/pkg-plist
+++ b/devel/zthread/pkg-plist
@@ -1,7 +1,6 @@
bin/zthread-config
lib/libZThread-2.3.so
lib/libZThread-2.3.so.1
-lib/libZThread.a
lib/libZThread.so
share/aclocal/pthread.m4
share/aclocal/zthread.m4