aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclement <clement@FreeBSD.org>2004-10-31 03:44:41 +0800
committerclement <clement@FreeBSD.org>2004-10-31 03:44:41 +0800
commit13d57bdd123620897f69fe5f202066f5907bfdf4 (patch)
tree528c2d86bec882261a8178247b86aa7e122db128
parentf5d155d1b93db4504e5f31f28fcf9f90bd4c288d (diff)
downloadfreebsd-ports-gnome-13d57bdd123620897f69fe5f202066f5907bfdf4.tar.gz
freebsd-ports-gnome-13d57bdd123620897f69fe5f202066f5907bfdf4.tar.zst
freebsd-ports-gnome-13d57bdd123620897f69fe5f202066f5907bfdf4.zip
- Fix apache2 build, I hope...
Noticed by: many Committed from: EuroBSDcon Hotel's bar. Pointy hat to: me Under supervision from: mat, thierry, erwin (former mentor)
-rw-r--r--www/apache2/Makefile4
-rw-r--r--www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c98
-rw-r--r--www/apache20/Makefile4
-rw-r--r--www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c98
4 files changed, 100 insertions, 104 deletions
diff --git a/www/apache2/Makefile b/www/apache2/Makefile
index 63695e3a274b..88e67e75220e 100644
--- a/www/apache2/Makefile
+++ b/www/apache2/Makefile
@@ -45,8 +45,8 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4 \
AUTOHEADER=${AUTOHEADER}
USE_ICONV= yes
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
+#USE_AUTOCONF_VER= 259
+#USE_LIBTOOL_VER= 15
USE_PERL5= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
diff --git a/www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c b/www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c
index e2df23d4921f..8a8749ebbc0f 100644
--- a/www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c
+++ b/www/apache2/files/patch-modules:experimental:util_ldap_cache_mgr.c
@@ -1,50 +1,48 @@
-Index: modules/experimental/util_ldap_cache_mgr.c
-===================================================================
-RCS file: /home/cvs/httpd-2.0/modules/experimental/Attic/util_ldap_cache_mgr.c,v
-retrieving revision 1.3.2.13
-diff -u -r1.3.2.13 util_ldap_cache_mgr.c
---- modules/experimental/util_ldap_cache_mgr.c 23 Sep 2004 16:55:37 -0000 1.3.2.13
-+++ modules/experimental/util_ldap_cache_mgr.c 24 Sep 2004 16:40:23 -0000
-@@ -173,7 +173,7 @@
- void util_ald_cache_purge(util_ald_cache_t *cache)
- {
- unsigned long i;
-- util_cache_node_t *p, *q;
-+ util_cache_node_t *p, *q, **pp;
- apr_time_t t;
-
- if (!cache)
-@@ -184,7 +184,8 @@
- cache->numpurges++;
-
- for (i=0; i < cache->size; ++i) {
-- p = cache->nodes[i];
-+ pp = cache->nodes + i;
-+ p = *pp;
- while (p != NULL) {
- if (p->add_time < cache->marktime) {
- q = p->next;
-@@ -192,10 +193,11 @@
- util_ald_free(cache, p);
- cache->numentries--;
- cache->npurged++;
-- p = q;
-+ p = *pp = q;
- }
- else {
-- p = p->next;
-+ pp = &(p->next);
-+ p = *pp;
- }
- }
- }
-@@ -687,6 +689,9 @@
- break;
- }
-
-+ }
-+ else {
-+ buf = "";
- }
- }
- else {
+--- modules/experimental/util_ldap_cache_mgr.c.orig Thu Sep 23 18:55:37 2004
++++ modules/experimental/util_ldap_cache_mgr.c Sat Oct 30 21:37:48 2004
+@@ -173,7 +173,7 @@
+ void util_ald_cache_purge(util_ald_cache_t *cache)
+ {
+ unsigned long i;
+- util_cache_node_t *p, *q;
++ util_cache_node_t *p, *q, *pp;
+ apr_time_t t;
+
+ if (!cache)
+@@ -184,7 +184,8 @@
+ cache->numpurges++;
+
+ for (i=0; i < cache->size; ++i) {
+- p = cache->nodes[i];
++ p = cache->nodes + i;
++ p = *pp;
+ while (p != NULL) {
+ if (p->add_time < cache->marktime) {
+ q = p->next;
+@@ -192,11 +193,12 @@
+ util_ald_free(cache, p);
+ cache->numentries--;
+ cache->npurged++;
+- p = q;
++ p = *pp = q;
+ }
+ else {
+- p = p->next;
+- }
++
++ pp = &(p->next);
++ p = *pp; }
+ }
+ }
+
+@@ -686,7 +688,9 @@
+ default:
+ break;
+ }
+-
++ }
++ else {
++ buf = "";
+ }
+ }
+ else {
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index 63695e3a274b..88e67e75220e 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -45,8 +45,8 @@ SCRIPTS_ENV+= LIBTOOL=${LIBTOOL} LIBTOOLIZE=${LIBTOOLIZE} \
LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4 \
AUTOHEADER=${AUTOHEADER}
USE_ICONV= yes
-USE_AUTOCONF_VER= 259
-USE_LIBTOOL_VER= 15
+#USE_AUTOCONF_VER= 259
+#USE_LIBTOOL_VER= 15
USE_PERL5= yes
USE_RC_SUBR= yes
USE_REINPLACE= yes
diff --git a/www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c b/www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c
index e2df23d4921f..8a8749ebbc0f 100644
--- a/www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c
+++ b/www/apache20/files/patch-modules:experimental:util_ldap_cache_mgr.c
@@ -1,50 +1,48 @@
-Index: modules/experimental/util_ldap_cache_mgr.c
-===================================================================
-RCS file: /home/cvs/httpd-2.0/modules/experimental/Attic/util_ldap_cache_mgr.c,v
-retrieving revision 1.3.2.13
-diff -u -r1.3.2.13 util_ldap_cache_mgr.c
---- modules/experimental/util_ldap_cache_mgr.c 23 Sep 2004 16:55:37 -0000 1.3.2.13
-+++ modules/experimental/util_ldap_cache_mgr.c 24 Sep 2004 16:40:23 -0000
-@@ -173,7 +173,7 @@
- void util_ald_cache_purge(util_ald_cache_t *cache)
- {
- unsigned long i;
-- util_cache_node_t *p, *q;
-+ util_cache_node_t *p, *q, **pp;
- apr_time_t t;
-
- if (!cache)
-@@ -184,7 +184,8 @@
- cache->numpurges++;
-
- for (i=0; i < cache->size; ++i) {
-- p = cache->nodes[i];
-+ pp = cache->nodes + i;
-+ p = *pp;
- while (p != NULL) {
- if (p->add_time < cache->marktime) {
- q = p->next;
-@@ -192,10 +193,11 @@
- util_ald_free(cache, p);
- cache->numentries--;
- cache->npurged++;
-- p = q;
-+ p = *pp = q;
- }
- else {
-- p = p->next;
-+ pp = &(p->next);
-+ p = *pp;
- }
- }
- }
-@@ -687,6 +689,9 @@
- break;
- }
-
-+ }
-+ else {
-+ buf = "";
- }
- }
- else {
+--- modules/experimental/util_ldap_cache_mgr.c.orig Thu Sep 23 18:55:37 2004
++++ modules/experimental/util_ldap_cache_mgr.c Sat Oct 30 21:37:48 2004
+@@ -173,7 +173,7 @@
+ void util_ald_cache_purge(util_ald_cache_t *cache)
+ {
+ unsigned long i;
+- util_cache_node_t *p, *q;
++ util_cache_node_t *p, *q, *pp;
+ apr_time_t t;
+
+ if (!cache)
+@@ -184,7 +184,8 @@
+ cache->numpurges++;
+
+ for (i=0; i < cache->size; ++i) {
+- p = cache->nodes[i];
++ p = cache->nodes + i;
++ p = *pp;
+ while (p != NULL) {
+ if (p->add_time < cache->marktime) {
+ q = p->next;
+@@ -192,11 +193,12 @@
+ util_ald_free(cache, p);
+ cache->numentries--;
+ cache->npurged++;
+- p = q;
++ p = *pp = q;
+ }
+ else {
+- p = p->next;
+- }
++
++ pp = &(p->next);
++ p = *pp; }
+ }
+ }
+
+@@ -686,7 +688,9 @@
+ default:
+ break;
+ }
+-
++ }
++ else {
++ buf = "";
+ }
+ }
+ else {