aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2018-12-09 22:53:56 +0800
committerriggs <riggs@FreeBSD.org>2018-12-09 22:53:56 +0800
commit147da7703ab5a88aa9baf4a7a5d6ca5c20119c46 (patch)
tree232b23b51529938d921ed0a402168109e8931d62
parent1156e11b7fabfc2260b0ecadcc0518a625d64777 (diff)
downloadfreebsd-ports-gnome-147da7703ab5a88aa9baf4a7a5d6ca5c20119c46.tar.gz
freebsd-ports-gnome-147da7703ab5a88aa9baf4a7a5d6ca5c20119c46.tar.zst
freebsd-ports-gnome-147da7703ab5a88aa9baf4a7a5d6ca5c20119c46.zip
Update to upstream version 2.5.0
Detailed maintainer log: - Update from 2.4.2 to 2.5.0 - Change sources from MASTER_SITES to GitHub - Update version of Python dependency - Remove CONFIGURE - Add CFLAGS to find gmp.h - Remov INSTALL_TARGET - Update WWW in pkg-descr - Update pkg-plist The new version brings some enhancements and changes: - New AGS global solver (#194), thanks to Vladislav Sovrasov - New nlopt_get_numevals function providing a built-in evaluation counter (#160) - New nlopt_get_errmsg function for more descriptive error messages - Build system is converted from autotools to cmake (#49), thanks to Julien Schueller - Plugins updated for recent Octave and Guile versions - Various other build fixes and minor bug fixes PR: 233497 Submitted by: rhurlin@gwdg.de (maintainer)
-rw-r--r--math/nlopt/Makefile22
-rw-r--r--math/nlopt/distinfo5
-rw-r--r--math/nlopt/pkg-descr4
-rw-r--r--math/nlopt/pkg-plist21
4 files changed, 25 insertions, 27 deletions
diff --git a/math/nlopt/Makefile b/math/nlopt/Makefile
index ba9eb7d0d22e..96e15acf18a4 100644
--- a/math/nlopt/Makefile
+++ b/math/nlopt/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= nlopt
-PORTVERSION= 2.4.2
-PORTREVISION= 3
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.5.0
CATEGORIES= math
-MASTER_SITES= http://ab-initio.mit.edu/nlopt/
MAINTAINER= rhurlin@gwdg.de
COMMENT= Nonlinear optimization library
@@ -20,17 +19,16 @@ BROKEN_armv7= fails to package: Unable to access file site-packages/_nlopt.a:No
LIB_DEPENDS= libgmp.so:math/gmp \
libguile-2.0.so:lang/guile2
BUILD_DEPENDS= swig3.0:devel/swig30 \
- ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1,1:math/py-numpy@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.9.1,1:math/py-numpy@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.15.1:math/py-numpy@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.15.1:math/py-numpy@${PY_FLAVOR}
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared
-CONFIGURE_ENV= SWIG="${LOCALBASE}/bin/swig3.0"
-
-USES= autoreconf compiler:features libtool pathfix \
- pkgconfig python:2.7
+USES= cmake compiler:features pathfix pkgconfig python:2.7
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
+USE_GITHUB= yes
+GH_ACCOUNT= stevengj
+
+# Needed to find gmp.h
+CFLAGS+= -I${LOCALBASE}/include
.include <bsd.port.mk>
diff --git a/math/nlopt/distinfo b/math/nlopt/distinfo
index 6fc468c0a303..f9b2fcf8c5a4 100644
--- a/math/nlopt/distinfo
+++ b/math/nlopt/distinfo
@@ -1,2 +1,3 @@
-SHA256 (nlopt-2.4.2.tar.gz) = 8099633de9d71cbc06cd435da993eb424bbcdbded8f803cdaa9fb8c6e09c8e89
-SIZE (nlopt-2.4.2.tar.gz) = 2361992
+TIMESTAMP = 1543131988
+SHA256 (stevengj-nlopt-v2.5.0_GH0.tar.gz) = c6dd7a5701fff8ad5ebb45a3dc8e757e61d52658de3918e38bab233e7fd3b4ae
+SIZE (stevengj-nlopt-v2.5.0_GH0.tar.gz) = 2403609
diff --git a/math/nlopt/pkg-descr b/math/nlopt/pkg-descr
index 719a982c7c6b..3047107c90d0 100644
--- a/math/nlopt/pkg-descr
+++ b/math/nlopt/pkg-descr
@@ -14,5 +14,7 @@ other algorithms. Its features include:
algorithms exploiting user-supplied gradients.
- Algorithms for unconstrained optimization, bound-constrained
optimization, and general nonlinear inequality/equality constraints.
+ - Free/open-source software under the GNU LGPL
+ (and looser licenses for some portions of NLopt).
-WWW: http://ab-initio.mit.edu/wiki/index.php/NLopt
+WWW: https://nlopt.readthedocs.io/en/latest/
diff --git a/math/nlopt/pkg-plist b/math/nlopt/pkg-plist
index 277fffcd9b16..2a246879f4ef 100644
--- a/math/nlopt/pkg-plist
+++ b/math/nlopt/pkg-plist
@@ -1,21 +1,18 @@
include/nlopt.f
include/nlopt.h
include/nlopt.hpp
-lib/libnlopt.a
+lib/cmake/nlopt/NLoptConfig.cmake
+lib/cmake/nlopt/NLoptConfigVersion.cmake
+lib/cmake/nlopt/NLoptLibraryDepends-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/nlopt/NLoptLibraryDepends.cmake
+lib/guile/2.0/extensions/nlopt_guile.so
lib/libnlopt.so
lib/libnlopt.so.0
-lib/libnlopt.so.0.8.2
-lib/libnlopt_guile.a
-lib/libnlopt_guile.so
-lib/libnlopt_guile.so.0
-lib/libnlopt_guile.so.0.8.2
-libdata/pkgconfig/nlopt.pc
-%%PYTHON_SITELIBDIR%%/_nlopt.a
+lib/libnlopt.so.0.9.0
%%PYTHON_SITELIBDIR%%/_nlopt.so
-%%PYTHON_SITELIBDIR%%/_nlopt.so.0
-%%PYTHON_SITELIBDIR%%/_nlopt.so.0.8.2
%%PYTHON_SITELIBDIR%%/nlopt.py
-%%PYTHON_SITELIBDIR%%/nlopt.pyc
-%%PYTHON_SITELIBDIR%%/nlopt.pyo
+libdata/pkgconfig/nlopt.pc
man/man3/nlopt.3.gz
+man/man3/nlopt_minimize.3.gz
+man/man3/nlopt_minimize_constrained.3.gz
share/guile/site/2.0/nlopt.scm