aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-11 01:08:58 +0800
committerbapt <bapt@FreeBSD.org>2014-06-11 01:08:58 +0800
commit1547a7b4446fb034ee9e78d2f0ce1eb447fe7a66 (patch)
treedc9dfb05355292ae5b121424629fa760636304aa
parentf47d1ccd7866c460781daa71a897c5bcbc302be2 (diff)
downloadfreebsd-ports-gnome-1547a7b4446fb034ee9e78d2f0ce1eb447fe7a66.tar.gz
freebsd-ports-gnome-1547a7b4446fb034ee9e78d2f0ce1eb447fe7a66.tar.zst
freebsd-ports-gnome-1547a7b4446fb034ee9e78d2f0ce1eb447fe7a66.zip
LibreOffice 4.2 depends on libe-book00
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/libe-book00/Makefile34
-rw-r--r--textproc/libe-book00/distinfo2
-rw-r--r--textproc/libe-book00/pkg-descr14
-rw-r--r--textproc/libe-book00/pkg-plist19
5 files changed, 70 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 33c72e9f784e..2cb09e5de9b0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -352,6 +352,7 @@
SUBDIR += libcsv
SUBDIR += libcue
SUBDIR += libe-book
+ SUBDIR += libe-book00
SUBDIR += libebml
SUBDIR += libextractor
SUBDIR += libexttextcat
diff --git a/textproc/libe-book00/Makefile b/textproc/libe-book00/Makefile
new file mode 100644
index 000000000000..fe86b70da23f
--- /dev/null
+++ b/textproc/libe-book00/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= libe-book
+PORTVERSION= 0.0.3
+CATEGORIES= textproc
+MASTER_SITES= SF/libebook/${PORTNAME}-${PORTVERSION}/
+PKGNAMESUFFIX= 00
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= Library for import of reflowable e-book formats
+
+LICENSE= LGPL21 MPL
+LICENSE_COMB= dual
+
+OPTIONS_DEFINE= DOCS
+
+BUILD_DEPENDS= ${LOCALBASE}/include/boost/algorithm/string.hpp:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libicui18n.so:${PORTSDIR}/devel/icu \
+ libwpd-0.9.so:${PORTSDIR}/textproc/libwpd
+
+USE_GNOME= libxml2
+
+USES= gmake libtool pathfix pkgconfig tar:xz
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= ZLIB_CFLAGS="-DWEHAVEZLIBINBASE" ZLIB_LIBS="-DWEDOHAVEIT"
+INSTALL_TARGET= install-strip
+CONFIGURE_ARGS= --disable-werror --without-docs
+CPPFLAGS+= -I${LOCALBASE}/include
+
+post-install:
+ ${RM} -f ${STAGEDIR}${PREFIX}/bin/*
+
+.include <bsd.port.mk>
diff --git a/textproc/libe-book00/distinfo b/textproc/libe-book00/distinfo
new file mode 100644
index 000000000000..a953a6fc677c
--- /dev/null
+++ b/textproc/libe-book00/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libe-book-0.0.3.tar.xz) = b19811069c7518808ee2c7d74a4012f3645ab656d79290909c192f9ec278b01b
+SIZE (libe-book-0.0.3.tar.xz) = 332808
diff --git a/textproc/libe-book00/pkg-descr b/textproc/libe-book00/pkg-descr
new file mode 100644
index 000000000000..39a54d8d3279
--- /dev/null
+++ b/textproc/libe-book00/pkg-descr
@@ -0,0 +1,14 @@
+libe-book is a library and a set of tools for reading and converting various
+non-HTML reflowable e-book formats.
+
+Currently supported are:
+- eReader .pdb
+- FictionBook v. 2 (including zipped files)
+- PalmDoc Ebook - Plucker .pdb
+- QiOO (mobile format, for java-enabled cellphones)
+- TCR (simple compressed text format)
+- TealDoc
+- zTXT
+- ZVR (simple compressed text format)
+
+WWW: http://sourceforge.net/projects/libebook/
diff --git a/textproc/libe-book00/pkg-plist b/textproc/libe-book00/pkg-plist
new file mode 100644
index 000000000000..2c57cae728a3
--- /dev/null
+++ b/textproc/libe-book00/pkg-plist
@@ -0,0 +1,19 @@
+include/libe-book-0.0/libe-book/FB2Document.h
+include/libe-book-0.0/libe-book/IMPDocument.h
+include/libe-book-0.0/libe-book/LRFDocument.h
+include/libe-book-0.0/libe-book/PDBDocument.h
+include/libe-book-0.0/libe-book/PLKRDocument.h
+include/libe-book-0.0/libe-book/PMLDocument.h
+include/libe-book-0.0/libe-book/QIOODocument.h
+include/libe-book-0.0/libe-book/TCRDocument.h
+include/libe-book-0.0/libe-book/TDDocument.h
+include/libe-book-0.0/libe-book/ZTXTDocument.h
+include/libe-book-0.0/libe-book/ZVRDocument.h
+include/libe-book-0.0/libe-book/EBOOKDocument.h
+include/libe-book-0.0/libe-book/libe-book.h
+lib/libe-book-0.0.so
+lib/libe-book-0.0.so.0
+lib/libe-book-0.0.so.0.0.3
+libdata/pkgconfig/libe-book-0.0.pc
+@dirrm include/libe-book-0.0/libe-book
+@dirrm include/libe-book-0.0