aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-11 23:11:42 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-11 23:11:42 +0800
commit169df2917434face98111a403e13db5d03f78444 (patch)
tree52800f640e9d8b8c89762b643db9e2e8b3f89ec3
parent5c5b94190956a759392ecc9d1d59d039daea405c (diff)
downloadfreebsd-ports-gnome-169df2917434face98111a403e13db5d03f78444.tar.gz
freebsd-ports-gnome-169df2917434face98111a403e13db5d03f78444.tar.zst
freebsd-ports-gnome-169df2917434face98111a403e13db5d03f78444.zip
Update to 2.0.0.
-rw-r--r--devel/libgtop2/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/devel/libgtop2/Makefile b/devel/libgtop2/Makefile
index ad3f83de3e69..0ff4cc44ae16 100644
--- a/devel/libgtop2/Makefile
+++ b/devel/libgtop2/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= glib-2.0.0:${PORTSDIR}/devel/glib20
USE_BZIP2= yes
USE_PERL5= yes
USE_GMAKE= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -27,10 +28,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${REINPLACE_CMD} -e \
+ 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
+ s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
+ s|[(]datadir[)]/locale|(prefix)/share/locale|g'
post-install:
install-info --section="Programming \& development tools" \