aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-10-30 01:05:50 +0800
committerkwm <kwm@FreeBSD.org>2013-10-30 01:05:50 +0800
commit1711e1d724333bf357bd74c8d8688cbce2c95b37 (patch)
tree5cd403e620f727ad5e2f7c0bfa122a124e085d34
parentd9af86a673bc1b49aad81603bbf1ba3d91dabaa6 (diff)
downloadfreebsd-ports-gnome-1711e1d724333bf357bd74c8d8688cbce2c95b37.tar.gz
freebsd-ports-gnome-1711e1d724333bf357bd74c8d8688cbce2c95b37.tar.zst
freebsd-ports-gnome-1711e1d724333bf357bd74c8d8688cbce2c95b37.zip
Restrict python to -2.7
Submitted by: mva@
-rw-r--r--accessibility/accerciser/Makefile4
-rw-r--r--accessibility/accerciser/pkg-plist1
-rw-r--r--accessibility/at-spi/Makefile2
-rw-r--r--accessibility/orca/Makefile2
-rw-r--r--accessibility/py-atspi/Makefile2
-rw-r--r--accessibility/speech-dispatcher/Makefile2
-rw-r--r--devel/glib20/Makefile2
-rw-r--r--devel/libglade2/Makefile2
-rw-r--r--devel/py-dbus/Makefile2
-rw-r--r--devel/py-notify/Makefile2
-rw-r--r--devel/py-xdg/Makefile2
-rw-r--r--multimedia/py-gstreamer/Makefile2
-rw-r--r--textproc/gnome-doc-utils/Makefile2
-rw-r--r--www/webkit-gtk2/Makefile2
-rw-r--r--x11-toolkits/py-gnome-desktop/Makefile2
-rw-r--r--x11-toolkits/py-gnome2/Makefile2
-rw-r--r--x11/gnome-desktop/Makefile2
-rw-r--r--x11/gnome-menus/Makefile2
-rw-r--r--x11/gnome-panel/Makefile2
19 files changed, 19 insertions, 20 deletions
diff --git a/accessibility/accerciser/Makefile b/accessibility/accerciser/Makefile
index 602bdad75426..c4ef6ae0ae98 100644
--- a/accessibility/accerciser/Makefile
+++ b/accessibility/accerciser/Makefile
@@ -12,10 +12,9 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Interactive Python accessibility explorer for GNOME
-NO_STAGE= yes
USE_BZIP2= yes
USE_GNOME= pygnomedesktop atspi intlhack
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USES= display:configure gettext gmake pkgconfig
INSTALLS_OMF= yes
INSTALLS_ICONS= yes
@@ -24,6 +23,5 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= accerciser.schemas
-MAN1= accerciser.1
.include <bsd.port.mk>
diff --git a/accessibility/accerciser/pkg-plist b/accessibility/accerciser/pkg-plist
index b4e45b7e06c1..f34ddbfc8b02 100644
--- a/accessibility/accerciser/pkg-plist
+++ b/accessibility/accerciser/pkg-plist
@@ -56,6 +56,7 @@ bin/accerciser
%%PYTHON_SITELIBDIR%%/accerciser/ui_manager.py
%%PYTHON_SITELIBDIR%%/accerciser/ui_manager.pyc
%%PYTHON_SITELIBDIR%%/accerciser/ui_manager.pyo
+man/man1/accerciser.1.gz
%%DATADIR%%/pixmaps/hicolor/22x22/acceleratorlabel.png
%%DATADIR%%/pixmaps/hicolor/22x22/alert.png
%%DATADIR%%/pixmaps/hicolor/22x22/animation.png
diff --git a/accessibility/at-spi/Makefile b/accessibility/at-spi/Makefile
index 6ace5e878b37..1e7b9dcdea9a 100644
--- a/accessibility/at-spi/Makefile
+++ b/accessibility/at-spi/Makefile
@@ -22,7 +22,7 @@ NO_STAGE= yes
USES= gmake gettext pkgconfig
USE_GNOME= gnomehack gnomehier intlhack gtk20 gconf2 libbonobo
USE_XORG= x11 xtst
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static
diff --git a/accessibility/orca/Makefile b/accessibility/orca/Makefile
index a7b6ef35e82a..1fc8fae5d14c 100644
--- a/accessibility/orca/Makefile
+++ b/accessibility/orca/Makefile
@@ -23,7 +23,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_dbus_bindings.so:${PORTSDIR}/devel/py-dbus \
NO_STAGE= yes
USE_BZIP2= yes
USES= gmake gettext pkgconfig
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_GNOME= gnomeprefix gnomehack libgnomeui gnomespeech pygnome2 \
pygnomedesktop
INSTALLS_ICONS= yes
diff --git a/accessibility/py-atspi/Makefile b/accessibility/py-atspi/Makefile
index 0bb36cd2f2e9..3fb26df2323a 100644
--- a/accessibility/py-atspi/Makefile
+++ b/accessibility/py-atspi/Makefile
@@ -23,7 +23,7 @@ USE_XZ= yes
USES= gettext gmake pathfix pkgconfig
USE_GNOME= gnomehier intlhack pygobject3
GNU_CONFIGURE= yes
-USE_PYTHON= yes
+USE_PYTHON= -2.7
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/accessibility/speech-dispatcher/Makefile b/accessibility/speech-dispatcher/Makefile
index 6d6149c37890..8f9b50a5c550 100644
--- a/accessibility/speech-dispatcher/Makefile
+++ b/accessibility/speech-dispatcher/Makefile
@@ -104,7 +104,7 @@ CONFIGURE_ARGS+=--without-pulse
.endif
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= 2.5+
+USE_PYTHON= -2.7
CONFIGURE_ARGS+=--enable-python
PLIST_SUB+= PYTHON=""
.else
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 21cf54c7614e..6ae2f390e058 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -26,7 +26,7 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USES= gettext gmake iconv pathfix pkgconfig shebangfix perl5
USE_GNOME= ltverhack
-USE_PYTHON= 2.5+
+USE_PYTHON= yes
CONFIGURE_ARGS= --enable-static \
--disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
--disable-man --without-xml-catalog \
diff --git a/devel/libglade2/Makefile b/devel/libglade2/Makefile
index c93e19ca5cec..6f1e9e2dc3b5 100644
--- a/devel/libglade2/Makefile
+++ b/devel/libglade2/Makefile
@@ -41,7 +41,7 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USE_PYTHON= -2.7
PLIST_SUB+= PYTHON=""
.else
PLIST_SUB+= PYTHON="@comment "
diff --git a/devel/py-dbus/Makefile b/devel/py-dbus/Makefile
index 7c14df244380..bd7f4e853f38 100644
--- a/devel/py-dbus/Makefile
+++ b/devel/py-dbus/Makefile
@@ -15,7 +15,7 @@ COMMENT= Python bindings for the D-BUS messaging system
LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
USES= gettext pathfix pkgconfig
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${PYTHON_INCLUDEDIR}
diff --git a/devel/py-notify/Makefile b/devel/py-notify/Makefile
index 1363ad2afa26..8a0cbc8cf5cc 100644
--- a/devel/py-notify/Makefile
+++ b/devel/py-notify/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= notify.4:${PORTSDIR}/devel/libnotify
USE_BZIP2= yes
USES= gmake pkgconfig
USE_GNOME= gnomehack pygtk2
-USE_PYTHON= yes
+USE_PYTHON= -2.7
GNU_CONFIGURE= yes
DOCS= AUTHORS COPYING ChangeLog NEWS
diff --git a/devel/py-xdg/Makefile b/devel/py-xdg/Makefile
index 355ffd41c16f..5a83db44866a 100644
--- a/devel/py-xdg/Makefile
+++ b/devel/py-xdg/Makefile
@@ -12,7 +12,7 @@ DISTNAME= py${PORTNAME}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A python library to access freedesktop.org standards
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= pyxdg
diff --git a/multimedia/py-gstreamer/Makefile b/multimedia/py-gstreamer/Makefile
index 5e361017d736..12e4307f12d6 100644
--- a/multimedia/py-gstreamer/Makefile
+++ b/multimedia/py-gstreamer/Makefile
@@ -20,7 +20,7 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/libxml2mod.so:${PORTSDIR}/textproc/py-libxml2
USES= pkgconfig
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= pygobject gnomehack
diff --git a/textproc/gnome-doc-utils/Makefile b/textproc/gnome-doc-utils/Makefile
index 161a655a2aaa..da9fc9dccec5 100644
--- a/textproc/gnome-doc-utils/Makefile
+++ b/textproc/gnome-doc-utils/Makefile
@@ -22,7 +22,7 @@ USE_XZ= yes
MAKE_JOBS_UNSAFE=yes
USES= gettext gmake pathfix pkgconfig
USE_GNOME= gnomehier libxslt intlhack
-USE_PYTHON= yes
+USE_PYTHON= -2.7
INSTALLS_OMF= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-omf-dir=${PREFIX}/share/omf
diff --git a/www/webkit-gtk2/Makefile b/www/webkit-gtk2/Makefile
index 316864018275..64f1d24624a0 100644
--- a/www/webkit-gtk2/Makefile
+++ b/www/webkit-gtk2/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libenchant.so:${PORTSDIR}/textproc/enchant \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup
USE_XZ= yes
-USE_PYTHON_BUILD= yes
+USE_PYTHON_BUILD= -2.7
USE_GSTREAMER= yes
USE_XORG= xt
USES= bison gmake pkgconfig gettext perl5
diff --git a/x11-toolkits/py-gnome-desktop/Makefile b/x11-toolkits/py-gnome-desktop/Makefile
index 3e13da5c90dd..314540be25d1 100644
--- a/x11-toolkits/py-gnome-desktop/Makefile
+++ b/x11-toolkits/py-gnome-desktop/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= bug-buddy:${PORTSDIR}/devel/bug-buddy
USE_BZIP2= yes
USES= gmake pkgconfig
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_GNOME= gnomehack libgnomeprintui gnomepanel gnomedesktop \
gtksourceview libwnck nautilus2 pygnome2 metacity \
evolutiondataserver
diff --git a/x11-toolkits/py-gnome2/Makefile b/x11-toolkits/py-gnome2/Makefile
index 7f96a2d527ad..afa8088c4e2f 100644
--- a/x11-toolkits/py-gnome2/Makefile
+++ b/x11-toolkits/py-gnome2/Makefile
@@ -20,7 +20,7 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/ORBit.so:${PORTSDIR}/devel/py-orbit
LATEST_LINK= py-gnome2
USE_BZIP2= yes
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_LDCONFIG= yes
USES= gettext gmake pkgconfig
USE_GNOME= gnomehack libgnomeui pygtk2
diff --git a/x11/gnome-desktop/Makefile b/x11/gnome-desktop/Makefile
index 53c6e0d49c18..cec13e947426 100644
--- a/x11/gnome-desktop/Makefile
+++ b/x11/gnome-desktop/Makefile
@@ -22,7 +22,7 @@ USE_XORG= xpm
USES= bison pathfix gettext pkgconfig gmake
USE_GNOME= gnomeprefix intlhack gnomedocutils gconf2 pygtk2 \
ltverhack referencehack
-USE_PYTHON= yes
+USE_PYTHON= -2.7
INSTALLS_OMF= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
diff --git a/x11/gnome-menus/Makefile b/x11/gnome-menus/Makefile
index f11dcc07a4f2..2d459fd17c3d 100644
--- a/x11/gnome-menus/Makefile
+++ b/x11/gnome-menus/Makefile
@@ -19,7 +19,7 @@ USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack glib20 ltverhack
USES= pkgconfig gettext
USE_AUTOTOOLS= libtool
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/x11/gnome-panel/Makefile b/x11/gnome-panel/Makefile
index b5660cbf9fba..c2c3ea381aba 100644
--- a/x11/gnome-panel/Makefile
+++ b/x11/gnome-panel/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= gweather:${PORTSDIR}/net/libgweather \
CONFLICTS= gnome-panel-3.[0-9]*
USE_XORG= ice sm x11 xau xrandr
-USE_PYTHON= yes
+USE_PYTHON= -2.7
INSTALLS_OMF= yes
USE_LDCONFIG= yes
INSTALLS_ICONS= yes