aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2006-06-25 01:54:22 +0800
committervanilla <vanilla@FreeBSD.org>2006-06-25 01:54:22 +0800
commit1abf58669b2ab05c8fa72cb79484c70b650e5795 (patch)
tree374ef8af12896daf3090ede05970d87149e1e16e
parent79253de7ab1c4170c32f3786ec36b652cc0e333e (diff)
downloadfreebsd-ports-gnome-1abf58669b2ab05c8fa72cb79484c70b650e5795.tar.gz
freebsd-ports-gnome-1abf58669b2ab05c8fa72cb79484c70b650e5795.tar.zst
freebsd-ports-gnome-1abf58669b2ab05c8fa72cb79484c70b650e5795.zip
Add ofc, it's The Objective-C Foundation Classes library.
-rw-r--r--lang/Makefile1
-rw-r--r--lang/ofc/Makefile35
-rw-r--r--lang/ofc/distinfo3
-rw-r--r--lang/ofc/files/patch-ofc-config15
-rw-r--r--lang/ofc/pkg-descr9
-rw-r--r--lang/ofc/pkg-plist97
6 files changed, 160 insertions, 0 deletions
diff --git a/lang/Makefile b/lang/Makefile
index e9c1813c1efb..219d0ad434f2 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -164,6 +164,7 @@
SUBDIR += ocaml-doc
SUBDIR += ocaml-mode.el
SUBDIR += ocaml-nox11
+ SUBDIR += ofc
SUBDIR += ohugs
SUBDIR += onyx
SUBDIR += oo2c
diff --git a/lang/ofc/Makefile b/lang/ofc/Makefile
new file mode 100644
index 000000000000..8f2cace27cb1
--- /dev/null
+++ b/lang/ofc/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: ofc
+# Date created: 06/21/2006
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= ofc
+PORTVERSION= 0.7.0
+CATEGORIES= lang
+MASTER_SITES= http://ofc.dvoudheusden.net/download/
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= The Objective-C Foundation Classes library
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+USE_GNOME= gnomehack gnometarget
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+OPTIONS= GDBM "Add gdbm support" off \
+ GMP "Add gmp support" off
+
+.if defined (WITH_GDBM)
+LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
+.endif
+
+.if defined (WITH_GMP)
+LIB_DEPENDS+= gmp.4:${PORTSDIR}/math/libgmp4
+.endif
+
+.include <bsd.port.mk>
diff --git a/lang/ofc/distinfo b/lang/ofc/distinfo
new file mode 100644
index 000000000000..90ebea22eb6d
--- /dev/null
+++ b/lang/ofc/distinfo
@@ -0,0 +1,3 @@
+MD5 (ofc-0.7.0.tar.gz) = 064538406d7d509b78da146141ff521e
+SHA256 (ofc-0.7.0.tar.gz) = 6c8536ff9915968ee3266de82a2bcf2eed1244e7cd2cc30165168294a54c3de3
+SIZE (ofc-0.7.0.tar.gz) = 760324
diff --git a/lang/ofc/files/patch-ofc-config b/lang/ofc/files/patch-ofc-config
new file mode 100644
index 000000000000..0dae90e8ad81
--- /dev/null
+++ b/lang/ofc/files/patch-ofc-config
@@ -0,0 +1,15 @@
+--- bin/ofc-config.in.orig Wed Jun 21 22:40:05 2006
++++ bin/ofc-config.in Wed Jun 21 22:40:44 2006
+@@ -39,10 +39,10 @@
+ echo @ofc_VERSION@
+ ;;
+ --cflags)
+- echo @OFC_CFLAGS@
++ echo @OFC_CFLAGS@ -I$prefix/include
+ ;;
+ --libs)
+- libdirs="-L/usr/lib "
++ libdirs="-L$prefix/lib "
+ echo $libdirs @OFC_LIB@ @SHARED_LIBS@
+ ;;
+ --static-libs)
diff --git a/lang/ofc/pkg-descr b/lang/ofc/pkg-descr
new file mode 100644
index 000000000000..c403b28aebd1
--- /dev/null
+++ b/lang/ofc/pkg-descr
@@ -0,0 +1,9 @@
+The Objective-C Foundation Classes (OFC) library
+
+The Objective-c foundation classes library is a general purpose library. The
+classes in the library are grouped in five clusters: data types, collections,
+c-wrappers, network and compound classes. At the moment the library is still
+under development. The OFC library and the test and example programs are
+licensed under the GNU GPL.
+
+WWW: http://ofc.dvoudheusden.net
diff --git a/lang/ofc/pkg-plist b/lang/ofc/pkg-plist
new file mode 100644
index 000000000000..077b6b96acc4
--- /dev/null
+++ b/lang/ofc/pkg-plist
@@ -0,0 +1,97 @@
+bin/ofc-config
+include/ofc/DArguments.h
+include/ofc/DArray.h
+include/ofc/DAtExit.h
+include/ofc/DAvlTree.h
+include/ofc/DBZipFile.h
+include/ofc/DBigDouble.h
+include/ofc/DBigInt.h
+include/ofc/DBitArray.h
+include/ofc/DBool.h
+include/ofc/DCRC32.h
+include/ofc/DCalendar.h
+include/ofc/DCircle.h
+include/ofc/DColor.h
+include/ofc/DComparable.h
+include/ofc/DComplex.h
+include/ofc/DConfig.h
+include/ofc/DCube.h
+include/ofc/DData.h
+include/ofc/DDataReadable.h
+include/ofc/DDataWritable.h
+include/ofc/DDatable.h
+include/ofc/DDateTime.h
+include/ofc/DDbm.h
+include/ofc/DDirectory.h
+include/ofc/DDiscreteDistribution.h
+include/ofc/DDouble.h
+include/ofc/DDoubleArray.h
+include/ofc/DDrawable.h
+include/ofc/DFSM.h
+include/ofc/DFile.h
+include/ofc/DFixedPoint.h
+include/ofc/DFraction.h
+include/ofc/DGZipFile.h
+include/ofc/DGraph.h
+include/ofc/DHTTPClient.h
+include/ofc/DHashTable.h
+include/ofc/DImageHeader.h
+include/ofc/DInt.h
+include/ofc/DIntArray.h
+include/ofc/DKey.h
+include/ofc/DLRnd.h
+include/ofc/DLexer.h
+include/ofc/DList.h
+include/ofc/DLog.h
+include/ofc/DLogger.h
+include/ofc/DLong.h
+include/ofc/DMD5.h
+include/ofc/DObjcTokenizer.h
+include/ofc/DParsable.h
+include/ofc/DPropertyTree.h
+include/ofc/DQueuable.h
+include/ofc/DRandomable.h
+include/ofc/DRegEx.h
+include/ofc/DRnd.h
+include/ofc/DSHA1.h
+include/ofc/DScore.h
+include/ofc/DScreenHandler.h
+include/ofc/DShort.h
+include/ofc/DSimpleArithmetic.h
+include/ofc/DSizeable.h
+include/ofc/DSocket.h
+include/ofc/DSocketAddress.h
+include/ofc/DSortedList.h
+include/ofc/DSource.h
+include/ofc/DStackable.h
+include/ofc/DSystemLogger.h
+include/ofc/DTCPClient.h
+include/ofc/DTCPServer.h
+include/ofc/DTable.h
+include/ofc/DTelNetClient.h
+include/ofc/DText.h
+include/ofc/DTextFilterable.h
+include/ofc/DTextReadable.h
+include/ofc/DTextScannable.h
+include/ofc/DTextScreen.h
+include/ofc/DTextWritable.h
+include/ofc/DTextWritableLogger.h
+include/ofc/DTextable.h
+include/ofc/DTimer.h
+include/ofc/DTokenizer.h
+include/ofc/DTree.h
+include/ofc/DUDPClient.h
+include/ofc/DUDPServer.h
+include/ofc/DURL.h
+include/ofc/DValue.h
+include/ofc/DXML.h
+include/ofc/config.h
+include/ofc/md5.h
+include/ofc/settings.h
+include/ofc/warning.h
+lib/libofc.a
+lib/libofc.la
+lib/libofc.so
+lib/libofc-0.7.so
+lib/libofc-0.7.so.0
+@dirrm include/ofc