aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>2004-02-24 22:30:43 +0800
committertg <tg@FreeBSD.org>2004-02-24 22:30:43 +0800
commit1b4f5655aa90ddcac27ce4b902f24903012590d4 (patch)
treea968bff10ae8431655e4d5e11aeaedab6e4c1cb8
parent440b23e1dab83518067f254ee8c103f4c3b3cbf0 (diff)
downloadfreebsd-ports-gnome-1b4f5655aa90ddcac27ce4b902f24903012590d4.tar.gz
freebsd-ports-gnome-1b4f5655aa90ddcac27ce4b902f24903012590d4.tar.zst
freebsd-ports-gnome-1b4f5655aa90ddcac27ce4b902f24903012590d4.zip
Unbreak: remove check for tkConfig.sh.
-rw-r--r--devel/ecos-tools/Makefile2
-rw-r--r--devel/ecos-tools/files/patch-host::libcdl::configure69
2 files changed, 69 insertions, 2 deletions
diff --git a/devel/ecos-tools/Makefile b/devel/ecos-tools/Makefile
index 284c7b19518c..11c0d82da78d 100644
--- a/devel/ecos-tools/Makefile
+++ b/devel/ecos-tools/Makefile
@@ -19,8 +19,6 @@ COMMENT= Configuration tools for the eCos embedded OS
LIB_DEPENDS= tcl84.1:${PORTSDIR}/lang/tcl84 \
wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
-BROKEN= "Configure fails"
-
USE_BZIP2= yes
WRKSRC= ${WRKDIR}/infra-build
GNU_CONFIGURE= yes
diff --git a/devel/ecos-tools/files/patch-host::libcdl::configure b/devel/ecos-tools/files/patch-host::libcdl::configure
new file mode 100644
index 000000000000..5774cc3606bb
--- /dev/null
+++ b/devel/ecos-tools/files/patch-host::libcdl::configure
@@ -0,0 +1,69 @@
+$FreeBSD$
+
+--- ../ecos/host/libcdl/configure~ Wed Feb 12 18:22:31 2003
++++ ../ecos/host/libcdl/configure Sat Feb 21 19:13:54 2004
+@@ -1968,64 +1968,6 @@
+ { echo "configure: error: ${tclconfig}/tclConfig.sh does not define TCL_LIB_SPEC" 1>&2; exit 1; }
+ fi
+ ecos_LIBS="${ecos_LIBS} ${TCL_LIB_SPEC}"
+-
+- possibles=`echo ${possibles} | sed -e 's,tcl,tk,g'`
+-
+- tkconfig=""
+- for i in ${possibles}; do
+- if test -r "$i/"tkConfig.sh""; then
+- tkconfig=$i
+- break
+- fi
+- done
+-
+- if test \! -r "${tkconfig}/tkConfig.sh" ; then
+- { echo "configure: error: unable to locate Tk config file tkConfig.sh" 1>&2; exit 1; }
+- else
+- . ${tkconfig}/tkConfig.sh
+- if test -z "${TK_INC_DIR}" ; then
+- if test "${TK_PREFIX}" = "/usr" ; then
+- ecos_tk_includes="${TK_XINCLUDES}"
+- else
+- ecos_tk_includes="-I${TK_PREFIX}/include ${TK_XINCLUDES}"
+- fi
+- else
+- ecos_tk_includes="-I${TK_INC_DIR} ${TK_XINCLUDES}"
+- fi
+-
+- if test -z "${TK_LIB_SPEC}" -a "${with_tcl_version+set}" = set ; then
+-
+- libtk=""
+- for i in ${possibles}; do
+- if test -r "$i/"libtk${with_tcl_version}.a""; then
+- libtk=$i
+- break
+- fi
+- done
+-
+- if test -r "${libtk}/libtk${with_tcl_version}.a" ; then
+- TK_LIB_SPEC="-L${libtk} -ltk${with_tcl_version}"
+- fi
+- fi
+- if test -z "${TK_LIB_SPEC}" ; then
+-
+- libtk=""
+- for i in ${possibles}; do
+- if test -r "$i/"libtk.a""; then
+- libtk=$i
+- break
+- fi
+- done
+-
+- if test -r "${libtk}/libtk.a" ; then
+- TK_LIB_SPEC="-L${libtk} -ltk"
+- fi
+- fi
+- if test -z "${TK_LIB_SPEC}" ; then
+- { echo "configure: error: ${tkconfig}/tkConfig.sh does not define TK_LIB_SPEC" 1>&2; exit 1; }
+- fi
+- ecos_tk_libs="${TK_LIB_SPEC} ${TK_LIBS}"
+- fi
+ fi
+ fi
+