aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2018-07-16 04:12:53 +0800
committerjbeich <jbeich@FreeBSD.org>2018-07-16 04:12:53 +0800
commit1ba2c7a358bdce46d0d87ee650a4af2d1928f255 (patch)
tree4895c71bb726f52998fd146bc9c57c29be0d075f
parentf694183711fd6a307beb9f36fd52e8c0f4c1d406 (diff)
downloadfreebsd-ports-gnome-1ba2c7a358bdce46d0d87ee650a4af2d1928f255.tar.gz
freebsd-ports-gnome-1ba2c7a358bdce46d0d87ee650a4af2d1928f255.tar.zst
freebsd-ports-gnome-1ba2c7a358bdce46d0d87ee650a4af2d1928f255.zip
multimedia/vapoursynth: update to R44
Changes: http://www.vapoursynth.com/2018/07/r44-speeding-up-slightly/ Changes: https://github.com/vapoursynth/vapoursynth/blob/R44/ChangeLog
-rw-r--r--multimedia/vapoursynth/Makefile3
-rw-r--r--multimedia/vapoursynth/distinfo6
-rw-r--r--multimedia/vapoursynth/files/patch-non-x8612
3 files changed, 10 insertions, 11 deletions
diff --git a/multimedia/vapoursynth/Makefile b/multimedia/vapoursynth/Makefile
index 6c629ac261d0..360677c2d0e5 100644
--- a/multimedia/vapoursynth/Makefile
+++ b/multimedia/vapoursynth/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= vapoursynth
-PORTVERSION= R43
-PORTREVISION= 1
+PORTVERSION= R44
CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
diff --git a/multimedia/vapoursynth/distinfo b/multimedia/vapoursynth/distinfo
index 9e4ea204bfeb..26ba51165205 100644
--- a/multimedia/vapoursynth/distinfo
+++ b/multimedia/vapoursynth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517427600
-SHA256 (vapoursynth-vapoursynth-R43_GH0.tar.gz) = 5c80d583f6891f4f5840edf09bc207c2e71653786b07606fdb4a164fd67470c2
-SIZE (vapoursynth-vapoursynth-R43_GH0.tar.gz) = 590554
+TIMESTAMP = 1531494777
+SHA256 (vapoursynth-vapoursynth-R44_GH0.tar.gz) = 3459aa903c42b2f87a634ee705fcc3dd251729bd179e8ab4684a50bd7415930a
+SIZE (vapoursynth-vapoursynth-R44_GH0.tar.gz) = 595344
diff --git a/multimedia/vapoursynth/files/patch-non-x86 b/multimedia/vapoursynth/files/patch-non-x86
index ca9f3aa570c9..4d125f9348b7 100644
--- a/multimedia/vapoursynth/files/patch-non-x86
+++ b/multimedia/vapoursynth/files/patch-non-x86
@@ -1,6 +1,6 @@
---- src/core/cpufeatures.c.orig 2016-02-02 16:12:42 UTC
+--- src/core/cpufeatures.c.orig 2018-07-13 15:12:57 UTC
+++ src/core/cpufeatures.c
-@@ -60,7 +60,7 @@ void getCPUFeatures(CPUFeatures *cpuFeat
+@@ -69,7 +69,7 @@ void getCPUFeatures(CPUFeatures *cpuFeatures) {
}
}
}
@@ -13,21 +13,21 @@
#endif
}
#else
--#error Do not know how to get CPU features.
+-#warning "Do not know how to get CPU features."
+void getCPUFeatures(CPUFeatures *cpuFeatures) {
+ memset(cpuFeatures, 0, sizeof(CPUFeatures));
+
+ cpuFeatures->can_run_vs = 1;
+}
#endif
---- src/core/cpufeatures.h.orig 2016-02-02 16:12:42 UTC
+--- src/core/cpufeatures.h.orig 2018-07-13 15:12:57 UTC
+++ src/core/cpufeatures.h
-@@ -51,8 +51,6 @@ typedef struct CPUFeatures {
+@@ -59,8 +59,6 @@ typedef struct CPUFeatures {
char efp_double;
char dfp;
char vsx;
-#else
--#error No VS_TARGET_CPU_* defined/handled!
+-#warning "No VS_TARGET_CPU_* defined/handled!"
#endif
} CPUFeatures;