aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2015-10-11 23:02:58 +0800
committerohauer <ohauer@FreeBSD.org>2015-10-11 23:02:58 +0800
commit1cac7462b2b6b46c01d0647988798d360295a52e (patch)
treed19a79d21fe57d28eb7584046a5d45bf1985b990
parentef33388e4dd7931c7ae206df2dc00d60671a4ea8 (diff)
downloadfreebsd-ports-gnome-1cac7462b2b6b46c01d0647988798d360295a52e.tar.gz
freebsd-ports-gnome-1cac7462b2b6b46c01d0647988798d360295a52e.tar.zst
freebsd-ports-gnome-1cac7462b2b6b46c01d0647988798d360295a52e.zip
- update to 3.0.3
- use target helpers ChangeLog: 20150722 The COMPATIBILITY_README text and HTML files were not installed. File: conf/postfix-files. 20150903 Workaround: disable DNSSEC support for AIX 7x and earlier. The AIX 6/7 resolver(5) API defines RES_USE_DNSSEC without defining the "ad" bit. Viktor Dukhovni. Files: makedefs, proto/INSTALL.html, dns/dns.h. 20150923 Bugfix (introduced: 20120531-617): the Postfix SMTP server used a larger-than-1 VSTREAM buffer to read the HAProxy connection hand-off information. This broke TLS wrappermode, as the TLS helo packet would end up in the plaintext VSTREAM buffer. Reported by Lukas Erlacher. File: smtpd/smtpd_haproxy.c. 20150924 Bugfix (introduced: 20090216-24): incorrect postmulti error message. Reported by Patrik Koetter. Fix by Viktor Dukhovni. File: postmulti/postmulti.c. Workaround: don't create a new instance when the template main.cf and master.cf files are missing, as happens on Debian-like systems. Viktor Dukhovni. File: conf/postmulti-script. 20150925 Bugfix (introduced: 19970309, fixed 20150421 in development release): reset errno before calling readdir(), in order to distinguish between an end-of-directory and an error condition. File: scandir.c. 20150930 Bugfix (introduced: 20040124): Milter client panic while adding a header, because the PREPEND action used the same output function for header_checks and body_checks. Viktor Dukhovni and Wietse. File: cleanup/cleanup_message.c. Bugfix (introduced: 20031128): xtext_unquote() did not propagate error reports from xtext_unquote_append(), causing the decoder to return partial ouput, instead of rejecting malformed input. Fix by Krzysztof Wojta. File: global/xtext.c. 20151003 Bugfix (copied from xtext): uxtext_unquote() did not propagate error reports from uxtext_unquote_append(), causing the decoder to return partial output, instead of rejecting malformed input. Found by searching the code for similar error patterns as with xtext_unquote(). File: global/uxtext.c. Bugfix (introduced: 20141130, fixed around 20150607 in development release): the DNS multi-query clients forgot to save and restore h_errno when evaluating the aggregate result. File: dns/dns_lookup.c.
-rw-r--r--mail/postfix-current/Makefile24
-rw-r--r--mail/postfix-current/distinfo4
2 files changed, 13 insertions, 15 deletions
diff --git a/mail/postfix-current/Makefile b/mail/postfix-current/Makefile
index b8b11d6c75ce..035ccc0804e4 100644
--- a/mail/postfix-current/Makefile
+++ b/mail/postfix-current/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= postfix
-DISTVERSION= 3.0-20150719
+DISTVERSION= 3.0-20151003
PORTEPOCH= 4
CATEGORIES= mail ipv6
MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/ \
@@ -14,7 +14,7 @@ MASTER_SITES= ftp://ftp.porcupine.org/mirrors/postfix-release/ \
#MASTER_SITES:= ${MASTER_SITES:S|$|experimental/|}
MASTER_SITES:= ${MASTER_SITES:S|$|official/|}
PKGNAMESUFFIX= -current
-DISTNAME= ${PORTNAME}-3.0.2
+DISTNAME= ${PORTNAME}-3.0.3
DIST_SUBDIR= ${PORTNAME}
MAINTAINER= ohauer@FreeBSD.org
@@ -319,17 +319,17 @@ post-patch:
@${ECHO} '$$html_directory/$f:f:root:-:644' \
>> ${WRKSRC}/conf/postfix-files
.endfor
-.if ${PORT_OPTIONS:MSPF}
- @${ECHO} '$$readme_directory/SPF_README:f:root:-:644' \
- >> ${WRKSRC}/conf/postfix-files
- @${REINPLACE_CMD} -E -e '${REINPLACE}' \
- ${WRKSRC}/README_FILES/SPF_README
-.endif
@${ECHO} '$$manpage_directory/man1/posttls-finger.1:f:root:-:644' \
>> ${WRKSRC}/conf/postfix-files
@${ECHO} '$$command_directory/posttls-finger:f:root:-:755' \
>> ${WRKSRC}/conf/postfix-files
+post-patch-SPF-on:
+ @${ECHO} '$$readme_directory/SPF_README:f:root:-:644' \
+ >> ${WRKSRC}/conf/postfix-files
+ @${REINPLACE_CMD} -E -e '${REINPLACE}' \
+ ${WRKSRC}/README_FILES/SPF_README
+
do-configure:
(cd ${WRKSRC} && ${MAKE} -f Makefile.init makefiles \
${MAKEFILEFLAGS} CCARGS="${POSTFIX_CCARGS}" \
@@ -339,10 +339,8 @@ do-configure:
AUXLIBS="${POSTFIX_AUXLIBS}" && \
${ECHO} "all: default" >> Makefile)
-pre-install:
-.if ${PORT_OPTIONS:MINST_BASE}
+pre-install-INST_BASE-on:
${MKDIR} ${STAGEDIR}/etc/rc.d
-.endif
do-install:
@(cd ${WRKSRC} && ${MAKE} non-interactive-package \
@@ -362,10 +360,10 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/rmail/rmail ${STAGEDIR}${PREFIX}/bin/rmail
${INSTALL_SCRIPT} ${WRKSRC}/auxiliary/qshape/qshape.pl ${STAGEDIR}${PREFIX}/bin/qshape
${INSTALL_MAN} ${WRKSRC}/man/man1/qshape.1 ${STAGEDIR}${MANPREFIX}/man/man1
-.if ${PORT_OPTIONS:MTEST}
+
+do-install-TEST-on:
${INSTALL_PROGRAM} ${BINTEST:S|^|${WRKSRC}/bin/|} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${MANTEST:S|^|${WRKSRC}/man/man1/|} ${STAGEDIR}${MANPREFIX}/man/man1
-.endif
post-stage:
# == do not overwrite existing config
diff --git a/mail/postfix-current/distinfo b/mail/postfix-current/distinfo
index a8cc405f666b..03819a142669 100644
--- a/mail/postfix-current/distinfo
+++ b/mail/postfix-current/distinfo
@@ -1,2 +1,2 @@
-SHA256 (postfix/postfix-3.0.2.tar.gz) = 68256314202f5f0f24022d64f7ac664d28fa1394d07c84a37c3fc7a2d040be80
-SIZE (postfix/postfix-3.0.2.tar.gz) = 4239235
+SHA256 (postfix/postfix-3.0.3.tar.gz) = 401e46ec3450569dcce60d1d8ca22a19ab1f7f817b0cc730cdf4875ba608ac02
+SIZE (postfix/postfix-3.0.3.tar.gz) = 4240588