aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-15 05:16:47 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-15 05:16:47 +0800
commit1e69bd0d0e3a220fd7d12166fc968090b3539a99 (patch)
treed46cf47a55938b62139e1b374dbc441594172d49
parent524cdd07cf1ccb3a82c939de1a89a85dfebc1a3b (diff)
downloadfreebsd-ports-gnome-1e69bd0d0e3a220fd7d12166fc968090b3539a99.tar.gz
freebsd-ports-gnome-1e69bd0d0e3a220fd7d12166fc968090b3539a99.tar.zst
freebsd-ports-gnome-1e69bd0d0e3a220fd7d12166fc968090b3539a99.zip
- Add stage support
- Add DOCS option - Use PLIST_FILES instead of pkg-plist
-rw-r--r--games/xoids/Makefile14
-rw-r--r--games/xoids/pkg-plist3
2 files changed, 7 insertions, 10 deletions
diff --git a/games/xoids/Makefile b/games/xoids/Makefile
index be37c781a68d..2c8e1dc5b66d 100644
--- a/games/xoids/Makefile
+++ b/games/xoids/Makefile
@@ -13,18 +13,18 @@ COMMENT= X Window Asteroids style game with full color pixmaps
USES= imake
USE_XORG= xpm
-MAN6= xoids.6
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+PLIST_FILES= bin/xoids \
+ man/man6/xoids.6.gz
+PORTDOCS= README
+
+OPTIONS_DEFINE= DOCS
post-extract:
@${CP} ${WRKSRC}/xoids.1x ${WRKSRC}/xoids.man
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/games/xoids/pkg-plist b/games/xoids/pkg-plist
deleted file mode 100644
index 6daa43dcd738..000000000000
--- a/games/xoids/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-bin/xoids
-%%PORTDOCS%%share/doc/xoids/README
-%%PORTDOCS%%@dirrm share/doc/xoids