aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2012-08-09 10:31:54 +0800
committerwen <wen@FreeBSD.org>2012-08-09 10:31:54 +0800
commit1f9d5a8fd3907600146f8facf4124ad5f189b99e (patch)
tree6b8b206c9937bb2463c2965764f219eb8a1db4f0
parent2a328d258590ffe34445c8311dbfe143f9a25c49 (diff)
downloadfreebsd-ports-gnome-1f9d5a8fd3907600146f8facf4124ad5f189b99e.tar.gz
freebsd-ports-gnome-1f9d5a8fd3907600146f8facf4124ad5f189b99e.tar.zst
freebsd-ports-gnome-1f9d5a8fd3907600146f8facf4124ad5f189b99e.zip
- Repocopy www/moodle2 --> www/moodle22
- Update www/moodle2 to 2.3.1 - Update CONFLICTS PR: 169778 Submitted by: wen@(myself) Thanks to: Michael Tomasek <michael.tomasek@complete-solutions.net>
-rw-r--r--www/Makefile1
-rw-r--r--www/moodle2/Makefile10
-rw-r--r--www/moodle2/distinfo4
-rw-r--r--www/moodle22/Makefile90
-rw-r--r--www/moodle22/distinfo2
-rw-r--r--www/moodle22/files/pkg-message.in61
-rw-r--r--www/moodle22/pkg-descr7
7 files changed, 168 insertions, 7 deletions
diff --git a/www/Makefile b/www/Makefile
index bdabc9ce8a1f..4edba9a368c1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -540,6 +540,7 @@
SUBDIR += mongrel2
SUBDIR += moodle
SUBDIR += moodle2
+ SUBDIR += moodle22
SUBDIR += moonshine
SUBDIR += mozplugger
SUBDIR += multisort
diff --git a/www/moodle2/Makefile b/www/moodle2/Makefile
index de52d181bf5a..715b681c6972 100644
--- a/www/moodle2/Makefile
+++ b/www/moodle2/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= moodle
-PORTVERSION= 2.2.4
+PORTVERSION= 2.3.1
CATEGORIES= www
-MASTER_SITES= SF/moodle/Moodle/stable22/
+MASTER_SITES= SF/moodle/Moodle/stable23/
EXTRACT_SUFX= .tgz
MAINTAINER= wen@FreeBSD.org
@@ -17,11 +17,11 @@ COMMENT= Course management system based on social constructionism
BUILD_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
-CONFLICTS= moodle-1.*.* moodle-2.1.*
-LATEST_LINK= moodle22
+CONFLICTS= moodle-1.*.* moodle-2.2.*
+LATEST_LINK= moodle23
USE_PHP= session gd pcre mbstring iconv tokenizer curl xml xmlrpc ctype \
- soap openssl simplexml spl dom json zip zlib
+ soap openssl simplexml spl dom json zip zlib hash
WRKSRC= ${WRKDIR}/moodle
OPTIONS= MYSQL "Add support for a MySQL database server" On \
diff --git a/www/moodle2/distinfo b/www/moodle2/distinfo
index 5397062597e0..f20829b45957 100644
--- a/www/moodle2/distinfo
+++ b/www/moodle2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (moodle-2.2.4.tgz) = f093fa32b20247c47d258f2f99af97a4f1ee64a86a3397265da5d5569215110f
-SIZE (moodle-2.2.4.tgz) = 24974166
+SHA256 (moodle-2.3.1.tgz) = b09a6f15fdfde1a6acf3e94e69e6e175f80e0efa217d0cd88545c375b7c28770
+SIZE (moodle-2.3.1.tgz) = 28464309
diff --git a/www/moodle22/Makefile b/www/moodle22/Makefile
new file mode 100644
index 000000000000..9674ac1c2a43
--- /dev/null
+++ b/www/moodle22/Makefile
@@ -0,0 +1,90 @@
+# New ports collection makefile for: moodle
+# Date created: 30 September 2005
+# Whom: Javier Martin Rueda <jmrueda@diatel.upm.es>
+#
+# $FreeBSD$
+#
+
+PORTNAME= moodle
+PORTVERSION= 2.2.4
+CATEGORIES= www
+MASTER_SITES= SF/moodle/Moodle/stable22/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Course management system based on social constructionism
+
+BUILD_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/intl.so:${PORTSDIR}/devel/pecl-intl
+
+CONFLICTS= moodle-1.*.* moodle-2.3.*
+LATEST_LINK= moodle22
+
+USE_PHP= session gd pcre mbstring iconv tokenizer curl xml xmlrpc ctype \
+ soap openssl simplexml spl dom json zip zlib
+WRKSRC= ${WRKDIR}/moodle
+
+OPTIONS= MYSQL "Add support for a MySQL database server" On \
+ PGSQL "Add support for a PostgreSQL database server" Off \
+ MSSQL "Add support for a MS SQL Server" Off \
+ LDAP "Add LDAP authentication functionality" Off \
+ MIMETEX "Add mimeTeX filter functionality" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_MYSQL)
+USE_PHP+= mysqli
+.endif
+
+.if defined(WITH_PGSQL)
+USE_PHP+= pgsql
+.endif
+
+.if defined(WITH_MSSQL)
+USE_PHP+= mssql
+.endif
+
+.if defined(WITH_LDAP)
+USE_PHP+= ldap
+.endif
+
+.if defined(WITH_MIMETEX)
+RUN_DEPENDS+= ${LOCALBASE}/www/mimetex/cgi-bin/mimetex.cgi:${PORTSDIR}/www/mimetex
+.endif
+
+NO_BUILD= yes
+PLIST= ${WRKDIR}/plist
+SUB_FILES= pkg-message
+SUB_LIST= MOODLEDIR=${MOODLEDIR} \
+ MOODLEDATADIR=${MOODLEDATADIR}
+
+MOODLEDIR?= www/moodle
+MOODLEDATADIR?= moodledata
+
+pre-install:
+ @${FIND} -s -d ${WRKSRC} -type f | ${SED} "s?${WRKSRC}?${MOODLEDIR}?g" >${PLIST}
+ @${FIND} -s -d ${WRKSRC} -type d | ${SED} "s?${WRKSRC}?@dirrm ${MOODLEDIR}?g" >> ${PLIST}
+ @${ECHO} @dirrm ${MOODLEDATADIR} >> ${PLIST}
+
+do-install:
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} . ${PREFIX}/${MOODLEDIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDIR}' \
+ >> ${TMPPLIST}
+ ${CHMOD} -R 755 ${PREFIX}/${MOODLEDIR}
+ @${ECHO_CMD} '@exec ${CHMOD} -R 755 ${PREFIX}/${MOODLEDIR}' >> ${TMPPLIST}
+
+ @${INSTALL} -d ${PREFIX}/${MOODLEDATADIR}
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDATADIR}
+ @${ECHO_CMD} '@exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MOODLEDATADIR}' \
+ >> ${TMPPLIST}
+ ${CHMOD} 755 ${PREFIX}/${MOODLEDATADIR}
+ @${ECHO_CMD} '@exec ${CHMOD} 755 ${PREFIX}/${MOODLEDATADIR}' >> ${TMPPLIST}
+.if !defined(WITHOUT_MIMETEX)
+ ${LN} -sf ${PREFIX}/www/mimetex/cgi-bin/mimetex.cgi ${PREFIX}/${MOODLEDIR}/filter/tex/mimetex.freebsd
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/moodle22/distinfo b/www/moodle22/distinfo
new file mode 100644
index 000000000000..5397062597e0
--- /dev/null
+++ b/www/moodle22/distinfo
@@ -0,0 +1,2 @@
+SHA256 (moodle-2.2.4.tgz) = f093fa32b20247c47d258f2f99af97a4f1ee64a86a3397265da5d5569215110f
+SIZE (moodle-2.2.4.tgz) = 24974166
diff --git a/www/moodle22/files/pkg-message.in b/www/moodle22/files/pkg-message.in
new file mode 100644
index 000000000000..9380c51f6361
--- /dev/null
+++ b/www/moodle22/files/pkg-message.in
@@ -0,0 +1,61 @@
+POST-INSTALL CONFIGURATION FOR MOODLE
+=====================================
+
+1) Create a user and a database for Moodle to store all
+ its tables in (or choose an existing database).
+ It doesn't matter what the database or user names are,
+ as this will be configured in a later step.
+ NOTE: this package assumes that either the phpX-pgsql,
+ phpX-mysql, or phpX-mssql packages are installed.
+
+2) Add the following to your Apache configuration, and
+ restart the server:
+
+ ### Add the AcceptPathInfo directive only for Apache 2.0.30 or later.
+ Alias /moodle %%PREFIX%%/%%MOODLEDIR%%/
+ AcceptPathInfo On
+ <Directory %%PREFIX%%/%%MOODLEDIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Allow from all
+ </Directory>
+ <Directory %%PREFIX%%/%%MOODLEDATADIR%%>
+ AllowOverride None
+ Order Allow,Deny
+ Deny from all
+ </Directory>
+
+3) Visit your Moodle site with a browser (i.e.,
+ http://your.server.com/moodle/), and you should
+ be taken to the install.php script, which will lead
+ you through creating a config.php file and then
+ setting up Moodle, creating an admin account, etc.
+
+ At one step, you will get a message saying that the
+ installer script was not able to automatically create
+ the config.php file. Just download it and copy it to
+ %%PREFIX%%/%%MOODLEDIR%%/config.php. Beware that it
+ will contain the database password in cleartext, so
+ set up whatever file permissions you deem more adequate.
+ For instance, user=root, group=www, mask=640.
+
+4) Set up a cron task to invoke the file admin/cron.php
+ every five minutes or so. For instance:
+ */5 * * * * fetch http://your.server.com/moodle/admin/cron.php
+
+For more information, see the INSTALL DOCUMENTATION:
+
+ http://docs.moodle.org/en/Installing_Moodle
+
+It may be worth reading the installation docs even if Moodle seems
+to be working at first, to ensure your PHP settings and database
+configuration will allow Moodle to operate properly.
+
+If you are upgrading from an earlier version of Moodle, check out
+possible additional steps at:
+
+ http://docs.moodle.org/en/Upgrading
+ http://docs.moodle.org/en/Upgrading_to_Moodle_2.0
+
+If you have real trouble, please visit the Moodle course
+"Using Moodle" on moodle.org.
diff --git a/www/moodle22/pkg-descr b/www/moodle22/pkg-descr
new file mode 100644
index 000000000000..fe30e0d25bab
--- /dev/null
+++ b/www/moodle22/pkg-descr
@@ -0,0 +1,7 @@
+Moodle is a course management system (CMS) - a free, Open Source software
+package designed using sound pedagogical principles, to help educators
+create effective online learning communities. You can use it on any
+computer you have handy (including webhosts), yet it can scale from a
+single-teacher site to a 40,000-student University.
+
+WWW: http://www.moodle.org/