aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-23 16:00:53 +0800
committeredwin <edwin@FreeBSD.org>2004-12-23 16:00:53 +0800
commit20b89ee1ca097dd5f3a92b553ece9330200bd888 (patch)
treec89f7b48872ba62054f88bc4b84007a1ab86db87
parenta2a69cb7c7a620da3fabf8fe777f8b3c740bd51f (diff)
downloadfreebsd-ports-gnome-20b89ee1ca097dd5f3a92b553ece9330200bd888.tar.gz
freebsd-ports-gnome-20b89ee1ca097dd5f3a92b553ece9330200bd888.tar.zst
freebsd-ports-gnome-20b89ee1ca097dd5f3a92b553ece9330200bd888.zip
New port games/wormux.
Almost everyone has heard of the Worms(R) series of games, developed by Team17. Worms was created in 1990, the goal of the game consisting of a several teams of "worms" fighting to the death on a 2D map. Wormux is heavily influenced by all games in this genre, including Scorched Earth and Liero. Wormux is free software clone of this game concept. Though currently under heavy development, it is already very playable, with lots of weapons (Dynamite, Baseball Bat, Teleportation, etc.). There are also lots of maps available for your battling pleasure! Wormux takes the genre to the next level, with great customisation options leading to great gameplay. There is a wide selection of teams, from the Aliens to the Chickens. Also, new battlefields can be downloaded from the Internet, making strategy an important part of each battle. PR: ports/75186 Submitted by: Anton Yudin <toha@toha.org.ua>
-rw-r--r--games/Makefile1
-rw-r--r--games/warmux/Makefile44
-rw-r--r--games/warmux/distinfo2
-rw-r--r--games/warmux/pkg-descr14
-rw-r--r--games/wormux/Makefile44
-rw-r--r--games/wormux/distinfo2
-rw-r--r--games/wormux/pkg-descr14
7 files changed, 121 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 9f5bd0a82259..c4f80aaa0931 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -500,6 +500,7 @@
SUBDIR += wolf3d
SUBDIR += wolfpack
SUBDIR += wordplay
+ SUBDIR += wormux
SUBDIR += wtf
SUBDIR += x3eyes
SUBDIR += xabacus
diff --git a/games/warmux/Makefile b/games/warmux/Makefile
new file mode 100644
index 000000000000..2813888ccdb5
--- /dev/null
+++ b/games/warmux/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: wormux
+# Date created: Thu Dec 16 18:46:55 EET 2004
+# Whom: Anton Yudin <toha@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wormux
+PORTVERSION= 0.5.0
+CATEGORIES= games
+MASTER_SITES= http://download.gna.org/wormux/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= toha@toha.org.ua
+COMMENT= Wormux game
+
+USE_BZIP2= yes
+USE_SDL= sdl
+USE_GETTEXT= yes
+
+LIB_DEPENDS+= clanGUI-0.7:${PORTSDIR}/devel/clanlib-devel
+LIB_DEPENDS+= xml\\+\\+-1.0.1:${PORTSDIR}/textproc/libxml++
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/wormux
+
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+GNU_CONFIGURE=yes
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for dir in ${PREFIX}/share/${PORTNAME}
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/games/warmux/distinfo b/games/warmux/distinfo
new file mode 100644
index 000000000000..585748247f6d
--- /dev/null
+++ b/games/warmux/distinfo
@@ -0,0 +1,2 @@
+MD5 (wormux-src-0.5.0.tar.bz2) = e09c8a699da7a3a60e0c379b75986573
+SIZE (wormux-src-0.5.0.tar.bz2) = 18787309
diff --git a/games/warmux/pkg-descr b/games/warmux/pkg-descr
new file mode 100644
index 000000000000..7f56eef58d08
--- /dev/null
+++ b/games/warmux/pkg-descr
@@ -0,0 +1,14 @@
+Almost everyone has heard of the Worms(R) series of games, developed by Team17.
+Worms was created in 1990, the goal of the game consisting of a several teams of
+"worms" fighting to the death on a 2D map. Wormux is heavily influenced by all
+games in this genre, including Scorched Earth and Liero.
+
+Wormux is free software clone of this game concept. Though currently under heavy
+development, it is already very playable, with lots of weapons (Dynamite,
+Baseball Bat, Teleportation, etc.). There are also lots of maps available for
+your battling pleasure! Wormux takes the genre to the next level, with great
+customisation options leading to great gameplay. There is a wide selection of
+teams, from the Aliens to the Chickens. Also, new battlefields can be downloaded
+from the Internet, making strategy an important part of each battle.
+
+WWW: http://www.wormux.org/
diff --git a/games/wormux/Makefile b/games/wormux/Makefile
new file mode 100644
index 000000000000..2813888ccdb5
--- /dev/null
+++ b/games/wormux/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: wormux
+# Date created: Thu Dec 16 18:46:55 EET 2004
+# Whom: Anton Yudin <toha@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wormux
+PORTVERSION= 0.5.0
+CATEGORIES= games
+MASTER_SITES= http://download.gna.org/wormux/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= toha@toha.org.ua
+COMMENT= Wormux game
+
+USE_BZIP2= yes
+USE_SDL= sdl
+USE_GETTEXT= yes
+
+LIB_DEPENDS+= clanGUI-0.7:${PORTSDIR}/devel/clanlib-devel
+LIB_DEPENDS+= xml\\+\\+-1.0.1:${PORTSDIR}/textproc/libxml++
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+PLIST_FILES= bin/wormux
+
+CONFIGURE_ARGS+=--prefix=${PREFIX}
+GNU_CONFIGURE=yes
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.for dir in ${PREFIX}/share/${PORTNAME}
+ @${FIND} ${dir} ! -type d | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${dir} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+.endfor
+
+.include <bsd.port.post.mk>
diff --git a/games/wormux/distinfo b/games/wormux/distinfo
new file mode 100644
index 000000000000..585748247f6d
--- /dev/null
+++ b/games/wormux/distinfo
@@ -0,0 +1,2 @@
+MD5 (wormux-src-0.5.0.tar.bz2) = e09c8a699da7a3a60e0c379b75986573
+SIZE (wormux-src-0.5.0.tar.bz2) = 18787309
diff --git a/games/wormux/pkg-descr b/games/wormux/pkg-descr
new file mode 100644
index 000000000000..7f56eef58d08
--- /dev/null
+++ b/games/wormux/pkg-descr
@@ -0,0 +1,14 @@
+Almost everyone has heard of the Worms(R) series of games, developed by Team17.
+Worms was created in 1990, the goal of the game consisting of a several teams of
+"worms" fighting to the death on a 2D map. Wormux is heavily influenced by all
+games in this genre, including Scorched Earth and Liero.
+
+Wormux is free software clone of this game concept. Though currently under heavy
+development, it is already very playable, with lots of weapons (Dynamite,
+Baseball Bat, Teleportation, etc.). There are also lots of maps available for
+your battling pleasure! Wormux takes the genre to the next level, with great
+customisation options leading to great gameplay. There is a wide selection of
+teams, from the Aliens to the Chickens. Also, new battlefields can be downloaded
+from the Internet, making strategy an important part of each battle.
+
+WWW: http://www.wormux.org/