aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 02:58:41 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 02:58:41 +0800
commit20c87248173e86c87df5e40a851cc97d4e96c62a (patch)
tree724b94a8c6f0d02ef3043dedec85106c6fcbbf97
parent10bcfcea5fcdc6a653dc725b54fe702a0c2ff3b4 (diff)
downloadfreebsd-ports-gnome-20c87248173e86c87df5e40a851cc97d4e96c62a.tar.gz
freebsd-ports-gnome-20c87248173e86c87df5e40a851cc97d4e96c62a.tar.zst
freebsd-ports-gnome-20c87248173e86c87df5e40a851cc97d4e96c62a.zip
Atomic operations including CAS (compare-and-swap), fetch & add and variants
suitable for low-level shared-memory synchronization. The implementation is using GCC's builtin atomic operations (available in GCC >= 4) in C wrappers called through the FFI. WWW: http://hackage.haskell.org/package/bits-atomic Obtained from: FreeBSD Haskell
-rw-r--r--devel/hs-bits-atomic/Makefile21
-rw-r--r--devel/hs-bits-atomic/distinfo2
-rw-r--r--devel/hs-bits-atomic/pkg-descr6
-rw-r--r--lang/ghc/bsd.hackage.mk1
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/hs-bits-atomic/Makefile b/devel/hs-bits-atomic/Makefile
new file mode 100644
index 000000000000..cec27924e85d
--- /dev/null
+++ b/devel/hs-bits-atomic/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-bits-atomic
+# Date created: May 12, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= bits-atomic
+PORTVERSION= 0.1.3
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Atomic bit operations on memory locations
+
+LICENSE= BSD
+FILE_LICENSE= License.txt
+
+CABAL_SETUP= Setup.hs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-bits-atomic/distinfo b/devel/hs-bits-atomic/distinfo
new file mode 100644
index 000000000000..52e579d6dd8e
--- /dev/null
+++ b/devel/hs-bits-atomic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/bits-atomic-0.1.3.tar.gz) = e0ac3456cf0338e1d5ed33f4c3c6b932d652add2ac827c6a1b6636c6e754cb8d
+SIZE (cabal/bits-atomic-0.1.3.tar.gz) = 7982
diff --git a/devel/hs-bits-atomic/pkg-descr b/devel/hs-bits-atomic/pkg-descr
new file mode 100644
index 000000000000..59ff9d08254a
--- /dev/null
+++ b/devel/hs-bits-atomic/pkg-descr
@@ -0,0 +1,6 @@
+Atomic operations including CAS (compare-and-swap), fetch & add and variants
+suitable for low-level shared-memory synchronization. The implementation
+is using GCC's builtin atomic operations (available in GCC >= 4) in C
+wrappers called through the FFI.
+
+WWW: http://hackage.haskell.org/package/bits-atomic
diff --git a/lang/ghc/bsd.hackage.mk b/lang/ghc/bsd.hackage.mk
index 285f3b1155d8..8791fa1903f1 100644
--- a/lang/ghc/bsd.hackage.mk
+++ b/lang/ghc/bsd.hackage.mk
@@ -31,6 +31,7 @@ base16-bytestring_port= devel/hs-base16-bytestring
base64-bytestring_port= devel/hs-base64-bytestring
binary_port= devel/hs-binary
bio_port= science/hs-bio
+bits-atomic_port= devel/hs-bits-atomic
blaze-builder_port= devel/hs-blaze-builder
blaze-builder-enumerator_port= devel/hs-blaze-builder-enumerator
blaze-html_port= textproc/hs-blaze-html