aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-04-30 05:11:12 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-04-30 05:11:12 +0800
commit20cfe3a953a43735308b5eefa614ffd0162c7841 (patch)
tree12f739cd9e4fe8e7da96bfd6da32f003e9fdc0ec
parent24bce2b8c3fc4cbf963564c3ced6d2f161a93057 (diff)
downloadfreebsd-ports-gnome-20cfe3a953a43735308b5eefa614ffd0162c7841.tar.gz
freebsd-ports-gnome-20cfe3a953a43735308b5eefa614ffd0162c7841.tar.zst
freebsd-ports-gnome-20cfe3a953a43735308b5eefa614ffd0162c7841.zip
- Add py-enum34 0.9.23
- While I'm here: - Shorten COMMENT - Use . for COPYTREE_SHARE An enumeration is a set of symbolic names (members) bound to unique, constant values. Within an enumeration, the members can be compared by identity, and the enumeration itself can be iterated over. WWW: https://pypi.python.org/pypi/enum34 PR: ports/189073 Submitted by: Muhammad Moinur Rahman <5u623l20@gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-enum34/Makefile26
-rw-r--r--devel/py-enum34/distinfo2
-rw-r--r--devel/py-enum34/pkg-descr5
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1d483c516ad5..9589b0e5ba9d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3597,6 +3597,7 @@
SUBDIR += py-durus
SUBDIR += py-dynrules
SUBDIR += py-eggtestinfo
+ SUBDIR += py-enum34
SUBDIR += py-epsilon
SUBDIR += py-event
SUBDIR += py-experimental.cssselect
diff --git a/devel/py-enum34/Makefile b/devel/py-enum34/Makefile
new file mode 100644
index 000000000000..3dfdf1adcd3e
--- /dev/null
+++ b/devel/py-enum34/Makefile
@@ -0,0 +1,26 @@
+# Created by: Muhammad Moinur Rahman <5u623l20@gmail.com>
+# $FreeBSD$
+
+PORTNAME= enum34
+PORTVERSION= 0.9.23
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= 5u623l20@gmail.com
+COMMENT= Python 3.4 Enum backported to 3.3, 3.2, 3.1, 2.7
+
+LICENSE= BSD3CLAUSE
+
+USE_PYTHON= 2.7-3.3
+USE_PYDISTUTILS=yes
+PYDISTUTILS_AUTOPLIST= yes
+
+PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC}/enum/doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
+
+.include <bsd.port.mk>
diff --git a/devel/py-enum34/distinfo b/devel/py-enum34/distinfo
new file mode 100644
index 000000000000..69c9fc427257
--- /dev/null
+++ b/devel/py-enum34/distinfo
@@ -0,0 +1,2 @@
+SHA256 (enum34-0.9.23.tar.gz) = cfc05f11b5169c7b5c4adfae6de51cb8ad608c269b2496fbb75a115a5b572440
+SIZE (enum34-0.9.23.tar.gz) = 44720
diff --git a/devel/py-enum34/pkg-descr b/devel/py-enum34/pkg-descr
new file mode 100644
index 000000000000..14d6afe41ce5
--- /dev/null
+++ b/devel/py-enum34/pkg-descr
@@ -0,0 +1,5 @@
+An enumeration is a set of symbolic names (members) bound to unique, constant
+values. Within an enumeration, the members can be compared by identity, and
+the enumeration itself can be iterated over.
+
+WWW: https://pypi.python.org/pypi/enum34