aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-12-17 04:59:35 +0800
committerbapt <bapt@FreeBSD.org>2012-12-17 04:59:35 +0800
commit21422e24f7d9400fb589ecfccc5b063fa23a11c8 (patch)
treec7d9b0933e845fc3f65130010f00a10a2f7b0121
parentb70b2e9cffeec0e142da65ecb36059d5b563cc07 (diff)
downloadfreebsd-ports-gnome-21422e24f7d9400fb589ecfccc5b063fa23a11c8.tar.gz
freebsd-ports-gnome-21422e24f7d9400fb589ecfccc5b063fa23a11c8.tar.zst
freebsd-ports-gnome-21422e24f7d9400fb589ecfccc5b063fa23a11c8.zip
Convert to new options framework,
While here trim headers and fix pkgconfig dependency Approved by: decke (maintainer)
-rw-r--r--audio/vagalume/Makefile28
-rw-r--r--net-mgmt/nefu/Makefile20
2 files changed, 21 insertions, 27 deletions
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
index 459b449587f7..bded117dcf05 100644
--- a/audio/vagalume/Makefile
+++ b/audio/vagalume/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: vagalume
-# Date created: 2008-06-14
-# Whom: Bernhard Fröhlich <decke@bluelife.at>
-#
+# Created by: Bernhard Fröhlich <decke@bluelife.at>
# $FreeBSD$
-#
PORTNAME= vagalume
PORTVERSION= 0.8.5
@@ -21,18 +17,20 @@ LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= pkgconfig gtk20
+USE_GNOME= gtk20
+USE_PKGCONFIG= build
USE_GSTREAMER= good mad gconf
INSTALLS_ICONS= yes
MAN1= vagalume.1
-OPTIONS= DBUS "Build with DBUS support" on \
- TRAY "Build with tray icon and libnotify support" on
+OPTIONS_DEFINE= DBUS TRAY NLS GCONF
+OPTIONS_DEFAULT= DBUS TRAY
+TRAY_DESC= Tray icon and libnotify support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -41,7 +39,7 @@ PLIST_SUB+= NLS=""
PLIST_SUB+= NLS="@comment "
.endif
-.if !defined(WITHOUT_DBUS)
+.if ${PORT_OPTIONS:MDBUS}
CONFIGURE_ARGS+=--enable-dbus --enable-im-status
LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
PLIST_SUB+= DBUS=""
@@ -51,7 +49,7 @@ CONFIGURE_ARGS+=--disable-dbus --disable-im-status
PLIST_SUB+= DBUS="@comment "
.endif
-.if !defined(WITHOUT_TRAY)
+.if ${PORT_OPTIONS:MTRAY}
CONFIGURE_ARGS+=--enable-tray-icon
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libnotify.pc:${PORTSDIR}/devel/libnotify
LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
@@ -59,7 +57,7 @@ LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
CONFIGURE_ARGS+=--disable-tray-icon
.endif
-.if defined(WITH_GNOME)
+.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= gconf2
CONFIGURE_ARGS+=--enable-gconf
.endif
@@ -67,9 +65,9 @@ CONFIGURE_ARGS+=--enable-gconf
post-patch:
@${REINPLACE_CMD} -e 's|serviceentrydir = @serviceentrydir@|serviceentrydir = ${PREFIX}/share/dbus-1/services|' \
${WRKSRC}/Makefile.in
-.if defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's|SUBDIRS = src po|SUBDIRS = src|' \
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/nefu/Makefile b/net-mgmt/nefu/Makefile
index 46a6d2c0efd4..fdb95c99a48c 100644
--- a/net-mgmt/nefu/Makefile
+++ b/net-mgmt/nefu/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: nefu
-# Date created: 17.10.2003
-# Whom: Kirill Ponomarew <krion@FreeBSD.org>
-#
+# Created by: Kirill Ponomarew <krion@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= nefu
PORTVERSION= 1.5
@@ -32,24 +28,24 @@ USERS= nefu
GROUPS= nefu
USE_OPENSSL= yes
-OPTIONS= LDAP "Enable OpenLDAP support" off \
- HTML "Enable HTML support" off
+OPTIONS_DEFINE= LDAP HTML
+HTML_DESC= HTML support
MAN1= nefu.1
MAN4= nefu.conf.4
DBDIR= /var/db/nefu
PLIST_FILES= bin/nefu
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}/lib
.else
CONFIGURE_ARGS+= --without-ldap
.endif
-.if defined(WITH_HTML)
+.if ${PORT_OPTIONS:MHTML}
CONFIGURE_ARGS+=--with-html=${WWWDIR}
PLIST_FILES+= "@unexec rm -rf "%D/%%WWWDIR%%" 2> /dev/null || true"
.else
@@ -72,11 +68,11 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/nefu.conf.4 ${PREFIX}/man/man4
post-install:
-.if defined(WITH_HTML)
+.if ${PORT_OPTIONS:MHTML}
${MKDIR} ${WWWDIR}
${CHOWN} -R ${USERS}:${GROUPS} ${WWWDIR}
.endif
${MKDIR} ${DBDIR}
${CHOWN} -R ${USERS}:${GROUPS} ${DBDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>