aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-08-06 22:38:38 +0800
committeritetcu <itetcu@FreeBSD.org>2006-08-06 22:38:38 +0800
commit22740ada357b6ce59d1d0862037e7b6922dd1235 (patch)
treed7e999301d664d2dc7912f349f2b6ba04a1a6389
parenta54effcc096a399f206753320deaac3c919a28da (diff)
downloadfreebsd-ports-gnome-22740ada357b6ce59d1d0862037e7b6922dd1235.tar.gz
freebsd-ports-gnome-22740ada357b6ce59d1d0862037e7b6922dd1235.tar.zst
freebsd-ports-gnome-22740ada357b6ce59d1d0862037e7b6922dd1235.zip
- Use version-independent patching via sed
- Update to 2.17 Short changelog: - Add "-x NAME" to readelf in addition to "-x NUMBER". - Add -i and -t switches to cxxfilt. -i disables the display of implementation specific extra demangling information (if any) and -t disables the demangling of types. - Add support for the "@<file>" syntax to the command lines of all tools, so that extra switches can be read from <file>. - Add "-W/--dwarf" to objdump to display the contents of the DWARF debug sections. - Add "-t/--section-details" to readelf to display section details. "-N/--full-section-name" is deprecated. - powerpc-linux ld now supports a variant form of PLT and GOT for the security conscious. This form will automatically be chosen when ld detects that all code in regular object files was generated by gcc -msecure-plt. The old PLT and GOT may be forced by a new ld option, --bss-plt. - Add "-i/--inlines" to addr2line to print enclosing scope information for inlined function chains, back to first non-inlined function. - Add "-N/--full-section-name" to readelf to display full section name. - Add "-M entry:<addr>" switch to objdump to specify a function entry address when disassembling VAX binaries. - Add "--globalize-symbol <name>" and "--globalize-symbols <filename>" switches to objcopy to convert local symbols into global symbols. PR: ports/101447 Submitted by: Stanislav Sedov (maintainer)
-rw-r--r--devel/powerpc-binutils/Makefile9
-rw-r--r--devel/powerpc-binutils/distinfo6
-rw-r--r--devel/powerpc-binutils/files/patch-aa48
3 files changed, 11 insertions, 52 deletions
diff --git a/devel/powerpc-binutils/Makefile b/devel/powerpc-binutils/Makefile
index d33d3c2969fb..362718495d28 100644
--- a/devel/powerpc-binutils/Makefile
+++ b/devel/powerpc-binutils/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= binutils
-PORTVERSION= 2.16.1
+PORTVERSION= 2.17
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
@@ -61,6 +61,13 @@ BINARIES= addr2line ar as c++filt ld \
nm objcopy objdump ranlib \
readelf size strings strip
+post-extract:
+ @${REINPLACE_CMD} -E -e 's,^(install:).*,\1,' \
+ ${WRKSRC}/bfd/Makefile.in \
+ ${WRKSRC}/etc/Makefile.in \
+ ${WRKSRC}/libiberty/Makefile.in \
+ ${WRKSRC}/opcodes/Makefile.in
+
post-install:
.for F in ${BINARIES}
@${LN} -sf ${PREFIX}/bin/${PKGNAMEPREFIX}$F \
diff --git a/devel/powerpc-binutils/distinfo b/devel/powerpc-binutils/distinfo
index 03585c305a26..bade8e3a29f4 100644
--- a/devel/powerpc-binutils/distinfo
+++ b/devel/powerpc-binutils/distinfo
@@ -1,3 +1,3 @@
-MD5 (binutils-2.16.1.tar.bz2) = 6a9d529efb285071dad10e1f3d2b2967
-SHA256 (binutils-2.16.1.tar.bz2) = 351a6846ee179a37ed87a487971547159a7f4f92a1dec598c727f184a0de61ae
-SIZE (binutils-2.16.1.tar.bz2) = 12549917
+MD5 (binutils-2.17.tar.bz2) = e26e2e06b6e4bf3acf1dc8688a94c0d1
+SHA256 (binutils-2.17.tar.bz2) = e2c33ce6f23c9a366f109ced295626cb2f8bd6b2f08ff9df6dafb5448505a25e
+SIZE (binutils-2.17.tar.bz2) = 13795751
diff --git a/devel/powerpc-binutils/files/patch-aa b/devel/powerpc-binutils/files/patch-aa
deleted file mode 100644
index 05a50523a71e..000000000000
--- a/devel/powerpc-binutils/files/patch-aa
+++ /dev/null
@@ -1,48 +0,0 @@
---- libiberty/Makefile.in.orig Tue Mar 8 00:20:07 2005
-+++ libiberty/Makefile.in Thu Jun 30 22:37:45 2005
-@@ -270,7 +270,8 @@
- @MAINT@ echo stamp > stamp-functions
-
- INSTALL_DEST = @INSTALL_DEST@
--install: install_to_$(INSTALL_DEST) install-subdir
-+#install: install_to_$(INSTALL_DEST) install-subdir
-+install:
-
- install_to_libdir: all
- ${mkinstalldirs} $(DESTDIR)$(libdir)$(MULTISUBDIR)
---- bfd/Makefile.in.orig Mon May 2 21:45:46 2005
-+++ bfd/Makefile.in Thu Jun 30 22:39:28 2005
-@@ -1137,7 +1137,8 @@
- for dir in "$(DESTDIR)$(bfdlibdir)"; do \
- test -z "$$dir" || $(mkdir_p) "$$dir"; \
- done
--install: install-recursive
-+#install: install-recursive
-+install:
- install-exec: install-exec-recursive
- install-data: install-data-recursive
- uninstall: uninstall-recursive
---- opcodes/Makefile.in.orig Mon Feb 21 12:48:33 2005
-+++ opcodes/Makefile.in Thu Jun 30 22:39:18 2005
-@@ -781,7 +781,8 @@
- for dir in "$(DESTDIR)$(bfdlibdir)"; do \
- test -z "$$dir" || $(mkdir_p) "$$dir"; \
- done
--install: install-recursive
-+#install: install-recursive
-+install:
- install-exec: install-exec-recursive
- install-data: install-data-recursive
- uninstall: uninstall-recursive
---- etc/Makefile.in.orig Thu Jan 2 21:51:02 2003
-+++ etc/Makefile.in Thu Jun 30 22:37:45 2005
-@@ -54,7 +54,8 @@
- all:
-
- # We want install to imply install-info as per GNU standards.
--install: install-info
-+#install: install-info
-+install:
-
- uninstall:
-