aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2010-05-22 00:22:40 +0800
committernaddy <naddy@FreeBSD.org>2010-05-22 00:22:40 +0800
commit22a2c1c2a6ad16ea36eb8e89262f2e501955bf56 (patch)
treec179129767261fc1b66f507e5576630ad26a9f25
parentf5c882b4de57381a9d401fd985960b6c4444ebb9 (diff)
downloadfreebsd-ports-gnome-22a2c1c2a6ad16ea36eb8e89262f2e501955bf56.tar.gz
freebsd-ports-gnome-22a2c1c2a6ad16ea36eb8e89262f2e501955bf56.tar.zst
freebsd-ports-gnome-22a2c1c2a6ad16ea36eb8e89262f2e501955bf56.zip
The xz utils and lzma library have been imported into base, so make
the dependency on the archivers/xz port conditional on OSVERSION. Approved by: MAINTAINER
-rw-r--r--archivers/ark/Makefile2
-rw-r--r--archivers/deco/Makefile9
-rw-r--r--comms/kremotecontrol/Makefile2
-rw-r--r--deskutils/kcharselect/Makefile2
-rw-r--r--math/kcalc/Makefile2
-rw-r--r--misc/kdeutils4/Makefile2
-rw-r--r--security/kgpg-kde4/Makefile2
-rw-r--r--security/kwallet/Makefile2
-rw-r--r--sysutils/kdf/Makefile2
-rw-r--r--sysutils/kfloppy/Makefile2
-rw-r--r--sysutils/sweeper/Makefile2
-rw-r--r--sysutils/warden/Makefile11
-rw-r--r--x11/kde4-runtime/Makefile2
-rw-r--r--x11/kdebase4-runtime/Makefile2
-rw-r--r--x11/kdelibs4/Makefile2
15 files changed, 28 insertions, 18 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/archivers/deco/Makefile b/archivers/deco/Makefile
index 4e4f8f5a52b4..de771fbb7c4a 100644
--- a/archivers/deco/Makefile
+++ b/archivers/deco/Makefile
@@ -20,7 +20,6 @@ RUN_DEPENDS= arc:${PORTSDIR}/archivers/arc \
arj:${PORTSDIR}/archivers/arj \
cabextract:${PORTSDIR}/archivers/cabextract \
dpkg:${PORTSDIR}/archivers/dpkg \
- lzma:${PORTSDIR}/archivers/xz \
lzop:${PORTSDIR}/archivers/lzop \
7z:${PORTSDIR}/archivers/p7zip \
rpm:${PORTSDIR}/archivers/rpm \
@@ -48,4 +47,10 @@ do-install:
.endfor
@cd ${WRKDIR}/${PORTNAME}-archive-1.5.1/ && ${CP} -pPR * ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+RUN_DEPENDS+= lzma:${PORTSDIR}/archivers/xz
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/security/kgpg-kde4/Makefile b/security/kgpg-kde4/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/security/kgpg-kde4/Makefile
+++ b/security/kgpg-kde4/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/sysutils/kdf/Makefile b/sysutils/kdf/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/sysutils/kdf/Makefile
+++ b/sysutils/kdf/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/sysutils/kfloppy/Makefile b/sysutils/kfloppy/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/sysutils/kfloppy/Makefile
+++ b/sysutils/kfloppy/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index d5fafbfcb9cb..0c69fb6321cd 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -37,7 +37,7 @@ OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/sysutils/warden/Makefile b/sysutils/warden/Makefile
index 9415fb604e65..29cec80af777 100644
--- a/sysutils/warden/Makefile
+++ b/sysutils/warden/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= ftp://ftp.pcbsd.org/pub/software/ \
MAINTAINER= kmoore@freebsd.org
COMMENT= PC-BSD's Jail Management Utility
-RUN_DEPENDS= pbreg:${PORTSDIR}/sysutils/pbreg \
- xz:${PORTSDIR}/archivers/xz
+RUN_DEPENDS= pbreg:${PORTSDIR}/sysutils/pbreg
WRKSRC= ${WRKDIR}/warden
@@ -42,4 +41,10 @@ do-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
${QMAKE} -unix CONFIG+="configure" ${QMAKE_PRO}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
+RUN_DEPENDS+= xz:${PORTSDIR}/archivers/xz
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 07620680cf57..ff8cbd4a0b49 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -40,7 +40,7 @@ CMAKE_ARGS+= -DWITH_ALSA:BOOL=OFF
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 07620680cf57..ff8cbd4a0b49 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -40,7 +40,7 @@ CMAKE_ARGS+= -DWITH_ALSA:BOOL=OFF
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index c1392126fe61..6c35db687594 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -82,7 +82,7 @@ MAN8= kbuildsycoca4.8 \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 900012
+.if ${OSVERSION} < 800505 || (${OSVERSION} >= 900000 && ${OSVERSION} < 900012)
LIB_DEPENDS+= lzma.0:${PORTSDIR}/archivers/xz
.endif