aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2013-09-29 17:00:04 +0800
committerlme <lme@FreeBSD.org>2013-09-29 17:00:04 +0800
commit232ba184e8f2b253bdb780952d5079a6839d25a9 (patch)
tree1bc0a2b66f816d454154ae1bb7f3517fc7d3cfe2
parentfc55f576d6460d5a16dab6903c9681a6367fe43e (diff)
downloadfreebsd-ports-gnome-232ba184e8f2b253bdb780952d5079a6839d25a9.tar.gz
freebsd-ports-gnome-232ba184e8f2b253bdb780952d5079a6839d25a9.tar.zst
freebsd-ports-gnome-232ba184e8f2b253bdb780952d5079a6839d25a9.zip
Add a slave port to pnp: pnp-icinga to use PNP with Icinga.
Approved by: portmgr (bapt)
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/pnp-icinga/Makefile18
-rw-r--r--net-mgmt/pnp/Makefile6
3 files changed, 22 insertions, 3 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 8872a112b2b3..50d3ec0adfee 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -262,6 +262,7 @@
SUBDIR += pixilate
SUBDIR += pmacct
SUBDIR += pnp
+ SUBDIR += pnp-icinga
SUBDIR += portmon
SUBDIR += py-flowtools
SUBDIR += py-ipcalc
diff --git a/net-mgmt/pnp-icinga/Makefile b/net-mgmt/pnp-icinga/Makefile
new file mode 100644
index 000000000000..4ae3b46fef3c
--- /dev/null
+++ b/net-mgmt/pnp-icinga/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -icinga
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Icinga performance data collector and grapher
+
+MASTERDIR= ${.CURDIR}/../pnp
+
+RUN_DEPENDS= ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool \
+ icinga:${PORTSDIR}/net-mgmt/icinga
+
+NAGIOSDIR?= /var/spool/icinga
+NAGIOSHTMURL?= /icinga
+NAGIOSUSER?= icinga
+NAGIOSGROUP?= icinga
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net-mgmt/pnp/Makefile b/net-mgmt/pnp/Makefile
index 89e0f677725b..ae4c87279d16 100644
--- a/net-mgmt/pnp/Makefile
+++ b/net-mgmt/pnp/Makefile
@@ -8,13 +8,13 @@ MASTER_SITES= SF
MASTER_SITE_SUBDIR=pnp4nagios/PNP-0.6
DISTNAME= pnp4nagios-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
-MAINTAINER= rea@FreeBSD.org
-COMMENT= Nagios performance data collector and grapher
+MAINTAINER?= rea@FreeBSD.org
+COMMENT?= Nagios performance data collector and grapher
LICENSE= GPLv2
BUILD_DEPENDS= ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool
-RUN_DEPENDS= ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool \
+RUN_DEPENDS?= ${LOCALBASE}/bin/rrdtool:${PORTSDIR}/databases/rrdtool \
nagios:${PORTSDIR}/net-mgmt/nagios
MAKE_JOBS_UNSAFE= yes