aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-03-10 05:25:46 +0800
committermarino <marino@FreeBSD.org>2014-03-10 05:25:46 +0800
commit261afc8aefbfaa2d775f54a94b965ca1ed5c0246 (patch)
tree18cef137b7b6030159c2827ca95d10baa53965c8
parent0913263fa9acb0b4e152df8f2835901fb07389c8 (diff)
downloadfreebsd-ports-gnome-261afc8aefbfaa2d775f54a94b965ca1ed5c0246.tar.gz
freebsd-ports-gnome-261afc8aefbfaa2d775f54a94b965ca1ed5c0246.tar.zst
freebsd-ports-gnome-261afc8aefbfaa2d775f54a94b965ca1ed5c0246.zip
Uses/ada.mk: Add support for soon-to-be-older Ada compiler
Currently the Ada framework uses a single compiler based on gcc47. Soon this compiler will be updated to the gcc49 base, but not all Ada ports are currently happy about this. This update to ada.mk induces the ARGS of "47" which causes the port to use the newly-created lang/gcc47-aux port which is currently a clone of lang/gcc-aux. When the latter is updated, the Ada Framework will use it except for those ports that feature "USES+= ada:47"
-rw-r--r--Mk/Uses/ada.mk18
1 files changed, 10 insertions, 8 deletions
diff --git a/Mk/Uses/ada.mk b/Mk/Uses/ada.mk
index fd5b0e4d964b..ff26d9605260 100644
--- a/Mk/Uses/ada.mk
+++ b/Mk/Uses/ada.mk
@@ -6,22 +6,24 @@
#
# Feature: ada
# Usage: USES=ada
-# Valid ARGS: does not require args
+# Valid ARGS: 47
.if !defined(_INCLUDE_USES_ADA_MK)
_INCLUDE_USES_ADA_MK= yes
-.if defined(ada_ARGS)
-IGNORE= USES=ada does not require args
-.endif
+CC= ada
-CC= ada
+. if defined(ada_ARGS) && ${ada_ARGS} == 47
+BUILD_DEPENDS+= ${LOCALBASE}/gcc47-aux/bin/ada:${PORTSDIR}/lang/gcc47-aux
+MAKE_ENV+= PATH=${LOCALBASE}/gcc47-aux/bin:${PATH}
+CONFIGURE_ENV+= PATH=${LOCALBASE}/gcc47-aux/bin:${PATH}
+. else
BUILD_DEPENDS+= ${LOCALBASE}/gcc-aux/bin/ada:${PORTSDIR}/lang/gcc-aux
-
MAKE_ENV+= PATH=${LOCALBASE}/gcc-aux/bin:${PATH}
-MAKE_ENV+= ADA_PROJECT_PATH=${LOCALBASE}/lib/gnat
-
CONFIGURE_ENV+= PATH=${LOCALBASE}/gcc-aux/bin:${PATH}
+. endif
+
+MAKE_ENV+= ADA_PROJECT_PATH=${LOCALBASE}/lib/gnat
CONFIGURE_ENV+= ADA_PROJECT_PATH=${LOCALBASE}/lib/gnat
.endif