aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2012-10-16 04:32:02 +0800
committerolivierd <olivierd@FreeBSD.org>2012-10-16 04:32:02 +0800
commit273762f769f6b9d22ea1f0fd221c1ce0b408fcb1 (patch)
treed45e73e06831bb73231755a2800f3879c387a5bf
parentddc3ae6cf9514491123d4a8bbd57d204e2ab8a0a (diff)
downloadfreebsd-ports-gnome-273762f769f6b9d22ea1f0fd221c1ce0b408fcb1.tar.gz
freebsd-ports-gnome-273762f769f6b9d22ea1f0fd221c1ce0b408fcb1.tar.zst
freebsd-ports-gnome-273762f769f6b9d22ea1f0fd221c1ce0b408fcb1.zip
- Update to 4.10.0
- Cleanup Makefile header - Use USE_PKGCONFIG - Add new option, KEYBIND (for multimedia keys) Approved by: rene, miwi (mentors) Feature safe: yes
-rw-r--r--audio/xfce4-mixer/Makefile47
-rw-r--r--audio/xfce4-mixer/distinfo4
-rw-r--r--audio/xfce4-mixer/pkg-plist115
3 files changed, 76 insertions, 90 deletions
diff --git a/audio/xfce4-mixer/Makefile b/audio/xfce4-mixer/Makefile
index c4309b8eaf6e..b83661cb1d36 100644
--- a/audio/xfce4-mixer/Makefile
+++ b/audio/xfce4-mixer/Makefile
@@ -1,37 +1,54 @@
-# New ports collection makefile for: xfce4-mixer
-# Date created: 3 July 2003
-# Whom: James Earl <jdearl@telus.net>
-#
+# Created by: James Earl <jdearl@telus.net>
# $FreeBSD$
#
PORTNAME= xfce4-mixer
-PORTVERSION= 4.8.0
-PORTREVISION= 2
+PORTVERSION= 4.10.0
CATEGORIES= audio xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
-MASTER_SITE_SUBDIR=/src/apps/${PORTNAME}/4.8
+MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= Xfce 4 volume mixer module for xfce4-panel
+COMMENT= A volume control for the Xfce desktop
-BUILD_DEPENDS+= gstreamer-plugins-good>=0.10.22:${PORTSDIR}/multimedia/gstreamer-plugins-good
-RUN_DEPENDS+= gstreamer-plugins-good>=0.10.22:${PORTSDIR}/multimedia/gstreamer-plugins-good
+LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ unique-1:${PORTSDIR}/x11-toolkits/unique
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 intltool intlhack libxml2 pkgconfig
-USE_XFCE= configenv libgui libutil panel xfconf
-USE_XORG= xproto x11 xrender xext xinerama xrandr xcursor xcomposite \
- xdamage xfixes xi xau xdmcp
+USE_GNOME= gnomehack glib20 gtk20 intltool intlhack desktopfileutils
+USE_XFCE= configenv libmenu libutil panel xfconf
+USE_PKGCONFIG= build
+USE_GSTREAMER= yes
MAKE_JOBS_UNSAFE= yes
+OPTIONS_DEFINE= KEYBIND
+
+KEYBIND_DESC= Global keyboard shortcuts
+
+MAN1= xfce4-mixer.1
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MKEYBIND}
+LIB_DEPENDS+= keybinder:${PORTSDIR}/x11/keybinder
+CONFIGURE_ARGS+=--enable-keybinder
+.else
+CONFIGURE_ARGS+=--disable-keybinder
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} -name 'Makefile.in' -type f \
+ | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|(pkgdatadir)/icons|(datadir)/icons| ; \
+ s|pixmaps/xfce4-mixer|pixmaps|'
+
+post-install:
+ @-update-desktop-database
.include <bsd.port.mk>
diff --git a/audio/xfce4-mixer/distinfo b/audio/xfce4-mixer/distinfo
index c1ad06588cf0..5ce7f52defcb 100644
--- a/audio/xfce4-mixer/distinfo
+++ b/audio/xfce4-mixer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-mixer-4.8.0.tar.bz2) = 9f9f48fdd0d3f6b1e46694b93a44d15b800db72a96d831b5111d9ac976970fab
-SIZE (xfce4/xfce4-mixer-4.8.0.tar.bz2) = 494990
+SHA256 (xfce4/xfce4-mixer-4.10.0.tar.bz2) = a8c589001b438171ea5a6b46ce9895c3ffbc5081ab67805ab9870e540068dade
+SIZE (xfce4/xfce4-mixer-4.10.0.tar.bz2) = 461526
diff --git a/audio/xfce4-mixer/pkg-plist b/audio/xfce4-mixer/pkg-plist
index cf60ec824d84..5a4065286949 100644
--- a/audio/xfce4-mixer/pkg-plist
+++ b/audio/xfce4-mixer/pkg-plist
@@ -1,104 +1,73 @@
bin/xfce4-mixer
-libexec/xfce4/panel-plugins/xfce4-mixer-plugin
+lib/xfce4/panel/plugins/libmixer.la
+lib/xfce4/panel/plugins/libmixer.so
share/applications/xfce4-mixer.desktop
-share/locale/ast/LC_MESSAGES/xfce4-mixer.mo
-share/locale/lv/LC_MESSAGES/xfce4-mixer.mo
-share/locale/ro/LC_MESSAGES/xfce4-mixer.mo
-share/locale/sk/LC_MESSAGES/xfce4-mixer.mo
-share/locale/ur/LC_MESSAGES/xfce4-mixer.mo
-share/locale/ur_PK/LC_MESSAGES/xfce4-mixer.mo
share/locale/am/LC_MESSAGES/xfce4-mixer.mo
share/locale/ar/LC_MESSAGES/xfce4-mixer.mo
+share/locale/ast/LC_MESSAGES/xfce4-mixer.mo
+share/locale/bg/LC_MESSAGES/xfce4-mixer.mo
share/locale/ca/LC_MESSAGES/xfce4-mixer.mo
share/locale/cs/LC_MESSAGES/xfce4-mixer.mo
share/locale/da/LC_MESSAGES/xfce4-mixer.mo
share/locale/de/LC_MESSAGES/xfce4-mixer.mo
+share/locale/el/LC_MESSAGES/xfce4-mixer.mo
+share/locale/en_GB/LC_MESSAGES/xfce4-mixer.mo
share/locale/es/LC_MESSAGES/xfce4-mixer.mo
share/locale/eu/LC_MESSAGES/xfce4-mixer.mo
share/locale/fi/LC_MESSAGES/xfce4-mixer.mo
share/locale/fr/LC_MESSAGES/xfce4-mixer.mo
share/locale/gl/LC_MESSAGES/xfce4-mixer.mo
+share/locale/he/LC_MESSAGES/xfce4-mixer.mo
+share/locale/hr/LC_MESSAGES/xfce4-mixer.mo
share/locale/hu/LC_MESSAGES/xfce4-mixer.mo
share/locale/id/LC_MESSAGES/xfce4-mixer.mo
+share/locale/is/LC_MESSAGES/xfce4-mixer.mo
share/locale/it/LC_MESSAGES/xfce4-mixer.mo
share/locale/ja/LC_MESSAGES/xfce4-mixer.mo
+share/locale/kk/LC_MESSAGES/xfce4-mixer.mo
+share/locale/ko/LC_MESSAGES/xfce4-mixer.mo
+share/locale/lt/LC_MESSAGES/xfce4-mixer.mo
+share/locale/lv/LC_MESSAGES/xfce4-mixer.mo
share/locale/nb/LC_MESSAGES/xfce4-mixer.mo
share/locale/nl/LC_MESSAGES/xfce4-mixer.mo
+share/locale/nn/LC_MESSAGES/xfce4-mixer.mo
share/locale/pl/LC_MESSAGES/xfce4-mixer.mo
-share/locale/pt_BR/LC_MESSAGES/xfce4-mixer.mo
share/locale/pt/LC_MESSAGES/xfce4-mixer.mo
+share/locale/pt_BR/LC_MESSAGES/xfce4-mixer.mo
+share/locale/ro/LC_MESSAGES/xfce4-mixer.mo
share/locale/ru/LC_MESSAGES/xfce4-mixer.mo
share/locale/si/LC_MESSAGES/xfce4-mixer.mo
+share/locale/sk/LC_MESSAGES/xfce4-mixer.mo
+share/locale/sr/LC_MESSAGES/xfce4-mixer.mo
share/locale/sv/LC_MESSAGES/xfce4-mixer.mo
share/locale/tr/LC_MESSAGES/xfce4-mixer.mo
+share/locale/ug/LC_MESSAGES/xfce4-mixer.mo
share/locale/uk/LC_MESSAGES/xfce4-mixer.mo
+share/locale/ur/LC_MESSAGES/xfce4-mixer.mo
+share/locale/ur_PK/LC_MESSAGES/xfce4-mixer.mo
+share/locale/vi/LC_MESSAGES/xfce4-mixer.mo
share/locale/zh_CN/LC_MESSAGES/xfce4-mixer.mo
-share/pixmaps/xfce4-mixer/chain-broken.png
-share/pixmaps/xfce4-mixer/chain.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-muted.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-ultra-low.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-low.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-low-medium.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-medium.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-high.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-volume-very-high.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-record.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-no-record.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-muted.png
-share/xfce4-mixer/icons/hicolor/16x16/status/xfce4-mixer-no-muted.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-muted.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-ultra-low.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-low.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-low-medium.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-medium.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-high.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-volume-very-high.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-record.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-no-record.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-muted.png
-share/xfce4-mixer/icons/hicolor/24x24/status/xfce4-mixer-no-muted.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-muted.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-ultra-low.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-low.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-low-medium.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-medium.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-high.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-volume-very-high.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-record.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-no-record.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-muted.png
-share/xfce4-mixer/icons/hicolor/48x48/status/xfce4-mixer-no-muted.png
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-muted.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-ultra-low.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-low.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-low-medium.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-medium.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-high.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-volume-very-high.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-record.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-no-record.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-muted.svg
-share/xfce4-mixer/icons/hicolor/scalable/status/xfce4-mixer-no-muted.svg
-share/xfce4/panel-plugins/xfce4-mixer-plugin.desktop
-@dirrmtry libexec/xfce4/panel-plugins
-@dirrmtry libexec/xfce4
-@dirrm share/pixmaps/xfce4-mixer
-@dirrmtry share/xfce4/panel-plugins
-@dirrmtry share/xfce4
-@dirrm share/xfce4-mixer/icons/hicolor/16x16/status
-@dirrm share/xfce4-mixer/icons/hicolor/16x16
-@dirrm share/xfce4-mixer/icons/hicolor/24x24/status
-@dirrm share/xfce4-mixer/icons/hicolor/24x24
-@dirrm share/xfce4-mixer/icons/hicolor/48x48/status
-@dirrm share/xfce4-mixer/icons/hicolor/48x48
-@dirrm share/xfce4-mixer/icons/hicolor/scalable/status
-@dirrm share/xfce4-mixer/icons/hicolor/scalable
-@dirrm share/xfce4-mixer/icons/hicolor
-@dirrm share/xfce4-mixer/icons
-@dirrm share/xfce4-mixer
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
+share/locale/zh_TW/LC_MESSAGES/xfce4-mixer.mo
+share/pixmaps/chain-broken.png
+share/pixmaps/chain.png
+share/icons/hicolor/16x16/status/audio-input-microphone-muted.png
+share/icons/hicolor/scalable/status/audio-input-microphone-muted.svg
+share/xfce4/panel/plugins/mixer.desktop
+@dirrmtry share/xfce4/panel/plugins
+@dirrmtry share/xfce4/panel
@dirrmtry share/locale/ur_PK/LC_MESSAGES
@dirrmtry share/locale/ur_PK
@dirrmtry share/locale/ur/LC_MESSAGES
@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/si/LC_MESSAGES
+@dirrmtry share/locale/si
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
+@dirrmtry lib/xfce4/panel/plugins
+@dirrmtry lib/xfce4/panel
+@exec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database >/dev/null || /usr/bin/true