aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-08-04 09:38:56 +0800
committerade <ade@FreeBSD.org>2000-08-04 09:38:56 +0800
commit279525d448469037000d02ce7ad897533d49d6aa (patch)
tree254422a632438012dce2470d337bed6ba0741c21
parent3e67804d709e34d749caa36729ea54b374435d71 (diff)
downloadfreebsd-ports-gnome-279525d448469037000d02ce7ad897533d49d6aa.tar.gz
freebsd-ports-gnome-279525d448469037000d02ce7ad897533d49d6aa.tar.zst
freebsd-ports-gnome-279525d448469037000d02ce7ad897533d49d6aa.zip
Add an etc/rc.d startup file to ldconfig the pilot-link
libraries at system reboot, since they're installed in a non-standard place.
-rw-r--r--palm/pilot-link-devel/Makefile6
-rw-r--r--palm/pilot-link-devel/pkg-plist3
-rw-r--r--palm/pilot-link/Makefile6
-rw-r--r--palm/pilot-link/pkg-plist3
4 files changed, 18 insertions, 0 deletions
diff --git a/palm/pilot-link-devel/Makefile b/palm/pilot-link-devel/Makefile
index f2bda596885a..a13a442a1579 100644
--- a/palm/pilot-link-devel/Makefile
+++ b/palm/pilot-link-devel/Makefile
@@ -28,4 +28,10 @@ MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
pilot-xfer.1 read-ical.1
MAN7= pilot-link.7
+post-install:
+ @${ECHO} "#!/bin/sh" > ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @${ECHO} "" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @${ECHO} "${LDCONFIG} -m ${PREFIX}/lib" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @${CHMOD} 750 ${LOCALBASE}/etc/rc.d/pilot-link.sh
+
.include <bsd.port.mk>
diff --git a/palm/pilot-link-devel/pkg-plist b/palm/pilot-link-devel/pkg-plist
index 27aa21366450..534e4468a8f8 100644
--- a/palm/pilot-link-devel/pkg-plist
+++ b/palm/pilot-link-devel/pkg-plist
@@ -1,3 +1,6 @@
+@cwd /usr/local
+etc/rc.d/pilot-link.sh
+@cwd /usr/local/pilot
bin/addresses
bin/ccexample
bin/debugsh
diff --git a/palm/pilot-link/Makefile b/palm/pilot-link/Makefile
index f2bda596885a..a13a442a1579 100644
--- a/palm/pilot-link/Makefile
+++ b/palm/pilot-link/Makefile
@@ -28,4 +28,10 @@ MAN1= dlpsh.1 ietf2datebook.1 install-datebook.1 \
pilot-xfer.1 read-ical.1
MAN7= pilot-link.7
+post-install:
+ @${ECHO} "#!/bin/sh" > ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @${ECHO} "" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @${ECHO} "${LDCONFIG} -m ${PREFIX}/lib" >> ${LOCALBASE}/etc/rc.d/pilot-link.sh
+ @${CHMOD} 750 ${LOCALBASE}/etc/rc.d/pilot-link.sh
+
.include <bsd.port.mk>
diff --git a/palm/pilot-link/pkg-plist b/palm/pilot-link/pkg-plist
index 27aa21366450..534e4468a8f8 100644
--- a/palm/pilot-link/pkg-plist
+++ b/palm/pilot-link/pkg-plist
@@ -1,3 +1,6 @@
+@cwd /usr/local
+etc/rc.d/pilot-link.sh
+@cwd /usr/local/pilot
bin/addresses
bin/ccexample
bin/debugsh