aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-01-12 14:57:31 +0800
committerahze <ahze@FreeBSD.org>2005-01-12 14:57:31 +0800
commit28821212940572ca08c8a785c65baaa1e1a9d914 (patch)
treefcf4cd22e79ab315e1574d57e6d865d8e54b85ac
parentd6e2832fef8c37e5bd7d8b4f0f7e095c0ace8893 (diff)
downloadfreebsd-ports-gnome-28821212940572ca08c8a785c65baaa1e1a9d914.tar.gz
freebsd-ports-gnome-28821212940572ca08c8a785c65baaa1e1a9d914.tar.zst
freebsd-ports-gnome-28821212940572ca08c8a785c65baaa1e1a9d914.zip
Add skippy-xd
Skippy-XD is a version of Skippy that uses Xserver's XDamage, XComposite and XFixes extensions to provide you with 'live' versions of the windows. Skippy-XD is best described as a full-screen task-switcher for X11. It tries to provide an alternative when taskbars or regular task-switchers aren't the most efficient way of switching tasks (like when you have a lot of applications open) When activated (currently only through a hotkey), it will arrange and scale snapshots of all windows on the current desktop and it'll let you pick a window using a mouse or a keyboard. Yes, this is also what expocity and Apple's Expose. PR: ports/66921
-rw-r--r--x11-wm/Makefile1
-rw-r--r--x11-wm/skippy-xd/Makefile47
-rw-r--r--x11-wm/skippy-xd/distinfo2
-rw-r--r--x11-wm/skippy-xd/files/patch-config.c22
-rw-r--r--x11-wm/skippy-xd/files/patch-skippy.h10
-rw-r--r--x11-wm/skippy-xd/pkg-descr12
-rw-r--r--x11-wm/skippy-xd/pkg-message14
7 files changed, 108 insertions, 0 deletions
diff --git a/x11-wm/Makefile b/x11-wm/Makefile
index 28f01c1ff434..620c4a9bd939 100644
--- a/x11-wm/Makefile
+++ b/x11-wm/Makefile
@@ -87,6 +87,7 @@
SUBDIR += sawfish2
SUBDIR += selectwm
SUBDIR += skippy
+ SUBDIR += skippy-xd
SUBDIR += swm
SUBDIR += tpager
SUBDIR += treewm
diff --git a/x11-wm/skippy-xd/Makefile b/x11-wm/skippy-xd/Makefile
new file mode 100644
index 000000000000..c3ac4080f942
--- /dev/null
+++ b/x11-wm/skippy-xd/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: skippy-xd
+# Date created: 2004-05-19
+# Whom: michael johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= skippy-xd
+PORTVERSION= 0.5.0
+CATEGORIES= x11-wm
+MASTER_SITES= http://thegraveyard.org/files/
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= A full-screen X11 task-switcher like Apple's Expose
+
+LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+
+USE_BZIP2= yes
+USE_GNOME= pkgconfig
+USE_REINPLACE= yes
+PLIST_FILES= bin/skippy-xd \
+ %%DATADIR%%/skippy-xd.rc-default
+PLIST_DIRS= %%DATADIR%%
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/X11R6|${X11BASE}|; \
+ s|/usr/local|${LOCALBASE}|; s|gcc|${CC}|' \
+ ${WRKSRC}/Makefile
+post-build:
+ @${SED} 's|%%DATADIR%%|${DATADIR}|' ${PKGDIR}/pkg-message >${PKGMESSAGE}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/skippy-xd ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/skippy-xd.rc-default ${DATADIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xorg
+BROKEN= XFree86 does not support XComposite.
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-wm/skippy-xd/distinfo b/x11-wm/skippy-xd/distinfo
new file mode 100644
index 000000000000..735defd6fc85
--- /dev/null
+++ b/x11-wm/skippy-xd/distinfo
@@ -0,0 +1,2 @@
+MD5 (skippy-xd-0.5.0.tar.bz2) = 0e847845c4cb8c16f79bc4538ae288ad
+SIZE (skippy-xd-0.5.0.tar.bz2) = 23970
diff --git a/x11-wm/skippy-xd/files/patch-config.c b/x11-wm/skippy-xd/files/patch-config.c
new file mode 100644
index 000000000000..4dfcce54a0fa
--- /dev/null
+++ b/x11-wm/skippy-xd/files/patch-config.c
@@ -0,0 +1,22 @@
+--- config.c.orig Mon Jul 5 22:36:39 2004
++++ config.c Mon Jul 5 23:32:25 2004
+@@ -72,9 +72,9 @@
+ int ix = 0, l_ix = 0;
+ dlist *new_config = 0;
+
+- regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*?)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_section, "^[[:space:]]*\\[[[:space:]]*([[:alnum:]]*)[[:space:]]*\\][[:space:]]*$", REG_EXTENDED);
+ regcomp(&re_empty, "^[[:space:]]*#|^[[:space:]]*$", REG_EXTENDED);
+- regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*?)[[:space:]]*$", REG_EXTENDED);
++ regcomp(&re_entry, "^[[:space:]]*([[:alnum:]]+)[[:space:]]*=[[:space:]]*(.*)[[:space:]]*$", REG_EXTENDED);
+
+ while(1)
+ {
+@@ -148,6 +148,7 @@
+ fclose(fin);
+ return 0;
+ }
++ data[flen] = '\0';
+
+ fclose(fin);
+
diff --git a/x11-wm/skippy-xd/files/patch-skippy.h b/x11-wm/skippy-xd/files/patch-skippy.h
new file mode 100644
index 000000000000..399e91f56fb8
--- /dev/null
+++ b/x11-wm/skippy-xd/files/patch-skippy.h
@@ -0,0 +1,10 @@
+--- skippy.h.orig Sat May 15 19:33:08 2004
++++ skippy.h Sat May 15 19:33:44 2004
+@@ -20,6 +20,7 @@
+ #ifndef SKIPPY_H
+ #define SKIPPY_H
+
++#include <ft2build.h>
+ #include <X11/Xlib.h>
+ #include <X11/Xmd.h>
+ #include <X11/Xatom.h>
diff --git a/x11-wm/skippy-xd/pkg-descr b/x11-wm/skippy-xd/pkg-descr
new file mode 100644
index 000000000000..0fd31ff74e0b
--- /dev/null
+++ b/x11-wm/skippy-xd/pkg-descr
@@ -0,0 +1,12 @@
+Skippy-XD is a version of Skippy that uses Xserver's XDamage, XComposite and
+XFixes extensions to provide you with 'live' versions of the windows.
+
+Skippy-XD is best described as a full-screen task-switcher for X11. It tries to
+provide an alternative when taskbars or regular task-switchers aren't the most
+efficient way of switching tasks (like when you have a lot of applications open)
+When activated (currently only through a hotkey), it will arrange and scale
+snapshots of all windows on the current desktop and it'll let you pick a
+window using a mouse or a keyboard. Yes, this is also what expocity and Apple's
+Expose.
+
+WWW: http://thegraveyard.org/skippy.php
diff --git a/x11-wm/skippy-xd/pkg-message b/x11-wm/skippy-xd/pkg-message
new file mode 100644
index 000000000000..5b1bf3b46218
--- /dev/null
+++ b/x11-wm/skippy-xd/pkg-message
@@ -0,0 +1,14 @@
+*******************************************************************************
+A sample configuration file, skippy-xd.rc-default, has been installed in
+%%DATADIR%%. To edit the default confiuration of skippy please
+'cp %%DATADIR%%/skippy-xd.rc-default ~/.skippy-xd.rc'
+
+You will also need to manually enable the X Composite Extension from Xorg
+by adding the following to your xorg.conf file which is normally found
+in /etc/X11/xorg.conf.
+
+ Section "Extensions"
+ Option "Composite" "Enable"
+ EndSection
+
+*******************************************************************************