aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-04-18 14:58:36 +0800
committeredwin <edwin@FreeBSD.org>2003-04-18 14:58:36 +0800
commit2a894ea487d890f27a87f4a31182954e3b7b8e3d (patch)
tree780d631d3d6a149905f68f55b1cda83c459a6308
parentaffbefb6f014a30493458138fd498728b74c66c2 (diff)
downloadfreebsd-ports-gnome-2a894ea487d890f27a87f4a31182954e3b7b8e3d.tar.gz
freebsd-ports-gnome-2a894ea487d890f27a87f4a31182954e3b7b8e3d.tar.zst
freebsd-ports-gnome-2a894ea487d890f27a87f4a31182954e3b7b8e3d.zip
new port: net/danamics 1.1
The DaNAMiCS project is to build a Petri Net editor that allows for both correctness and performance analysis. The performance analysis will be performed by Steady State anaylsis and by simulation. DaNAMiCS will also include support for Inhibitor Arcs. This will allow for priorities to be modelled and will increase the modelling power of Petri Nets to that of Turing Machines. DaNAMiCS will also enable the user to model with Coloured Tokens, which greatly reduce the complexity of the resultant nets. WWW: http://www.cs.uct.ac.za/Research/DNA/DaNAMiCS/ PR: ports/50108 Submitted by: Matthew West <mwest@uct.ac.za>
-rw-r--r--net/Makefile1
-rw-r--r--net/danamics/Makefile43
-rw-r--r--net/danamics/distinfo1
-rw-r--r--net/danamics/files/danamics.sh3
-rw-r--r--net/danamics/pkg-descr14
5 files changed, 62 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5e11d01c3c45..79192e88c147 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -84,6 +84,7 @@
SUBDIR += cvsup-without-gui
SUBDIR += cvsupit
SUBDIR += cvsync
+ SUBDIR += danamics
SUBDIR += dante
SUBDIR += darkstat
SUBDIR += datapipe
diff --git a/net/danamics/Makefile b/net/danamics/Makefile
new file mode 100644
index 000000000000..d06140b0527a
--- /dev/null
+++ b/net/danamics/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: danamics
+# Date created: 18 March 2003
+# Whom: mwest@uct.ac.za
+#
+# $FreeBSD$
+#
+
+PORTNAME= danamics
+PORTVERSION= 1.1
+CATEGORIES= net java
+MASTER_SITES= ftp://ftp.cs.uct.ac.za/pub/FreeBSD/distfiles-local/
+
+MAINTAINER= mwest@uct.ac.za
+COMMENT= Petri Net editor for correctness and performance analysis
+
+USE_JAVA= 1.1+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/DaNAMiCS
+
+.include <bsd.port.pre.mk>
+
+PLIST= ${WRKDIR}/plist
+
+SORT?= /usr/bin/sort
+
+do-install:
+ ${MKDIR} ${PREFIX}/danamics
+ ${CP} -R ${WRKSRC}/* ${PREFIX}/danamics
+
+ cd ${PREFIX}; ${FIND} danamics -type f \
+ | ${SORT} >${PLIST}
+ cd ${PREFIX}; ${FIND} danamics -type d \
+ | ${SORT} -r | ${SED} -e 's|^|@dirrm |' >>${PLIST}
+
+ ${SED} \
+ -e s,%%PREFIX%%,${PREFIX},g \
+ < ${FILESDIR}/danamics.sh > ${PREFIX}/bin/danamics; \
+ ${CHMOD} a+x ${PREFIX}/bin/danamics
+
+ ${ECHO} bin/danamics >>${PLIST}
+
+.include <bsd.port.post.mk>
diff --git a/net/danamics/distinfo b/net/danamics/distinfo
new file mode 100644
index 000000000000..b592d7b25cf7
--- /dev/null
+++ b/net/danamics/distinfo
@@ -0,0 +1 @@
+MD5 (danamics-1.1.tar.gz) = bf6926431280e313325f232808ecdada
diff --git a/net/danamics/files/danamics.sh b/net/danamics/files/danamics.sh
new file mode 100644
index 000000000000..f41814de6428
--- /dev/null
+++ b/net/danamics/files/danamics.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd %%PREFIX%%/danamics
+exec javavm -classpath DaNAMiCS.jar:swing.jar:$CLASSPATH DaNAMiCS.DFrame
diff --git a/net/danamics/pkg-descr b/net/danamics/pkg-descr
new file mode 100644
index 000000000000..47626472242d
--- /dev/null
+++ b/net/danamics/pkg-descr
@@ -0,0 +1,14 @@
+The DaNAMiCS project is to build a Petri Net editor that allows for
+both correctness and performance analysis. The performance analysis
+will be performed by Steady State anaylsis and by simulation.
+
+DaNAMiCS will also include support for Inhibitor Arcs. This will
+allow for priorities to be modelled and will increase the modelling
+power of Petri Nets to that of Turing Machines. DaNAMiCS will also
+enable the user to model with Coloured Tokens, which greatly reduce
+the complexity of the resultant nets.
+
+WWW: http://www.cs.uct.ac.za/Research/DNA/DaNAMiCS/
+
+--
+mwest@uct.ac.za