aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-11-27 18:41:41 +0800
committerpav <pav@FreeBSD.org>2006-11-27 18:41:41 +0800
commit2aa1a1543e01bf3882cfdbcc80e379ab98e56a72 (patch)
treeeef4dd5070ca4d3b3b5e265dc78cb89a1ca6d24e
parentac45af30d390fda2b8aa4d1eece3540670a6b72b (diff)
downloadfreebsd-ports-gnome-2aa1a1543e01bf3882cfdbcc80e379ab98e56a72.tar.gz
freebsd-ports-gnome-2aa1a1543e01bf3882cfdbcc80e379ab98e56a72.tar.zst
freebsd-ports-gnome-2aa1a1543e01bf3882cfdbcc80e379ab98e56a72.zip
- Fix startup crash with non-english locales
PR: ports/105906 Reported by: girgen Obtained from: graphics/gimp port
-rw-r--r--graphics/gimpshop/Makefile2
-rw-r--r--graphics/gimpshop/files/patch-plug-ins.c19
2 files changed, 20 insertions, 1 deletions
diff --git a/graphics/gimpshop/Makefile b/graphics/gimpshop/Makefile
index 24ecd9a2d9f4..3d069d563547 100644
--- a/graphics/gimpshop/Makefile
+++ b/graphics/gimpshop/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gimpshop
PORTVERSION= 2.2.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics gnome
MASTER_SITES= http://www.plasticbugs.com/blogimg/ \
http://freebsd.powered.net/distfiles/
diff --git a/graphics/gimpshop/files/patch-plug-ins.c b/graphics/gimpshop/files/patch-plug-ins.c
new file mode 100644
index 000000000000..f7650f0e0529
--- /dev/null
+++ b/graphics/gimpshop/files/patch-plug-ins.c
@@ -0,0 +1,19 @@
+--- app/plug-in/plug-ins.c.orig Wed Nov 17 15:51:50 2004
++++ app/plug-in/plug-ins.c Sun Oct 22 18:58:36 2006
+@@ -317,6 +317,8 @@
+
+ if (! gimp->no_interface)
+ {
++ gimp_menus_init (gimp, gimp->plug_in_defs, STD_PLUGINS_DOMAIN);
++
+ gimp->load_procs = g_slist_sort_with_data (gimp->load_procs,
+ plug_ins_file_proc_compare,
+ gimp);
+@@ -324,7 +326,6 @@
+ plug_ins_file_proc_compare,
+ gimp);
+
+- gimp_menus_init (gimp, gimp->plug_in_defs, STD_PLUGINS_DOMAIN);
+ }
+
+ /* build list of automatically started extensions */