aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2012-03-10 05:42:01 +0800
committerdecke <decke@FreeBSD.org>2012-03-10 05:42:01 +0800
commit2d19c4ccb309c542e9d8619de96e7c5ff0086daf (patch)
treef9cfc97558136d2c251bb9bb70357191223d9e14
parenteeba42c7b5420aea513423867e977e02c061c51c (diff)
downloadfreebsd-ports-gnome-2d19c4ccb309c542e9d8619de96e7c5ff0086daf.tar.gz
freebsd-ports-gnome-2d19c4ccb309c542e9d8619de96e7c5ff0086daf.tar.zst
freebsd-ports-gnome-2d19c4ccb309c542e9d8619de96e7c5ff0086daf.zip
- Fix compile error on recent current
include/iprt/stdint.h:162: error: 'intptr_t' has a previous declaration as 'typedef long int intptr_t' /usr/include/sys/_stdint.h:78: error: conflicting declaration 'typedef uintptr_t uintptr_t' include/iprt/stdint.h:165: error: 'uintptr_t' has a previous declaration as 'typedef long unsigned int uintptr_t' kBuild: Compiling tstAsmStructsasm - src/VBox/VMM/testcase/tstAsmStructsAsm.asm kBuild: Compiling tstGlobalConfig - src/VBox/VMM/testcase/tstGlobalConfig.cpp kmk: * [out/freebsd.amd64/release/obj/tstVMStructRC/tstVMStructRC.o] Submitted by: Tijl Coosemans <tijl@freebsd.org> Feature safe: yes
-rw-r--r--emulators/virtualbox-ose/Makefile1
-rw-r--r--emulators/virtualbox-ose/files/patch-include-iprt-types.h11
2 files changed, 12 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index a3561098ef13..223958c131c4 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -7,6 +7,7 @@
PORTNAME= virtualbox-ose
DISTVERSION= 4.1.8
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://tmp.chruetertee.ch/ \
http://freebsd.unixfreunde.de/sources/ \
diff --git a/emulators/virtualbox-ose/files/patch-include-iprt-types.h b/emulators/virtualbox-ose/files/patch-include-iprt-types.h
new file mode 100644
index 000000000000..4c2070e3bb10
--- /dev/null
+++ b/emulators/virtualbox-ose/files/patch-include-iprt-types.h
@@ -0,0 +1,11 @@
+--- include/iprt/types.h.orig 2012-03-05 10:48:48.000000000 +0100
++++ include/iprt/types.h 2012-03-05 11:21:25.000000000 +0100
+@@ -82,6 +82,8 @@
+ # include <stddef.h>
+ # define _UINT64_T_DECLARED
+ # define _INT64_T_DECLARED
++# define _UINTPTR_T_DECLARED
++# define _INTPTR_T_DECLARED
+ # include <sys/types.h>
+
+ # elif defined(RT_OS_LINUX) && defined(__KERNEL__)