aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-05 13:20:24 +0800
committermiwi <miwi@FreeBSD.org>2014-06-05 13:20:24 +0800
commit2eb2a0ba5d0def62a27521ddef2fe85cf2e3a6d9 (patch)
treec8b214e9688db4299f784dc5b13c55ee2c9c4eaf
parent28268d52a19ca55cec14cbc688c738721f20f429 (diff)
downloadfreebsd-ports-gnome-2eb2a0ba5d0def62a27521ddef2fe85cf2e3a6d9.tar.gz
freebsd-ports-gnome-2eb2a0ba5d0def62a27521ddef2fe85cf2e3a6d9.tar.zst
freebsd-ports-gnome-2eb2a0ba5d0def62a27521ddef2fe85cf2e3a6d9.zip
- Stage support
PR: 190372
-rw-r--r--www/pwebstats/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/www/pwebstats/Makefile b/www/pwebstats/Makefile
index 8930ed155efa..2610703f0a1b 100644
--- a/www/pwebstats/Makefile
+++ b/www/pwebstats/Makefile
@@ -5,7 +5,9 @@ PORTNAME= pwebstats
PORTVERSION= 1.3.8
PORTREVISION= 3
CATEGORIES= www
-MASTER_SITES= ftp://ftp.psg.com/pub/pwebstats/
+MASTER_SITES= http://www.gleeson.net/pub/pwebstats/dist/ \
+ ftp://ftp.psg.com/pub/pwebstats/ \
+ ftp://ftp.unimelb.edu.au/pub/www/tools/unix/pwebstats/
MAINTAINER= sexbear@tmu.edu.tw
COMMENT= Analyse a web server log
@@ -16,13 +18,11 @@ USES= perl5
NO_BUILD= yes
-NO_STAGE= yes
do-install:
- ${MKDIR} ${PREFIX}/etc/pwebstats/
- ${CP} -R ${WRKSRC}/* ${PREFIX}/etc/pwebstats/
- ${MV} "${PREFIX}/etc/pwebstats/templates/images/'.gif" ${PREFIX}/etc/pwebstats/templates/images/10.gif
- ${MV} "${PREFIX}/etc/pwebstats/templates/images/dates/'.gif" ${PREFIX}/etc/pwebstats/templates/images/dates/10.gif
- ${RM} ${PREFIX}/etc/pwebstats/pwebstats.orig
- @${CAT} ${PKGMESSAGE}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/pwebstats/
+ ${CP} -R ${WRKSRC}/* ${STAGEDIR}${PREFIX}/etc/pwebstats/
+ ${MV} "${STAGEDIR}${PREFIX}/etc/pwebstats/templates/images/'.gif" ${STAGEDIR}${PREFIX}/etc/pwebstats/templates/images/10.gif
+ ${MV} "${STAGEDIR}${PREFIX}/etc/pwebstats/templates/images/dates/'.gif" ${STAGEDIR}${PREFIX}/etc/pwebstats/templates/images/dates/10.gif
+ ${RM} ${STAGEDIR}${PREFIX}/etc/pwebstats/pwebstats.orig
.include <bsd.port.mk>