aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-30 20:22:14 +0800
committeredwin <edwin@FreeBSD.org>2003-09-30 20:22:14 +0800
commit2f892b8faafc65eafcda75db2ed5f640abdaed71 (patch)
tree91d0677464f0ef1388a4b12ff758a811cf1821e9
parent0adc4fad008fdc0b98769812b8c2c01704966111 (diff)
downloadfreebsd-ports-gnome-2f892b8faafc65eafcda75db2ed5f640abdaed71.tar.gz
freebsd-ports-gnome-2f892b8faafc65eafcda75db2ed5f640abdaed71.tar.zst
freebsd-ports-gnome-2f892b8faafc65eafcda75db2ed5f640abdaed71.zip
IMP3 port's dependancy test fails for cyrus-imapd22
The mail/imp3 port can be built with support for the Cyrus IMAPd The WITH_CYRUS flag specifies version 1.x (mail/cyrus) and the WITH_CYRUS_IMAPD flag specifies version 2.x (mail/cyrus-imapd). The WITH_CYRUS flag tests the existance of the installed Cyrus directory in ${LOCALBASE}. The WITH_CYRUS_IMAPD flag tests for the existance of libacap. There are actually three ports providing different subreleases of the Cyrus IMAP system version 2. The cyrus-imapd port is version 2.0.17, the cyrus-imapd2 port is 2.1.14, and the cyrus-imapd22 port is 2.2.1b. Unfortunately, 2.2.1b does not include libacap so the imp3 build failes to recognize when it is installed. Since imp3 doesn't directly use the ACAP library, and appears to work fine with cyrus-imapd22, the test should be modified. PR: ports/56120 Submitted by: Pat Lashley <patl+freebsd@volant.org> Approved by: Thierry Thomas <thierry@pompo.net> (maintainer)
-rw-r--r--mail/imp3/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/mail/imp3/Makefile b/mail/imp3/Makefile
index 4255490f5671..0d504ce324cd 100644
--- a/mail/imp3/Makefile
+++ b/mail/imp3/Makefile
@@ -192,24 +192,15 @@ pre-install:
.endif
.endif
.if !defined(WITHOUT_LDAP)
-.if exists(${LOCALBASE}/lib/libldap.so.1)
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.1"; then \
+ @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so"; then \
${ECHO_MSG} "" ; \
- ${ECHO_MSG} "Please configure PHP with OpenLDAP support." ; \
+ ${ECHO_MSG} "Please configure PHP with OpenLDAP or OpenLDAP2 support." ; \
${ECHO_MSG} "" ; \
${FALSE} ; \
fi
-.else
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libldap.so.2"; then \
- ${ECHO_MSG} "" ; \
- ${ECHO_MSG} "Please configure PHP with OpenLDAP2 support." ; \
- ${ECHO_MSG} "" ; \
- ${FALSE} ; \
- fi
-.endif
.endif
.if !defined(NOCRYPT)
- @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libmcrypt.so.8"; then \
+ @if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libmcrypt.so"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with mcrypt support." ; \
${ECHO_MSG} "" ; \
@@ -218,9 +209,9 @@ pre-install:
.endif
.if !defined(WITHOUT_SUPPORTED_DB)
@if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libmysqlclient.so"; then \
- if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libpq.so.3" ; then \
- if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libsybdb.so.1" ; then \
- if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libct.so.0" ; then \
+ if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libpq.so" ; then \
+ if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libsybdb.so" ; then \
+ if ! ${LDD} ${PHPSO} | ${GREP} -q -e "libct.so" ; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with a database support." ; \
${ECHO_MSG} "MySQL, PostgreSQL and Sybase (CTLIB or DBLIB)" ; \