aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2012-10-09 16:07:30 +0800
committerale <ale@FreeBSD.org>2012-10-09 16:07:30 +0800
commit2fdde09b3729d5990dfb651c64867efdfd579b10 (patch)
tree8bd275cdb3e2f41ce51cb3691897ce61f87432c4
parentd7930655b502552352fb522f246c628476c99bdd (diff)
downloadfreebsd-ports-gnome-2fdde09b3729d5990dfb651c64867efdfd579b10.tar.gz
freebsd-ports-gnome-2fdde09b3729d5990dfb651c64867efdfd579b10.tar.zst
freebsd-ports-gnome-2fdde09b3729d5990dfb651c64867efdfd579b10.zip
simple build tool (sbt) is a minimally intrusive
build tool for Scala projects. WWW: http://www.scala-sbt.org/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/sbt/Makefile53
-rw-r--r--devel/sbt/distinfo2
-rw-r--r--devel/sbt/files/patch-bin_sbt25
-rw-r--r--devel/sbt/files/patch-bin_sbt-launch-lib.bash11
-rw-r--r--devel/sbt/files/sbt.sh.in2
-rw-r--r--devel/sbt/pkg-descr4
7 files changed, 98 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1233c033436d..879fcf838de8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4005,6 +4005,7 @@
SUBDIR += sabre
SUBDIR += safe-iop
SUBDIR += safestr
+ SUBDIR += sbt
SUBDIR += scalatest
SUBDIR += scandoc
SUBDIR += scons
diff --git a/devel/sbt/Makefile b/devel/sbt/Makefile
new file mode 100644
index 000000000000..a2f5cecc9e29
--- /dev/null
+++ b/devel/sbt/Makefile
@@ -0,0 +1,53 @@
+# Created by: Alex Dupre <ale@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= sbt
+PORTVERSION= 0.12.1
+CATEGORIES= devel java
+MASTER_SITES= http://scalasbt.artifactoryonline.com/scalasbt/sbt-native-packages/org/scala-sbt/sbt/${PORTVERSION}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A build tool for Scala projects
+
+LICENSE= AL2
+
+OPTIONS_DEFINE= ADVANCED
+ADVANCED_DESC= Install advanced bash shell-script
+
+NO_BUILD= yes
+USE_JAVA= yes
+
+PLIST_FILES= bin/sbt \
+ %%DATADIR%%/sbt-launch.jar
+PLIST_DIRS= %%DATADIR%%
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MADVANCED}
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+
+PLIST_FILES+= %%DATADIR%%/sbt \
+ %%DATADIR%%/sbt-launch-lib.bash
+.else
+SUB_FILES= sbt.sh
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|g" \
+ ${WRKSRC}/bin/sbt ${WRKSRC}/bin/sbt-launch-lib.bash
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/bin/sbt-launch.jar ${DATADIR}
+.if ${PORT_OPTIONS:MADVANCED}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/sbt ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/sbt-launch-lib.bash ${DATADIR}
+ ${LN} -s ${DATADIR}/sbt ${PREFIX}/bin/
+.else
+ ${INSTALL_SCRIPT} ${WRKDIR}/sbt.sh ${PREFIX}/bin/sbt
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/sbt/distinfo b/devel/sbt/distinfo
new file mode 100644
index 000000000000..5e42e2e02ce3
--- /dev/null
+++ b/devel/sbt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sbt/0.12.1/sbt.tgz) = bb446337ca8c988bdf9815748375466746b2d1a5634268188e22a3890f393335
+SIZE (sbt/0.12.1/sbt.tgz) = 1083996
diff --git a/devel/sbt/files/patch-bin_sbt b/devel/sbt/files/patch-bin_sbt
new file mode 100644
index 000000000000..82f459f49e93
--- /dev/null
+++ b/devel/sbt/files/patch-bin_sbt
@@ -0,0 +1,25 @@
+--- bin/sbt.orig 2012-09-18 09:35:52.000000000 +0200
++++ bin/sbt 2012-09-18 09:37:14.000000000 +0200
+@@ -1,11 +1,11 @@
+ #!/usr/bin/env bash
+
+-. $(dirname $0)/sbt-launch-lib.bash
++. %%PREFIX%%/share/sbt/sbt-launch-lib.bash
+
+
+ declare -r noshare_opts="-Dsbt.global.base=project/.sbtboot -Dsbt.boot.directory=project/.boot -Dsbt.ivy.home=project/.ivy"
+ declare -r sbt_opts_file=".sbtopts"
+-declare -r etc_sbt_opts_file="/etc/sbt/sbtopts"
++declare -r etc_sbt_opts_file="%%PREFIX%%/etc/sbt/sbtopts"
+
+ usage() {
+ cat <<EOM
+@@ -39,7 +39,7 @@
+ SBT_OPTS environment variable, if unset uses "$default_sbt_opts"
+ .sbtopts if this file exists in the current directory, it is
+ prepended to the runner args
+- /etc/sbt/sbtopts if this file exists, it is prepended to the runner args
++ %%PREFIX%%/etc/sbt/sbtopts if this file exists, it is prepended to the runner args
+ -Dkey=val pass -Dkey=val directly to the java runtime
+ -J-X pass option -X directly to the java runtime
+ (-J is stripped)
diff --git a/devel/sbt/files/patch-bin_sbt-launch-lib.bash b/devel/sbt/files/patch-bin_sbt-launch-lib.bash
new file mode 100644
index 000000000000..c8a3dafb51c4
--- /dev/null
+++ b/devel/sbt/files/patch-bin_sbt-launch-lib.bash
@@ -0,0 +1,11 @@
+--- bin/sbt-launch-lib.bash.orig 2012-09-18 09:35:57.000000000 +0200
++++ bin/sbt-launch-lib.bash 2012-09-18 09:37:53.000000000 +0200
+@@ -29,7 +29,7 @@
+ }
+
+ jar_file () {
+- echo "$(dirname $0)/sbt-launch.jar"
++ echo "%%PREFIX%%/share/sbt/sbt-launch.jar"
+ }
+
+ acquire_sbt_jar () {
diff --git a/devel/sbt/files/sbt.sh.in b/devel/sbt/files/sbt.sh.in
new file mode 100644
index 000000000000..70f9dc2a7449
--- /dev/null
+++ b/devel/sbt/files/sbt.sh.in
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec "%%LOCALBASE%%/bin/java" -Xms512M -Xmx1536M -Xss1M -XX:+CMSClassUnloadingEnabled -XX:MaxPermSize=384M -jar "%%DATADIR%%/sbt-launch.jar" "$@"
diff --git a/devel/sbt/pkg-descr b/devel/sbt/pkg-descr
new file mode 100644
index 000000000000..8b1d9f6b74ef
--- /dev/null
+++ b/devel/sbt/pkg-descr
@@ -0,0 +1,4 @@
+simple build tool (sbt) is a minimally intrusive
+build tool for Scala projects.
+
+WWW: http://www.scala-sbt.org/