aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenner <fenner@FreeBSD.org>2006-02-19 02:13:08 +0800
committerfenner <fenner@FreeBSD.org>2006-02-19 02:13:08 +0800
commit2feab99f3b482ad2b05ba8bf9e45c96078915c97 (patch)
tree1d45bf101ff96731c689da38439083ffa714cdbb
parentd43b00986077c723bfce056e845b380668c0209d (diff)
downloadfreebsd-ports-gnome-2feab99f3b482ad2b05ba8bf9e45c96078915c97.tar.gz
freebsd-ports-gnome-2feab99f3b482ad2b05ba8bf9e45c96078915c97.tar.zst
freebsd-ports-gnome-2feab99f3b482ad2b05ba8bf9e45c96078915c97.zip
Net::NBName is a class that allows you to perform simple NetBIOS Name
Service Requests in your Perl code. It performs these NetBIOS operations over TCP/IP using Perl's built-in socket support. WWW: http://search.cpan.org/dist/Net-NBName/
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-NBName/Makefile20
-rw-r--r--net/p5-Net-NBName/distinfo3
-rw-r--r--net/p5-Net-NBName/pkg-descr5
-rw-r--r--net/p5-Net-NBName/pkg-plist15
5 files changed, 44 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 87b2f3444572..ffacc822d413 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -403,6 +403,7 @@
SUBDIR += p5-Net-HL7
SUBDIR += p5-Net-Ident
SUBDIR += p5-Net-MovableType
+ SUBDIR += p5-Net-NBName
SUBDIR += p5-Net-OpenDHT
SUBDIR += p5-Net-Packet
SUBDIR += p5-Net-ParseWhois
diff --git a/net/p5-Net-NBName/Makefile b/net/p5-Net-NBName/Makefile
new file mode 100644
index 000000000000..50ed4a3b00cb
--- /dev/null
+++ b/net/p5-Net-NBName/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: p5-Net-NBName
+# Date created: 18 Feb 2006
+# Whom: Bill Fenner <fenner@FreeBSD.Org>
+#
+# $FreeBSD$
+
+PORTNAME= Net-NBName
+PORTVERSION= 0.25
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+
+MAINTAINER= fenner@FreeBSD.Org
+COMMENT= Performs simple NetBIOS Name Service Requests
+
+PERL_CONFIGURE= YES
+MAN3= Net::NBName.3 Net::NBName::NameQuery.3 Net::NBName::NameQuery::RR.3 \
+ Net::NBName::NodeStatus.3 Net::NBName::NodeStatus::RR.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-NBName/distinfo b/net/p5-Net-NBName/distinfo
new file mode 100644
index 000000000000..aa0c48f0d531
--- /dev/null
+++ b/net/p5-Net-NBName/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-NBName-0.25.tar.gz) = e059e2a368743574bb0eea770409c2f6
+SHA256 (Net-NBName-0.25.tar.gz) = 54f6b428a0d6c397df43696783a19be9e9ab7a3673d4534a4560967289718fea
+SIZE (Net-NBName-0.25.tar.gz) = 8644
diff --git a/net/p5-Net-NBName/pkg-descr b/net/p5-Net-NBName/pkg-descr
new file mode 100644
index 000000000000..ccca2c9b75e7
--- /dev/null
+++ b/net/p5-Net-NBName/pkg-descr
@@ -0,0 +1,5 @@
+Net::NBName is a class that allows you to perform simple NetBIOS Name
+Service Requests in your Perl code. It performs these NetBIOS operations over
+TCP/IP using Perl's built-in socket support.
+
+WWW: http://search.cpan.org/dist/Net-NBName/
diff --git a/net/p5-Net-NBName/pkg-plist b/net/p5-Net-NBName/pkg-plist
new file mode 100644
index 000000000000..50738302e514
--- /dev/null
+++ b/net/p5-Net-NBName/pkg-plist
@@ -0,0 +1,15 @@
+bin/namequery.pl
+bin/nodescan.pl
+bin/nodestat.pl
+%%SITE_PERL%%/Net/NBName.pm
+%%SITE_PERL%%/Net/NBName/NameQuery.pm
+%%SITE_PERL%%/Net/NBName/NodeStatus.pm
+%%SITE_PERL%%/Net/NBName/NameQuery/RR.pm
+%%SITE_PERL%%/Net/NBName/NodeStatus/RR.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/NBName/.packlist
+@dirrm %%SITE_PERL%%/Net/NBName/NameQuery
+@dirrm %%SITE_PERL%%/Net/NBName/NodeStatus
+@dirrm %%SITE_PERL%%/Net/NBName
+@dirrmtry %%SITE_PERL%%/Net
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/NBName
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net