aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2009-12-13 16:39:46 +0800
committerale <ale@FreeBSD.org>2009-12-13 16:39:46 +0800
commit30c42e616d6bc067723229671eff8eb6f4fe082a (patch)
treefd2dda1deea0a854a07e042c7d7d58a96fc1c1df
parent31feb86f8df0da92e19e5f1acc08372a045f714c (diff)
downloadfreebsd-ports-gnome-30c42e616d6bc067723229671eff8eb6f4fe082a.tar.gz
freebsd-ports-gnome-30c42e616d6bc067723229671eff8eb6f4fe082a.tar.zst
freebsd-ports-gnome-30c42e616d6bc067723229671eff8eb6f4fe082a.zip
Remove unneeded dependencies and don't link to libthr.
Approved by: maintainer
-rw-r--r--databases/unixODBC/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/databases/unixODBC/Makefile b/databases/unixODBC/Makefile
index c08803dc7011..dad86cba91f6 100644
--- a/databases/unixODBC/Makefile
+++ b/databases/unixODBC/Makefile
@@ -7,7 +7,7 @@
PORTNAME= unixODBC
PORTVERSION= 2.2.14
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://www.unixodbc.org/
@@ -16,9 +16,8 @@ COMMENT= ODBC library suite for Unix
CONFLICTS= libiodbc-[0-9]*
-USE_GNOME= gnomehack gnometarget
USE_ICONV= yes
-USE_AUTOTOOLS= libtool:22
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static --enable-shared \
--with-libiconv-prefix=${LOCALBASE}
USE_LDCONFIG= yes
@@ -32,8 +31,8 @@ CONFIGURE_ENV= MOC="${MOC}" \
QTINC="${QT_PREFIX}/include" \
QTLIB="${QT_PREFIX}/lib" \
USER_INCLUDES="${QTCPPFLAGS}" \
- USER_LDFLAGS="${QTCFGLIBS}"
-CONFIGURE_ENV+= QTMAX=030400
+ USER_LDFLAGS="${QTCFGLIBS}" \
+ QTMAX=030400
CONFIGURE_ARGS+=--enable-gui
PLIST_SUB= GUI:=""
.else
@@ -41,13 +40,9 @@ CONFIGURE_ARGS+=--disable-gui
PLIST_SUB= GUI:="@comment "
.endif
-.if !defined(WITHOUT_THREADS) || defined(WITH_GUI)
-CONFIGURE_ARGS+=--enable-threads=yes
-.else
-CONFIGURE_ARGS+=--enable-threads=no
-.endif
-
post-patch:
+ @${REINPLACE_CMD} 's,$$LIBS $$THREADLIB,$$LIBS,;s,$$CFLAGS -pthread,$$CFLAGS,' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's,@MSQL_TRUE@lib_LTLIBRARIES,#&,' \
${WRKSRC}/Drivers/MiniSQL/Makefile.in