aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-04-13 19:41:47 +0800
committermarino <marino@FreeBSD.org>2014-04-13 19:41:47 +0800
commit30f411a729216b5a4d7733a4a22e7e2dd6a15ac4 (patch)
tree2a52bde0d754639e89c73477398d81d599ad823c
parente10f592f37aa6f02e7f5d0e6920801c5a0e1107a (diff)
downloadfreebsd-ports-gnome-30f411a729216b5a4d7733a4a22e7e2dd6a15ac4.tar.gz
freebsd-ports-gnome-30f411a729216b5a4d7733a4a22e7e2dd6a15ac4.tar.zst
freebsd-ports-gnome-30f411a729216b5a4d7733a4a22e7e2dd6a15ac4.zip
www/aws: Fix usage of aws in jailed environment
AWS has a sanity check that assumes that binding to the standard loopback address of 127.0.0.1 is always possible, but this is not a good assumption inside a FreeBSD jail. The result is that connection is success because it adjusts the 127.0.0.1 address correctly on the fly, but the sanity check is no longer valid. The provided patch changes the sanity check to get the address rather than assuming 127.0.0.1. PR: ports/188342 submitted by: Natacha Porte Approved by: maintainer (myself)
-rw-r--r--www/aws/Makefile7
-rw-r--r--www/aws/files/patch-src_core_aws-net.adb10
2 files changed, 13 insertions, 4 deletions
diff --git a/www/aws/Makefile b/www/aws/Makefile
index d670e0789a2c..9f47cc213ec6 100644
--- a/www/aws/Makefile
+++ b/www/aws/Makefile
@@ -3,7 +3,7 @@
PORTNAME= aws
PORTVERSION= 3.1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://downloads.dragonlace.net/src/
@@ -13,15 +13,14 @@ COMMENT= Adacore Ada Web Server and framework
LICENSE= GPLv3 GPLv3RLE
LICENSE_COMB= multi
-BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
+BUILD_DEPENDS= gprbuild:${PORTSDIR}/devel/gprbuild \
xmlada>=3.2:${PORTSDIR}/textproc/xmlada \
gnatpython>=20101207:${PORTSDIR}/devel/gnatpython
USE_PYTHON= yes
-USE_BZIP2= yes
GNU_CONFIGURE= yes
NO_MTREE= yes
-USES= ada gmake
+USES= ada gmake tar:bzip2
DOTBUILD= release
ADDL_RPATH= ${LOCALBASE}/lib:${LOCALBASE}/lib/aws/native/relocatable
diff --git a/www/aws/files/patch-src_core_aws-net.adb b/www/aws/files/patch-src_core_aws-net.adb
new file mode 100644
index 000000000000..a0623f6374e0
--- /dev/null
+++ b/www/aws/files/patch-src_core_aws-net.adb
@@ -0,0 +1,10 @@
+--- src/core/aws-net.adb.orig 2014-04-03 07:44:04.691630539 +0200
++++ src/core/aws-net.adb 2014-04-03 15:48:00.868957657 +0200
+@@ -439,7 +439,7 @@
+
+ -- to be shure that it is S1 and S2 connected together
+
+- exit when Peer_Addr (STC (S2)) = Local_Host
++ exit when Peer_Addr (STC (S2)) = Get_Addr (STC (S1))
+ and then Peer_Port (STC (S2)) = Get_Port (STC (S1))
+ and then Peer_Port (STC (S1)) = Get_Port (STC (S2));