aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-06-22 10:38:31 +0800
committerswills <swills@FreeBSD.org>2013-06-22 10:38:31 +0800
commit31d65354b129351e88d821d322f0c6278337bd45 (patch)
tree14396e225b79c2d1ead71ad1ea7f5db8004992b3
parentf369f2ea56f3501a5f882cecf4663213f9aad271 (diff)
downloadfreebsd-ports-gnome-31d65354b129351e88d821d322f0c6278337bd45.tar.gz
freebsd-ports-gnome-31d65354b129351e88d821d322f0c6278337bd45.tar.zst
freebsd-ports-gnome-31d65354b129351e88d821d322f0c6278337bd45.zip
The Hashery is a tight collection of Hash-like classes. Included among its many
offerings are the auto-sorting Dictionary class, the efficient LRUHash, the flexible OpenHash and the convenient KeyHash. Nearly every class is a subclass of the CRUDHash which defines a CRUD model on top of Ruby's standard Hash making it a snap to subclass and augment to fit any specific use case. WWW: http://rubyworks.github.com/hashery
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-hashery/Makefile16
-rw-r--r--devel/rubygem-hashery/distinfo2
-rw-r--r--devel/rubygem-hashery/pkg-descr7
4 files changed, 26 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f18f8edfa50f..bc1189e1965c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4069,6 +4069,7 @@
SUBDIR += rubygem-glib2
SUBDIR += rubygem-gobject-introspection
SUBDIR += rubygem-grit
+ SUBDIR += rubygem-hashery
SUBDIR += rubygem-hashie
SUBDIR += rubygem-highline
SUBDIR += rubygem-hike
diff --git a/devel/rubygem-hashery/Makefile b/devel/rubygem-hashery/Makefile
new file mode 100644
index 000000000000..ec9a053bb33c
--- /dev/null
+++ b/devel/rubygem-hashery/Makefile
@@ -0,0 +1,16 @@
+# Created by: Steve Wills <swills@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hashery
+PORTVERSION= 2.1.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Hashery is a tight collection of Hash-like classes
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-hashery/distinfo b/devel/rubygem-hashery/distinfo
new file mode 100644
index 000000000000..29146a91277f
--- /dev/null
+++ b/devel/rubygem-hashery/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/hashery-2.1.0.gem) = d7e079b0da3f3e62c085c0b7b8f27d994cd4c16710f198a2ad98e7a95cf13b27
+SIZE (rubygem/hashery-2.1.0.gem) = 37888
diff --git a/devel/rubygem-hashery/pkg-descr b/devel/rubygem-hashery/pkg-descr
new file mode 100644
index 000000000000..3041cd6fae16
--- /dev/null
+++ b/devel/rubygem-hashery/pkg-descr
@@ -0,0 +1,7 @@
+The Hashery is a tight collection of Hash-like classes. Included among its many
+offerings are the auto-sorting Dictionary class, the efficient LRUHash, the
+flexible OpenHash and the convenient KeyHash. Nearly every class is a subclass
+of the CRUDHash which defines a CRUD model on top of Ruby's standard Hash
+making it a snap to subclass and augment to fit any specific use case.
+
+WWW: http://rubyworks.github.com/hashery