aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjdp <jdp@FreeBSD.org>2001-05-27 04:37:10 +0800
committerjdp <jdp@FreeBSD.org>2001-05-27 04:37:10 +0800
commit323f1cae4292b7fd608921056633662fa0cedcbb (patch)
tree39f0df14fcca05c867b0940304f631f3f2f0bbce
parente022d7b8caceb9e98396283cf9d7cf90d6eb3640 (diff)
downloadfreebsd-ports-gnome-323f1cae4292b7fd608921056633662fa0cedcbb.tar.gz
freebsd-ports-gnome-323f1cae4292b7fd608921056633662fa0cedcbb.tar.zst
freebsd-ports-gnome-323f1cae4292b7fd608921056633662fa0cedcbb.zip
If PACKAGE_BUILDING is defined, link statically and disable the
RUN_DEPENDS. This makes the package completely stand-alone; it will work without Modula-3 being installed. This should make it practical to eliminate the cvsup-bin and cvsupd-bin ports entirely. Note, this change applies to the cvsup-devel port too, since it shares this Makefile.
-rw-r--r--net/cvsup/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/net/cvsup/Makefile b/net/cvsup/Makefile
index ed5b6a34c571..e54f6754af4e 100644
--- a/net/cvsup/Makefile
+++ b/net/cvsup/Makefile
@@ -14,14 +14,22 @@ MASTER_SITES?= ftp://ftp3.freebsd.org/pub/FreeBSD/development/CVSup/sources/ \
MAINTAINER= jdp@FreeBSD.org
+.ifdef PACKAGE_BUILDING
+STATIC= yes
+.endif
+
.ifdef WITHOUT_X11
M3FLAGS+= -DNOGUI
BUILD_DEPENDS= ${L1}libm3tcp${L2}:${PORTSDIR}/lang/pm3-net
+.ifndef STATIC
RUN_DEPENDS= ${L1}libm3tcp${L2}:${PORTSDIR}/lang/pm3-net
+.endif
.else
BUILD_DEPENDS= ${L1}libm3formsvbt${L2}:${PORTSDIR}/lang/pm3-forms
+.ifndef STATIC
RUN_DEPENDS= ${L1}libm3formsvbt${L2}:${PORTSDIR}/lang/pm3-forms
.endif
+.endif
MAKE_ARGS+= PREFIX=${PREFIX} M3FLAGS="${M3FLAGS}"
MAN1= cvpasswd.1 cvsup.1
@@ -30,8 +38,9 @@ MAN8= cvsupd.8
L1= ${PREFIX}/lib/m3/${TARGET}/
SOVERSION= 7
-# To link the programs statically:
-#M3FLAGS+= -DSTATIC
+.ifdef STATIC
+M3FLAGS+= -DSTATIC
+.endif
.include <bsd.port.pre.mk>