aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordaichi <daichi@FreeBSD.org>2003-08-06 18:39:04 +0800
committerdaichi <daichi@FreeBSD.org>2003-08-06 18:39:04 +0800
commit32593563a2e44178635b14f8a55e20551c8f7ddd (patch)
tree29ea127793fd1a81d59d3a7357c209b50db71085
parentd3b832d9401a54236a373c8d92205fbb89060636 (diff)
downloadfreebsd-ports-gnome-32593563a2e44178635b14f8a55e20551c8f7ddd.tar.gz
freebsd-ports-gnome-32593563a2e44178635b14f8a55e20551c8f7ddd.tar.zst
freebsd-ports-gnome-32593563a2e44178635b14f8a55e20551c8f7ddd.zip
fix security/py-m2crypto:
- use PYTHON_INCLUDEDIR instead of PYTHON_VERSION Pointed out by: Hye-Shik Chang <perky@i18n.org>
-rw-r--r--security/py-m2crypto/Makefile2
-rw-r--r--security/py-m2crypto/files/patch-SWIG::Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index c6e982efce9a..9bdc072f5f1c 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -28,7 +28,7 @@ USE_REINPLACE= yes
PINSTALL_PLIST= ${WRKDIR}/pinstall-plist
post-patch:
- ${REINPLACE_CMD} "s/PYTHON_VERSION/${PYTHON_VERSION}/" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} "s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|" ${WRKSRC}/Makefile
post-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/../M2Crypto
diff --git a/security/py-m2crypto/files/patch-SWIG::Makefile b/security/py-m2crypto/files/patch-SWIG::Makefile
index e6d34ff9d941..a51b1c11d3ab 100644
--- a/security/py-m2crypto/files/patch-SWIG::Makefile
+++ b/security/py-m2crypto/files/patch-SWIG::Makefile
@@ -6,7 +6,7 @@
LIBS = -L/usr/local/lib -lssl -lcrypto
-PYVER = 2.2
-PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
-+PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/PYTHON_VERSION \
++PYINCLUDE = -DHAVE_CONFIG_H -I%%PYTHON_INCLUDEDIR%% \
-I/usr/local/lib/python$(PYVER)/config
PYLIB = /usr/local/lib/python$(PYVER)/config