aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-02-27 10:01:30 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-02-27 10:01:30 +0800
commit32624ac527740a052396c69f34f3912900fb5d5e (patch)
tree6d25fffc42e1fafb9e86052485f4bb4095bb1f5a
parent59bbf594d21d94d640d7304a3e434dd2a54c1f32 (diff)
downloadfreebsd-ports-gnome-32624ac527740a052396c69f34f3912900fb5d5e.tar.gz
freebsd-ports-gnome-32624ac527740a052396c69f34f3912900fb5d5e.tar.zst
freebsd-ports-gnome-32624ac527740a052396c69f34f3912900fb5d5e.zip
List changes for CPAN modules.
WWW: http://search.cpan.org/dist/cpan-listchanges/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-cpan-listchanges/Makefile32
-rw-r--r--devel/p5-cpan-listchanges/distinfo2
-rw-r--r--devel/p5-cpan-listchanges/pkg-descr3
-rw-r--r--devel/p5-cpan-listchanges/pkg-plist6
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3728ba07e895..519a6c6353bb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2475,6 +2475,7 @@
SUBDIR += p5-constant-boolean
SUBDIR += p5-constant-def
SUBDIR += p5-constant-lexical
+ SUBDIR += p5-cpan-listchanges
SUBDIR += p5-doxygenfilter
SUBDIR += p5-enum
SUBDIR += p5-ex-lib
diff --git a/devel/p5-cpan-listchanges/Makefile b/devel/p5-cpan-listchanges/Makefile
new file mode 100644
index 000000000000..f1abc27df392
--- /dev/null
+++ b/devel/p5-cpan-listchanges/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: cpan::listchanges
+# Date created: 27 Feb 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cpan-listchanges
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/MI/MIYAGAWA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to list changes for CPAN modules
+
+RUN_DEPENDS= \
+ p5-Algorithm-Diff>0:${PORTSDIR}/devel/p5-Algorithm-Diff \
+ p5-CPAN-DistnameInfo>0:${PORTSDIR}/devel/p5-CPAN-DistnameInfo \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-Module-Metadata>0:${PORTSDIR}/devel/p5-Module-Metadata \
+ p5-Try-Tiny>0:${PORTSDIR}/lang/p5-Try-Tiny \
+ p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= cpan-listchanges.1
+MAN3= App::cpanlistchanges.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-cpan-listchanges/distinfo b/devel/p5-cpan-listchanges/distinfo
new file mode 100644
index 000000000000..d8d1ee69b029
--- /dev/null
+++ b/devel/p5-cpan-listchanges/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cpan-listchanges-0.05.tar.gz) = 37ad78fb02e2d8d0a2116a3374ad6ad97d735401afe71734783e1cd3eaba4391
+SIZE (cpan-listchanges-0.05.tar.gz) = 20869
diff --git a/devel/p5-cpan-listchanges/pkg-descr b/devel/p5-cpan-listchanges/pkg-descr
new file mode 100644
index 000000000000..ec94b5bbbe7c
--- /dev/null
+++ b/devel/p5-cpan-listchanges/pkg-descr
@@ -0,0 +1,3 @@
+List changes for CPAN modules.
+
+WWW: http://search.cpan.org/dist/cpan-listchanges/
diff --git a/devel/p5-cpan-listchanges/pkg-plist b/devel/p5-cpan-listchanges/pkg-plist
new file mode 100644
index 000000000000..7bc2e613aedc
--- /dev/null
+++ b/devel/p5-cpan-listchanges/pkg-plist
@@ -0,0 +1,6 @@
+bin/cpan-listchanges
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/cpan/listchanges/.packlist
+%%SITE_PERL%%/App/cpanlistchanges.pm
+@dirrmtry %%SITE_PERL%%/App
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/cpan/listchanges
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/cpan