aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-10 05:46:18 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-10 05:46:18 +0800
commit32ff8155e9f1efb3ef6b3f24f2640eb17e4f21af (patch)
tree2852edb98c302597da4da2fdd0eed3189eeb9abb
parent37dbcce9ddb12de516365f25e21e809c7f2d1119 (diff)
downloadfreebsd-ports-gnome-32ff8155e9f1efb3ef6b3f24f2640eb17e4f21af.tar.gz
freebsd-ports-gnome-32ff8155e9f1efb3ef6b3f24f2640eb17e4f21af.tar.zst
freebsd-ports-gnome-32ff8155e9f1efb3ef6b3f24f2640eb17e4f21af.zip
- Mark some ruby* and rubygem* broken with ruby 1.9
With Hat: ruby@ Sponsored by: RideCharge Inc. / TaxiMagic
-rw-r--r--comms/ruby-termios/Makefile4
-rw-r--r--devel/rubygem-linecache/Makefile6
-rw-r--r--devel/rubygem-ncurses/Makefile7
-rw-r--r--devel/rubygem-rcov/Makefile7
-rw-r--r--devel/rubygem-zoom/Makefile6
-rw-r--r--graphics/ruby-gd/Makefile4
-rw-r--r--graphics/rubygem-objectdetect/Makefile4
-rw-r--r--mail/rubygem-tmail/Makefile6
-rw-r--r--misc/rubygem-ohcount/Makefile7
-rw-r--r--textproc/rubygem-ferret/Makefile6
-rw-r--r--textproc/rubygem-formosa/Makefile6
-rw-r--r--www/rubygem-mongrel/Makefile6
12 files changed, 60 insertions, 9 deletions
diff --git a/comms/ruby-termios/Makefile b/comms/ruby-termios/Makefile
index 7344cd3a2b9c..2826a7274ba6 100644
--- a/comms/ruby-termios/Makefile
+++ b/comms/ruby-termios/Makefile
@@ -17,6 +17,10 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface to termios
+.if ${RUBY_VER} = 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+
MAKE_JOBS_UNSAFE= yes
USE_RUBY= yes
diff --git a/devel/rubygem-linecache/Makefile b/devel/rubygem-linecache/Makefile
index 2ac22da37e7c..ee15f04e10cb 100644
--- a/devel/rubygem-linecache/Makefile
+++ b/devel/rubygem-linecache/Makefile
@@ -16,4 +16,8 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not work with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/rubygem-ncurses/Makefile b/devel/rubygem-ncurses/Makefile
index da276d39c3c0..730a194e3564 100644
--- a/devel/rubygem-ncurses/Makefile
+++ b/devel/rubygem-ncurses/Makefile
@@ -17,4 +17,9 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
+
diff --git a/devel/rubygem-rcov/Makefile b/devel/rubygem-rcov/Makefile
index c49371d0a49b..35d98ac40d44 100644
--- a/devel/rubygem-rcov/Makefile
+++ b/devel/rubygem-rcov/Makefile
@@ -18,4 +18,9 @@ USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/rcov
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
+
diff --git a/devel/rubygem-zoom/Makefile b/devel/rubygem-zoom/Makefile
index 3039bbc653c8..06a513ca054b 100644
--- a/devel/rubygem-zoom/Makefile
+++ b/devel/rubygem-zoom/Makefile
@@ -22,4 +22,8 @@ RUBYGEM_AUTOPLIST= yes
CONFIGURE_ARGS+= --with-opt-dir="${LOCALBASE}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not work with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index 5a6d7ffbfcbb..ca5428f111fc 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -36,6 +36,10 @@ LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not work with ruby 1.9
+.endif
+
# Hmm, GREP and TRUE seem to be defined in the bsd.port.post.mk stage.
.if exists(${LOCALBASE}/bin/gd2topng)
WITH_X11_CHECK!= ldd ${LOCALBASE}/bin/gd2topng | grep -w 'libX11\.so' || true
diff --git a/graphics/rubygem-objectdetect/Makefile b/graphics/rubygem-objectdetect/Makefile
index 83d877d77b47..162ae4157a85 100644
--- a/graphics/rubygem-objectdetect/Makefile
+++ b/graphics/rubygem-objectdetect/Makefile
@@ -22,6 +22,10 @@ RUBYGEM_AUTOPLIST= yes
.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not work with ruby 1.9
+.endif
+
.if ${OSVERSION} < 700000
BROKEN= does not compile on 6.X
.endif
diff --git a/mail/rubygem-tmail/Makefile b/mail/rubygem-tmail/Makefile
index 67843bf9b065..6e6fdf742308 100644
--- a/mail/rubygem-tmail/Makefile
+++ b/mail/rubygem-tmail/Makefile
@@ -17,4 +17,8 @@ USE_RUBYGEMS= yes
USE_RUBY_FEATURES= racc-runtime
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/misc/rubygem-ohcount/Makefile b/misc/rubygem-ohcount/Makefile
index 3ad2ca3258bb..115729c9a926 100644
--- a/misc/rubygem-ohcount/Makefile
+++ b/misc/rubygem-ohcount/Makefile
@@ -22,4 +22,9 @@ USE_RAKE= yes
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/ohcount
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
+
diff --git a/textproc/rubygem-ferret/Makefile b/textproc/rubygem-ferret/Makefile
index b5d3196dfced..a7f7c4fa2deb 100644
--- a/textproc/rubygem-ferret/Makefile
+++ b/textproc/rubygem-ferret/Makefile
@@ -19,4 +19,8 @@ USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/ferret-browser
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/textproc/rubygem-formosa/Makefile b/textproc/rubygem-formosa/Makefile
index 5a4f09ad4ca4..9eb28d34e9da 100644
--- a/textproc/rubygem-formosa/Makefile
+++ b/textproc/rubygem-formosa/Makefile
@@ -20,4 +20,8 @@ USE_RUBY= yes
USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/rubygem-mongrel/Makefile b/www/rubygem-mongrel/Makefile
index 3b45609b6c2e..32f29b70e874 100644
--- a/www/rubygem-mongrel/Makefile
+++ b/www/rubygem-mongrel/Makefile
@@ -23,4 +23,8 @@ USE_RUBYGEMS= yes
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/mongrel_rails
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.if ${RUBY_VER} == 1.9
+BROKEN= does not compile with ruby 1.9
+.endif
+.include <bsd.port.post.mk>