aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2006-09-17 16:40:33 +0800
committerale <ale@FreeBSD.org>2006-09-17 16:40:33 +0800
commit354d74ca85fba467b8e52e94b5d806bc3aca26c6 (patch)
tree6cbac206deffeaa67deaf35c0b353971b698b337
parent8b52af005584f0028ba93fac829725f171882acd (diff)
downloadfreebsd-ports-gnome-354d74ca85fba467b8e52e94b5d806bc3aca26c6.tar.gz
freebsd-ports-gnome-354d74ca85fba467b8e52e94b5d806bc3aca26c6.tar.zst
freebsd-ports-gnome-354d74ca85fba467b8e52e94b5d806bc3aca26c6.zip
The tarball has been rerolled with many post 3.3 release fixes,
so bump PORTREVISION, too.
-rw-r--r--security/cryptlib/Makefile1
-rw-r--r--security/cryptlib/distinfo6
-rw-r--r--security/cryptlib/files/patch-context_ctx_aes.c14
3 files changed, 4 insertions, 17 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index 7546bef958be..dd35a77502aa 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cryptlib
PORTVERSION= 3.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ftp://ftp.franken.de/pub/crypt/cryptlib/
DISTNAME= cl${PORTVERSION:S/.//g}
diff --git a/security/cryptlib/distinfo b/security/cryptlib/distinfo
index 102ce4c1825c..4fb87b3959eb 100644
--- a/security/cryptlib/distinfo
+++ b/security/cryptlib/distinfo
@@ -1,3 +1,3 @@
-MD5 (cl33.zip) = 50383f20dfe79c401540d083c7d52084
-SHA256 (cl33.zip) = 73d72b005aeb75da7d385e762f4e8cdcff9ac75d17152c980545a654c7d9c2f5
-SIZE (cl33.zip) = 3777255
+MD5 (cl33.zip) = 386abce26023fe1ca3bf67cb4b2d739f
+SHA256 (cl33.zip) = 8c9d784d7699456e1aff2211cde6b95962116f43a05e869a0caec21b5be754b8
+SIZE (cl33.zip) = 3779126
diff --git a/security/cryptlib/files/patch-context_ctx_aes.c b/security/cryptlib/files/patch-context_ctx_aes.c
deleted file mode 100644
index eeb5479c06ce..000000000000
--- a/security/cryptlib/files/patch-context_ctx_aes.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- context/ctx_aes.c.orig Thu Sep 14 20:29:24 2006
-+++ context/ctx_aes.c Thu Sep 14 20:30:14 2006
-@@ -67,10 +67,10 @@
- is a relatively minor overhead compared to en/decryption, so it's not a
- big problem) */
-
-+#define L_SIZE( x ) ( sizeof( x ) / sizeof( unsigned long ) )
- #if defined( USE_VIA_ACE_IF_PRESENT )
- /* Data is DWORD-aligned anyway but we need to have 16-byte alignment for
- key data in case we're using the VIA ACE */
-- #define L_SIZE( x ) ( sizeof( x ) / sizeof( unsigned long ) )
- #define KS_SIZE ( sizeof( AES_EKEY ) + sizeof( AES_DKEY ) + 24 )
- #define ALGN( x ) ( ( unsigned long )( x ) & 0xFFFFFFF0 )
- #define EKEY( x ) ( ( AES_EKEY * ) ALGN( ( ( AES_CTX * ) x )->ksch + 3 ) )