aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2007-07-07 19:52:21 +0800
committerbeech <beech@FreeBSD.org>2007-07-07 19:52:21 +0800
commit35c75ad3bdc44e43c181bb0d6a697c46cf677a02 (patch)
tree4d1b3079eb5bc1f8c405c7ac8e5b64cb1206a762
parent4b11064572a4397fae6a90a76c39cf438553118a (diff)
downloadfreebsd-ports-gnome-35c75ad3bdc44e43c181bb0d6a697c46cf677a02.tar.gz
freebsd-ports-gnome-35c75ad3bdc44e43c181bb0d6a697c46cf677a02.tar.zst
freebsd-ports-gnome-35c75ad3bdc44e43c181bb0d6a697c46cf677a02.zip
- Fix build
- Remove use_getopt_long Approved by: sat (mentor)
-rw-r--r--graphics/yafaray/Makefile1
-rw-r--r--graphics/yafaray/files/patch-src_yafraycore_ccthreads.h12
-rw-r--r--graphics/yafray/Makefile1
-rw-r--r--graphics/yafray/files/patch-src_yafraycore_ccthreads.h12
4 files changed, 24 insertions, 2 deletions
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index fdf375ad2a1f..9dda6ae36ed5 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -15,7 +15,6 @@ COMMENT= A fast XML based raytracer
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_SCONS= yes
-USE_GETOPT_LONG=yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/yafaray/files/patch-src_yafraycore_ccthreads.h b/graphics/yafaray/files/patch-src_yafraycore_ccthreads.h
new file mode 100644
index 000000000000..082cf1d35429
--- /dev/null
+++ b/graphics/yafaray/files/patch-src_yafraycore_ccthreads.h
@@ -0,0 +1,12 @@
+--- src/yafraycore/ccthreads.h.orig 2007-07-02 17:04:18.000000000 -0400
++++ src/yafraycore/ccthreads.h 2007-07-02 17:04:33.000000000 -0400
+@@ -81,9 +81,7 @@
+ virtual void body()=0;
+ void run();
+ void wait();
+- int getId() {return (int)id;};
+ pthread_t getPid() {return id;};
+- int getSelf() {return (int)pthread_self();};
+ bool isRunning()const {return running;};
+ protected:
+ bool running;
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
index fdf375ad2a1f..9dda6ae36ed5 100644
--- a/graphics/yafray/Makefile
+++ b/graphics/yafray/Makefile
@@ -15,7 +15,6 @@ COMMENT= A fast XML based raytracer
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
USE_SCONS= yes
-USE_GETOPT_LONG=yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/yafray/files/patch-src_yafraycore_ccthreads.h b/graphics/yafray/files/patch-src_yafraycore_ccthreads.h
new file mode 100644
index 000000000000..082cf1d35429
--- /dev/null
+++ b/graphics/yafray/files/patch-src_yafraycore_ccthreads.h
@@ -0,0 +1,12 @@
+--- src/yafraycore/ccthreads.h.orig 2007-07-02 17:04:18.000000000 -0400
++++ src/yafraycore/ccthreads.h 2007-07-02 17:04:33.000000000 -0400
+@@ -81,9 +81,7 @@
+ virtual void body()=0;
+ void run();
+ void wait();
+- int getId() {return (int)id;};
+ pthread_t getPid() {return id;};
+- int getSelf() {return (int)pthread_self();};
+ bool isRunning()const {return running;};
+ protected:
+ bool running;