aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlesi <lesi@FreeBSD.org>2006-01-22 03:15:29 +0800
committerlesi <lesi@FreeBSD.org>2006-01-22 03:15:29 +0800
commit35cb70197fd7b78df8bebe081de168fd37ac796b (patch)
treeafef0a5a67f3987e353af4fa12fc92b2d43f52d4
parentf4c7557277fbe1faaa593c807aaf334131cad2bb (diff)
downloadfreebsd-ports-gnome-35cb70197fd7b78df8bebe081de168fd37ac796b.tar.gz
freebsd-ports-gnome-35cb70197fd7b78df8bebe081de168fd37ac796b.tar.zst
freebsd-ports-gnome-35cb70197fd7b78df8bebe081de168fd37ac796b.zip
Fix breakage after X.Org upgrade to 6.9:
A macro that helps gcc4 checking of sentinels was introduced in Xlib.h, Intrinsic.h and IntrinsicI.h and is defined in Xfuncproto.h. Apparently the sequence of including these X headers is not quite like this port would want it to be so the macros don't get expanded. Workaround this by adding them to CFLAGS as they would be for not-gcc4 case.
-rw-r--r--graphics/pixmap/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/graphics/pixmap/Makefile b/graphics/pixmap/Makefile
index 8edf7f1395be..b246e4560914 100644
--- a/graphics/pixmap/Makefile
+++ b/graphics/pixmap/Makefile
@@ -23,4 +23,6 @@ USE_IMAKE= yes
USE_XPM= yes
MAN1= pixmap.1
+CFLAGS+= -D_X_SENTINEL\(x\)= -D_X_ATTRIBUTE_PRINTF\(x,y\)=
+
.include <bsd.port.mk>