aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-09-03 13:16:13 +0800
committerbapt <bapt@FreeBSD.org>2014-09-03 13:16:13 +0800
commit360c6f45b25a6b859b394a23d7c55f6feaf0419f (patch)
tree049ffcb5b571194aa7324281882d2623d6a9cf5d
parente6828d6bb5c7d6843a07e468e216176eeb25cdd4 (diff)
downloadfreebsd-ports-gnome-360c6f45b25a6b859b394a23d7c55f6feaf0419f.tar.gz
freebsd-ports-gnome-360c6f45b25a6b859b394a23d7c55f6feaf0419f.tar.zst
freebsd-ports-gnome-360c6f45b25a6b859b394a23d7c55f6feaf0419f.zip
Convert rmtry into regular Keyword
Note that this allows to control when it is executed (always in post-installation) This makes @rmtry accept both absolute path and relative path (to latest prefix/cwd) While here now that it is not used, remove the old PLIST_REINPLACE macro Reviewed by: antoine Differential Revision: https://reviews.freebsd.org/D713
-rw-r--r--Keywords/rmtry.ucl11
-rw-r--r--Mk/bsd.port.mk9
2 files changed, 11 insertions, 9 deletions
diff --git a/Keywords/rmtry.ucl b/Keywords/rmtry.ucl
new file mode 100644
index 000000000000..deddce913c9f
--- /dev/null
+++ b/Keywords/rmtry.ucl
@@ -0,0 +1,11 @@
+# $FreeBSD$
+#
+# MAINTAINER: portmgr@FreeBSD.org
+actions: []
+post-deinstall: <<EOD
+ case "%@" in
+ /*) f="%@" ;;
+ *) f="%D/%@" ;;
+ esac
+ /bin/rm -f $f 2>/dev/null || /usr/bin/true
+EOD
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index adc6424ce243..f631c37b2c9b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1601,9 +1601,6 @@ SUB_LIST+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} \
PLIST_SUB_SED_MIN?= 2
PLIST_SUB_SED?= ${PLIST_SUB:C/.*=.{1,${PLIST_SUB_SED_MIN}}$//g:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
-PLIST_REINPLACE+= rmtry
-PLIST_REINPLACE_RMTRY=s!^@rmtry \(.*\)!@unexec rm -f %D/\1 2>/dev/null || true!
-
# kludge to strip trailing whitespace from CFLAGS;
# sub-configure will not # survive double space
CFLAGS:= ${CFLAGS:C/ $//}
@@ -5321,12 +5318,6 @@ generate-plist: ${WRKDIR}
@${ECHO_CMD} ${dir} | ${SED} ${PLIST_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} -e 's,^,@dirrmtry ,' >> ${TMPPLIST}
.endfor
-.for reinplace in ${PLIST_REINPLACE}
-.if defined(PLIST_REINPLACE_${reinplace:tu})
- @${SED} -i "" -e '${PLIST_REINPLACE_${reinplace:tu}}' ${TMPPLIST}
-.endif
-.endfor
-
.if defined(USE_LINUX_PREFIX)
.if defined(USE_LDCONFIG)
@${ECHO_CMD} "@exec ${LDCONFIG_CMD}" >> ${TMPPLIST}