aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-31 05:36:32 +0800
committeraaron <aaron@FreeBSD.org>2006-05-31 05:36:32 +0800
commit36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c (patch)
tree7bfb928644278a2a389330918c4f96d014450d60
parent9d4e9c55cc0d0ad838b8efb74d1d8f661529d713 (diff)
downloadfreebsd-ports-gnome-36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c.tar.gz
freebsd-ports-gnome-36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c.tar.zst
freebsd-ports-gnome-36724fe71dd7683e5b8da1f9bbe6eb0ba6df1b6c.zip
Adding port databases/p5-Data-Pageset, a module for manipulating multiple pages of returned data as well as sets of pages.
Approved by: tobez (implicit)
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Data-Pageset/Makefile31
-rw-r--r--databases/p5-Data-Pageset/distinfo2
-rw-r--r--databases/p5-Data-Pageset/pkg-descr16
-rw-r--r--databases/p5-Data-Pageset/pkg-plist5
5 files changed, 55 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 092e166d951e..687e79a09de9 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -240,6 +240,7 @@
SUBDIR += p5-DBZ_File
SUBDIR += p5-DWH_File
SUBDIR += p5-Data-Page
+ SUBDIR += p5-Data-Pageset
SUBDIR += p5-Exception-Class-DBI
SUBDIR += p5-GDBM
SUBDIR += p5-GraphViz-DBI
diff --git a/databases/p5-Data-Pageset/Makefile b/databases/p5-Data-Pageset/Makefile
new file mode 100644
index 000000000000..d7412b383c9a
--- /dev/null
+++ b/databases/p5-Data-Pageset/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Data-Pageset
+# Date created: 29 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Pageset
+PORTVERSION= 1.03
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Page numbering and page sets
+
+BUILD_DEPENDS= ${SITE_PERL}/Data/Page.pm:${PORTSDIR}/databases/p5-Data-Page
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Data::Pageset.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/databases/p5-Data-Pageset/distinfo b/databases/p5-Data-Pageset/distinfo
new file mode 100644
index 000000000000..c21af3e10b55
--- /dev/null
+++ b/databases/p5-Data-Pageset/distinfo
@@ -0,0 +1,2 @@
+MD5 (Data-Pageset-1.03.tar.gz) = 5175f54b07abf7b68740c3f452c49505
+SIZE (Data-Pageset-1.03.tar.gz) = 7035
diff --git a/databases/p5-Data-Pageset/pkg-descr b/databases/p5-Data-Pageset/pkg-descr
new file mode 100644
index 000000000000..ff6305828a70
--- /dev/null
+++ b/databases/p5-Data-Pageset/pkg-descr
@@ -0,0 +1,16 @@
+The object produced by Data::Pageset can be used to create page
+navigation, it inherits from Data::Page and has access to all methods from
+this object.
+
+In addition it also provides methods for dealing with set of pages, so
+that if there are too many pages you can easily break them into chunks for
+the user to browse through.
+
+You can even choose to view page numbers in your set in a 'sliding'
+fassion.
+
+The object can easily be passed to a templating system such as Template
+Toolkit or be used within a script.
+
+WWW: http://search.cpan.org/dist/Data-Pageset
+Author: Leo Lapworth <LLAP@cuckoo.org>
diff --git a/databases/p5-Data-Pageset/pkg-plist b/databases/p5-Data-Pageset/pkg-plist
new file mode 100644
index 000000000000..57faf9d67762
--- /dev/null
+++ b/databases/p5-Data-Pageset/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/Pageset.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Pageset/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Pageset
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data