aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2016-04-11 19:59:00 +0800
committergahr <gahr@FreeBSD.org>2016-04-11 19:59:00 +0800
commit36d26776d5c7f4e4268a8dac5e86f93a8cdcd311 (patch)
treeb8cad6d93547d2fe886d2caf0b12309d983893c8
parentad897e3ae68cb83143d2a8bf778bfb3ccfe87672 (diff)
downloadfreebsd-ports-gnome-36d26776d5c7f4e4268a8dac5e86f93a8cdcd311.tar.gz
freebsd-ports-gnome-36d26776d5c7f4e4268a8dac5e86f93a8cdcd311.tar.zst
freebsd-ports-gnome-36d26776d5c7f4e4268a8dac5e86f93a8cdcd311.zip
devel/tcloo: update to 1.0.4 (corresponds to the version in Tcl 8.6.5)
Changelog: http://core.tcl.tk/tcloo/timeline?from=release-1.0.2&to=release-1.0.4 Note that there were no meaningful changes in 1.0.3.
-rw-r--r--devel/tcloo/Makefile11
-rw-r--r--devel/tcloo/distinfo4
-rw-r--r--devel/tcloo/files/patch-Makefile.in29
3 files changed, 39 insertions, 5 deletions
diff --git a/devel/tcloo/Makefile b/devel/tcloo/Makefile
index 4f7d7eadc7a5..b4eac3c21f6e 100644
--- a/devel/tcloo/Makefile
+++ b/devel/tcloo/Makefile
@@ -2,20 +2,25 @@
# $FreeBSD$
PORTNAME= tcloo
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.4
CATEGORIES= devel
-MASTER_SITES= SF/tcl/TclOO%20Package/${PORTVERSION}/
-DISTNAME= TclOO${PORTVERSION}
+MASTER_SITES= http://core.tcl.tk/tcloo/tarball/
+DISTNAME= TclOO+Package-${FOSSIL_CHECKIN}
MAINTAINER= tcltk@FreeBSD.org
COMMENT= Implementation of TclOO for Tcl 8.5
+FOSSIL_CHECKIN= 0a6e9f1ea3
+WRKSRC= ${WRKDIR}/${DISTNAME:S/+/_/}
USES+= tcl:85
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
--exec-prefix=${PREFIX}
+CFLAGS+= -fPIC
PLIST_SUB+= PORTVERSION=${PORTVERSION}
+TEST_TARGET= test
+
.include <bsd.port.mk>
diff --git a/devel/tcloo/distinfo b/devel/tcloo/distinfo
index 6cd5d142da94..21e005507161 100644
--- a/devel/tcloo/distinfo
+++ b/devel/tcloo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (TclOO1.0.2.tar.gz) = 19265e494ecf3765fcc57744f343f27faccbc4eb66768c9c83dd1c6617022c98
-SIZE (TclOO1.0.2.tar.gz) = 235037
+SHA256 (TclOO+Package-0a6e9f1ea3.tar.gz) = 8b7e573e41037d53b5621fd7c12c21352c458dab15c2d4ca115a8216e49ffb13
+SIZE (TclOO+Package-0a6e9f1ea3.tar.gz) = 242436
diff --git a/devel/tcloo/files/patch-Makefile.in b/devel/tcloo/files/patch-Makefile.in
new file mode 100644
index 000000000000..f5bd93b8d467
--- /dev/null
+++ b/devel/tcloo/files/patch-Makefile.in
@@ -0,0 +1,29 @@
+--- Makefile.in.orig 2016-03-01 00:07:14 UTC
++++ Makefile.in
+@@ -42,7 +42,7 @@ DESTDIR =
+ INSTALL_OPTIONS =
+ INSTALL = $(SHELL) $(srcdir)/tclconfig/install-sh -c ${INSTALL_OPTIONS}
+ INSTALL_DATA_DIR = ${INSTALL} -d -m 755
+-INSTALL_PROGRAM = ${INSTALL} -m 555
++INSTALL_PROGRAM = ${INSTALL} -m 555 -s
+ INSTALL_DATA = ${INSTALL} -m 444
+ INSTALL_SCRIPT = ${INSTALL_PROGRAM}
+ INSTALL_LIBRARY = ${INSTALL_DATA}
+@@ -79,7 +79,7 @@ PKG_CFLAGS=@PKG_CFLAGS@
+ DEFS=@DEFS@ $(PKG_CFLAGS)
+ CPPFLAGS=@CPPFLAGS@
+ LIBS=@PKG_LIBS@ @LIBS@ @MATH_LIBS@
+-PKG_TEST_LIBS=-L. -lTclOOstub$(PACKAGE_VERSION)
++PKG_TEST_LIBS=${PKG_STUB_LIB_FILE}
+ AR=@AR@
+ CFLAGS=@CFLAGS@
+ CYGPATH=@CYGPATH@
+@@ -261,7 +261,7 @@ $(PKG_STUB_LIB_FILE): $(PKG_STUB_OBJECTS
+ $(PKG_TEST_LIB_FILE): $(PKG_STUB_LIB_FILE)
+ $(MAKE) PKG_TEST_LIB_FILE=dummy PKG_LIB_FILE=$(PKG_TEST_LIB_FILE) \
+ PKG_OBJECTS="$(PKG_TEST_OBJECTS)" \
+- LIBS="$(PKG_TEST_LIBS)" CFLAGS="-DUSE_TCL_STUBS -DUSE_TCLOO_STUBS" \
++ LIBS="$(PKG_TEST_LIBS)" CFLAGS="${SHLIB_CFLAGS} -DUSE_TCL_STUBS -DUSE_TCLOO_STUBS" \
+ $(PKG_TEST_LIB_FILE)
+ .c.@OBJEXT@:
+ $(COMPILE) -c `$(CYGPATH) $<` -o $@