aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-11-12 20:28:49 +0800
committerpav <pav@FreeBSD.org>2005-11-12 20:28:49 +0800
commit3701031f3241bad530e9f3e7e3cb888258941baf (patch)
tree8352671c8efdf5e3984e166093c708b71ad87db8
parent4e63485dda54288a77fb4009ae6b97a11e9cc705 (diff)
downloadfreebsd-ports-gnome-3701031f3241bad530e9f3e7e3cb888258941baf.tar.gz
freebsd-ports-gnome-3701031f3241bad530e9f3e7e3cb888258941baf.tar.zst
freebsd-ports-gnome-3701031f3241bad530e9f3e7e3cb888258941baf.zip
Network Leak Finder is a collection of small perlscripts that detects
connectivity between network segments. It is mostly useful to detect "leaks" in large organizations that have private network segments physically separated from the Internet. PR: ports/88424 Submitted by: Vaida Bogdan <vaidab@phenix.rootshell.be>
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/netleak/Makefile40
-rw-r--r--net-mgmt/netleak/distinfo3
-rw-r--r--net-mgmt/netleak/files/patch-Makefile23
-rw-r--r--net-mgmt/netleak/pkg-descr9
-rw-r--r--net-mgmt/netleak/pkg-plist4
6 files changed, 80 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index e0d77ffd3e0e..fc47550af813 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -89,6 +89,7 @@
SUBDIR += net-snmp-tkmib
SUBDIR += net-snmp4
SUBDIR += netams
+ SUBDIR += netleak
SUBDIR += netmask
SUBDIR += netmond
SUBDIR += netqc
diff --git a/net-mgmt/netleak/Makefile b/net-mgmt/netleak/Makefile
new file mode 100644
index 000000000000..7c853ffcfff8
--- /dev/null
+++ b/net-mgmt/netleak/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: netleak
+# Date created: 1 Nov 2005
+# Whom: Vaida Bogdan
+#
+# $FreeBSD$
+#
+
+PORTNAME= netleak
+PORTVERSION= 0.1a
+CATEGORIES= net-mgmt
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= vaida.bogdan@gmail.com
+COMMENT= Tool to detect connectivity between network segments
+
+RUN_DEPENDS= ${SITE_PERL}/Net/PcapUtils.pm:${PORTSDIR}/net/p5-Net-PcapUtils \
+ ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
+ ${SITE_PERL}/NetPacket/Ethernet.pm:${PORTSDIR}/net/p5-NetPacket \
+ ${SITE_PERL}/Mail/Sendmail.pm:${PORTSDIR}/mail/p5-Mail-Sendmail \
+ ${SITE_PERL}/${PERL_ARCH}/Net/RawIP.pm:${PORTSDIR}/net/p5-Net-RawIP \
+ ${SITE_PERL}/${PERL_ARCH}/IO/Interface.pm:${PORTSDIR}/net/p5-IO-Interface \
+ ${SITE_PERL}/NetAddr/IP.pm:${PORTSDIR}/net-mgmt/p5-NetAddr-IP
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_PERL5_RUN= yes
+MAN8= netleak.8 netleakd.8
+
+PORTDOCS= BUGS README TODO
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/netleak/distinfo b/net-mgmt/netleak/distinfo
new file mode 100644
index 000000000000..d544274bb9e1
--- /dev/null
+++ b/net-mgmt/netleak/distinfo
@@ -0,0 +1,3 @@
+MD5 (netleak-0.1a.tgz) = d2a4a7535c0b76ed70a68cee293d558c
+SHA256 (netleak-0.1a.tgz) = dc97597188f017613ab2b39f6c6da83a4f198d6ab814b13504c993ba1995e6d1
+SIZE (netleak-0.1a.tgz) = 18808
diff --git a/net-mgmt/netleak/files/patch-Makefile b/net-mgmt/netleak/files/patch-Makefile
new file mode 100644
index 000000000000..a128639dcc50
--- /dev/null
+++ b/net-mgmt/netleak/files/patch-Makefile
@@ -0,0 +1,23 @@
+--- Makefile.old Thu Nov 3 03:24:56 2005
++++ Makefile Thu Nov 3 03:25:22 2005
+@@ -10,15 +10,15 @@
+ @echo "type 'make uninstall' to uninstall"
+
+ install:
+- @mkdir -p $(PREFIX)/sbin
+- @mkdir -p $(PREFIX)/etc
+- @mkdir -p $(PREFIX)/share/man/man8
++# @mkdir -p $(PREFIX)/sbin
++# @mkdir -p $(PREFIX)/etc
++# @mkdir -p $(PREFIX)/man/man8
+ install netleak $(PREFIX)/sbin
+ install netleakd $(PREFIX)/sbin
+ install netleak.conf $(PREFIX)/etc
+ install netleakd.conf $(PREFIX)/etc
+- install netleak.8 $(PREFIX)/share/man/man8
+- install netleakd.8 $(PREFIX)/share/man/man8
++ install netleak.8 $(PREFIX)/man/man8
++ install netleakd.8 $(PREFIX)/man/man8
+
+ uninstall:
+ rm -f $(PREFIX)/sbin/netleak
diff --git a/net-mgmt/netleak/pkg-descr b/net-mgmt/netleak/pkg-descr
new file mode 100644
index 000000000000..591338d8b1da
--- /dev/null
+++ b/net-mgmt/netleak/pkg-descr
@@ -0,0 +1,9 @@
+Network Leak Finder is a collection of small perlscripts that detects
+connectivity between network segments. It is mostly useful to detect "leaks" in
+large organizations that have private network segments physically separated
+from the Internet.
+
+WWW: http://netleak.sourceforge.net/
+
+- Vaida Bogdan
+vaida.bogdan@gmail.com
diff --git a/net-mgmt/netleak/pkg-plist b/net-mgmt/netleak/pkg-plist
new file mode 100644
index 000000000000..074b24270c09
--- /dev/null
+++ b/net-mgmt/netleak/pkg-plist
@@ -0,0 +1,4 @@
+etc/netleak.conf
+etc/netleakd.conf
+sbin/netleak
+sbin/netleakd