aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-10-06 19:50:34 +0800
committergarga <garga@FreeBSD.org>2005-10-06 19:50:34 +0800
commit38c471b07e07eb966506e7e792eeb4ec8ab61322 (patch)
tree9a43d834df5918a3e293f9dfc38148f291391c2c
parent607417e796eb258d02d13b8fa7517da5f786e2f2 (diff)
downloadfreebsd-ports-gnome-38c471b07e07eb966506e7e792eeb4ec8ab61322.tar.gz
freebsd-ports-gnome-38c471b07e07eb966506e7e792eeb4ec8ab61322.tar.zst
freebsd-ports-gnome-38c471b07e07eb966506e7e792eeb4ec8ab61322.zip
xboxproxy is an xbox system link proxy that bridges xbox network traffic
across multiple separate networks. This allows an XBox to communicate via system link across multiple networks (eg. two people in different states). It also supports bridging of the Apple Rendezvous protocol for sharing of iTunes music shares across different Layer 3 networks.. WWW: http://www.csh.rit.edu/~psionic/projects/xboxproxy/ PR: ports/86969 Submitted by: Antony Mawer <ports@mawer.org>
-rw-r--r--net/Makefile1
-rw-r--r--net/xboxproxy/Makefile30
-rw-r--r--net/xboxproxy/distinfo2
-rw-r--r--net/xboxproxy/pkg-descr7
4 files changed, 40 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 4c588214a272..c7b86112bbe3 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -909,6 +909,7 @@
SUBDIR += xbms
SUBDIR += xbone
SUBDIR += xbone-gui
+ SUBDIR += xboxproxy
SUBDIR += xferstats
SUBDIR += xicq
SUBDIR += xipdump
diff --git a/net/xboxproxy/Makefile b/net/xboxproxy/Makefile
new file mode 100644
index 000000000000..4587e5ea1109
--- /dev/null
+++ b/net/xboxproxy/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: xboxproxy
+# Date created: 6 October 2005
+# Whom: Antony Mawer <ports@mawer.org>
+#
+# $FreeBSD$
+
+PORTNAME= xboxproxy
+PORTVERSION= 1.9
+CATEGORIES= net
+MASTER_SITES= http://www.csh.rit.edu/~psionic/projects/xboxproxy/
+DISTNAME= proxy-${PORTVERSION}
+
+MAINTAINER= ports@mawer.org
+COMMENT= A proxy for the XBox system link protocol
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=xbox
+USE_GMAKE= yes
+
+PLIST_FILES= bin/xboxproxy
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Doesn't build on FreeBSD < 5.x"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/xboxproxy/distinfo b/net/xboxproxy/distinfo
new file mode 100644
index 000000000000..95646a607a8f
--- /dev/null
+++ b/net/xboxproxy/distinfo
@@ -0,0 +1,2 @@
+MD5 (proxy-1.9.tar.gz) = ac9bbf18833959399b0214bf97899221
+SIZE (proxy-1.9.tar.gz) = 119703
diff --git a/net/xboxproxy/pkg-descr b/net/xboxproxy/pkg-descr
new file mode 100644
index 000000000000..848573631868
--- /dev/null
+++ b/net/xboxproxy/pkg-descr
@@ -0,0 +1,7 @@
+xboxproxy is an xbox system link proxy that bridges xbox network traffic
+across multiple separate networks. This allows an XBox to communicate via
+system link across multiple networks (eg. two people in different states).
+It also supports bridging of the Apple Rendezvous protocol for sharing of
+iTunes music shares across different Layer 3 networks..
+
+WWW: http://www.csh.rit.edu/~psionic/projects/xboxproxy/
exon-foundation/sol-doc@1.0.15@dexon-foundation/sol-coverage@1.0.4@dexon-foundation/sol-compiler@2.0.6@0x/monorepo-scripts@1.0.20Hsuan Lee2019-01-199-19/+19 * Update dependency packagesHsuan Lee2019-01-192336-189587/+1020 * Merge pull request #1518 from 0xProject/feature/new-ganacheLeonid Logvinov2019-01-186-521/+455 |\ | * Merge branch 'development' into feature/new-ganacheLeonid Logvinov2019-01-18;id=77b024cb6706bbe4a8cc0d45ea8589c06ec9be00'>- Remove fatal white spaces.ahze2005-07-241-1/+1 * - Add knob WITH_CDDB, adds cddb support.ahze2005-07-243-1/+23 * - Chase libversion bump in libcddbahze2005-07-241-1/+2 * Change .error to IGNORE so index building doesn't fail for unsupportedlesi2005-07-241-1/+1 * Fix package build.krion2005-07-231-4/+3 * This port is scheduled for deletion on 2005-09-22 if it is still brokenkris2005-07-233-0/+6 * Upgrade modules postfix-1.220-1, time-1.220-1.olgeni2005-07-222-2/+8 * - Update to 0.3pav2005-07-222-4/+4 * - Update to 1.2.3sergei2005-07-223-5/+4 * - Update to 2.0.2sergei2005-07-222-3/+3 * Add vttest 2005.01.07, a program to test "VT100-compatibility" ofthierry2005-07-214-0/+37 * - Update to 0.2pav2005-07-213-4/+3 * Upgrade module proftpd-1.220-1.olgeni2005-07-202-1/+4 * Update to version 0.12.2:markus2005-07-2036-1584/+506 * Update to version 0.3.2.demon2005-07-202-4/+4 * Update to a snapshot from HEAD from 2005-07-20.marcus2005-07-202-3/+3 * [1]:jylefort2005-07-206-17/+98 * - Teach eject to recognize full device node pathnames toopav2005-07-203-6/+60 * convert po files to UTF-8 if WITH_GKT2 is specified to solve problems witholiver2005-07-191-1/+10 * Update to snapshot version to support building on FreeBSD 7.0.obrien2005-07-192-5/+5 * Magic Rescue scans a block device for file types it knows how to recover andgarga2005-07-196-0/+106 * Upgrade to version 1.150.olgeni2005-07-192-3/+3 * Upgrade to version 1.220.olgeni2005-07-192-16/+5 * - Grabclement2005-07-182-2/+2 * - Fix typopav2005-07-182-0/+12 * With portmgr hat on, reset eik's ports since he has been inactive forlinimon2005-07-182-2/+2 * BROKEN: incomplete pkg-plistkris2005-07-181-0/+2 * Update to 1.2.2.perky2005-07-172-3/+3 * With TinyBSD you can create embedded systems based on FreeBSD 5.X and 6-CURRENTpav2005-07-176-0/+65 * Add p5-Unix-Mknod 0.02, perl5 module to create special files.erwin2005-07-165-0/+44 * Add p5-File-Stat-Bits 0.18, perl5 module interface to theerwin2005-07-165-0/+40 * - Update to 2.0.9sem2005-07-153-14/+3 * USB ups driver for sysutils/nutsem2005-07-143-0/+25 * SNMP ups driver for sysutils/nutsem2005-07-143-0/+25 * Slave port to sysutils/nut: the libupsclient archive and headerssem2005-07-143-0/+30 * - Update to 2.0.2sem2005-07-1412-72/+226 * Chase master sitekris2005-07-141-1/+1 * Update to 1.0 release.ale2005-07-143-14/+3 * GAG (initials, in spanish, of Graphical Boot Manager) is a Boot Managerpav2005-07-145-0/+73 * - Update to debian patch 5pav2005-07-132-4/+4 * Fix dependency on ploticus.edwin2005-07-131-1/+1 * Remove BROKEN and let pointyhat sort this out.edwin2005-07-131-2/+0 * - Chase lib version to libcdioahze2005-07-132-2/+2 * Improve battery support.novel2005-07-131-3/+26 * - Update to 1.8.2clsung2005-07-1313-138/+98 * Update to 1.5.1.novel2005-07-132-4/+4 * o Update to -> 0.75mich2005-07-125-86/+4 * Declaim responsibility for this port. I no longer have time to maintaindougb2005-07-122-2/+2 * Add rename.jylefort2005-07-125-0/+72 * o) Correct filemart -> filemarks in post-install hint section ;-)lkoeller2005-07-121-2/+2 * Mark FORBIDDEN due to security issuesniels2005-07-122-0/+4 * - Fix fetchpav2005-07-121-1/+1 * - Fix build on 4.Xpav2005-07-121-0/+19 * - Update to 1.01pav2005-07-122-3/+3 * o adopt this maintainer-less portmich2005-07-111-1/+1 * o fix build, as latest libcddb update had API changesmich2005-07-112-0/+81 * - Chase lib version in libcddb, bump PORTREVISIONahze2005-07-111-1/+2 * Remove the only listed master site because it is incorrectly specified.kris2005-07-111-1/+1 * Chase master sitekris2005-07-111-1/+1 * Resign from maintainership.marius2005-07-101-1/+1 * - Update to 2.01.01a03 (there was no public 2.01.01a02). For changes sincemarius2005-07-102-4/+4 * - Move pager ports from misc/ to sysutils/pav2005-07-105-4/+8 * Log:dinoex2005-07-101-0/+2 * Add mmore, a Motif/X file/stream viewer.pav2005-07-095-0/+33 * - Stop forcing -O, the problem was fixedpav2005-07-091-1/+0 * - Update to 2.1.15pav2005-07-094-57/+29 * Add highlnk , a tool to save disk space on hard disks by usingahze2005-07-084-0/+52 * - Fix dependenciespav2005-07-081-0/+1 * - Update to 1.6.8 that fixes some bugsnovel2005-07-086-36/+38 * Track the in-place distfile change:jylefort2005-07-082-2/+3 * - Fix SIZE line in distinfopav2005-07-071-1/+1 * Correct CATAGORIES.kwm2005-07-072-2/+2 * Update to 0.8.10.kwm2005-07-063-0/+35 * Epylog is a syslog parser which runs periodically, looks at your logs,pav2005-07-065-0/+117 * - Fix "Aborted!" messages when entering commandspav2005-07-062-0/+12 * Update description.grog2005-07-061-30/+84 * Update to new name of library.grog2005-07-061-1/+1 * Change name of the installed library. It was calledgrog2005-07-061-4/+17 * Install in ${PREFIX}, not /usr.grog2005-07-061-4/+11 * Update to 1.4.novel2005-07-062-3/+3 * Update to 2.10.2.marcus2005-07-066-76/+6 * Add pdixtract 1.5, which converts Pinnacle Disk Images (i.e. .pdi file sets)markus2005-07-054-0/+32 * fix build on sparc64.ume2005-07-051-5/+14 * Update to version 2.1grog2005-07-052-5/+5 * - Update to 1.0.0ahze2005-07-052-14/+10 * Update to safecat 1.12.roam2005-07-043-2/+14 * Fix plist.novel2005-07-042-1/+4 * - Local patch has been renamed.flz2005-07-031-78/+0 * PLOD is a tool designed to help administrators and others keep trackpav2005-07-034-0/+35 * Add ufs_copy.nobutaka2005-07-036-0/+54 * o) Forgotten to increase PORTREVISION (always the same ....)lkoeller2005-07-031-1/+1 * o) Add switch for SNMP support (ports/82765)lkoeller2005-07-033-0/+45 * Update to 1.38.novel2005-07-032-3/+3 * Do not build on FreeBSD 4.x, due to lack of uuid.h header files.rodrigc2005-07-031-1/+7 * Fix build on 4-stable.nobutaka2005-07-022-4/+14 * Update to 1.2.4.nobutaka2005-07-0211-107/+39 * Reset undeliverable maintainer address:kris2005-07-021-1/+1 * Add fatback, recover deleted files from FAT filesystems.lawrance2005-07-015-0/+61 * Update to 1.0jylefort2005-07-014-60/+12 * - Update to 1.2.1.flz2005-07-013-7/+72 * - Update to 2.0pav2005-06-305-9/+19 * Add dependency on libtool.rodrigc2005-06-301-0/+1 * - sysutils/portupgrade: add option for BDB4:daichi2005-06-292-14/+24 * Add megarc.jylefort2005-06-294-0/+51 * - Update to 1.1 [1]jylefort2005-06-294-17/+10 * Update to version 3.0.6markus2005-06-294-6/+6 * Upgrade to version 0.9.2. This adds a -I option to "portsnap update"cperciva2005-06-292-3/+3 * sysutils/topless: update to 1.46daichi2005-06-282-3/+3 * - Fix gconf/os.statvfs hack by making defining the default tmp directory as .ahze2005-06-283-14/+13 * sysutils/portupgrade: fix minor documentation issuesdaichi2005-06-274-2/+50 * Update to KDE 3.4.1lofi2005-06-266-12/+12 * From the PR, with some small mods from me:dougb2005-06-268-152/+140 * - Add support for muine audio player pluginahze2005-06-263-1/+26 * - Add sysutils/serpentineahze2005-06-266-0/+137 * - Allow the configure script to use any zlib version rather thanjylefort2005-06-253-14/+12 * Remove expired port.lawrance2005-06-255-74/+0 * utilise OPTIONSoliver2005-06-254-72/+417 * Update to version 8lawrance2005-06-253-8/+14 * Update to reflect the addition of sha256 to the RELENG_5 base system.cperciva2005-06-242-2/+2 * Update to 2.10.2.kwm2005-06-233-3/+4 * - Update to 6.1 (bump PORTEPOCH)sem2005-06-232-6/+7 * - Update to 2.0.8sem2005-06-235-31/+24 * Change maintainershipdaichi2005-06-222-2/+2 * Update to 2.01, bugfix release.danfe2005-06-222-3/+3 * New port: oak.demon2005-06-217-0/+67